Scrivener 3 compile doesn't include cover

I switch what the cover is in the cover menu and the generated epub2 does not actually show a cover in calibre. I can see the file size is larger, however. Is there some magic that has to be done to images to make the cover work in scrivener 3?

This project used to include the cover fine when it was a scrivener 1 project.

Could you post a small sample project demonstrating this problem? I cannot reproduce this in a quick test. When I supply a cover image in the compile settings and import into Calibre, I see the cover image in the quick preview frame, and also in the “Edit Metadata” pane. Furthermore the internal wiring all appears to be correct when clicking the “Edit Book” button. There is a “cover.jpg” file in the Images subfolder of the epub file, and it is linked properly in the OPF file in the two places it needs to be:

    <meta name="cover" content="cover-image"/>
    <item id="cover-image" href="images/cover.jpg" media-type="image/jpeg" properties="cover-image"/> (409.7 KB)

There is a cover.jpg in the images subfolder.
inside the OPF file:
<meta name=“cover” content=“cover-image”/>

<item id=“cover-image” href=“images/cover.jpg” media-type=“image/jpeg”/>

It’s just missing that one property at the end. That’s the only difference between what you wrote.

The version 1 scrivener generated files show a cover. I don’t see one for this small project.

The scivener 1 working epub has a cover.xhtml and a reference to it in content.opf (2.1 KB)

Ah, I see your compile settings are for ePub 2 instead of ePub 3, which probably explains the small different in syntax here.

I’m still getting a cover image when I compile that test project though. It shows up in the same two places I referred to before, as a thumbnail when the book is selected in the list, and when viewing its metadata. Additionally, if I click the Layout button in the bottom right corner of Calibre’s main window and select the “Cover Grid” view, it shows up normally along with the rest of my ebooks.

It might help to clarify where you are looking for the cover, and if you have tried these same locations I am referring to.

I can’t go to epub3 or the table of contents doesn’t show up right (see other post from yesterday). epub3 shows a double “content” heading which is not centered either.

When I open the epub2 file in calibre to read it, I expect to see the cover before the table of contents. I don’t see a cover with the test project. The version 1 generated epub shows a cover before the table of contents when reading it.

Maybe you want to include a HTML-cover on the first page of your e-book and not as a metadata field of your e-book? E-readers will recognize both, but show the HTML-cover as a normal page with only one image.

See the option at the bottom of the Compile Settings for e-books.

Scrivener Manual 23.4.5:
AddHTMLcoverpage Some ePub book readers will not discover an image that hasbeenmarkedasacovergraphicinthebook’smetadata. Forthesereaders you will need a literal page in your book that contains the graphic, like a sort of title page. They will typically look for the first graphic in the book and use that for the thumbnail, which this option will enable.

Cover page title This option is only available when the Add HTML cover page option has been enabled. You should not supply the name of your book here. Thisiswhatwillbeusedinthetableofcontentsinternally,toidentify the cover page in ebook readers that allow navigation to the cover page. The standard “Cover” has been provided as a default.


That fixed it. I feel stupid for not trying that. I saw there was the working epub had a separate xhtml for the cover. I was thinking there should be a way to generate one. The button is pretty clear that it does that.

I really wish I was as smart as I used to be three years ago. Oh well, at least I still have my genius moments.