Scrivener 3 compile -The "as is" option is inconsistent. Indents don't show on iPad and iPhone Kindle Apps.

In Scrivener 2, I could import my Word Document, and compile, into a mobi for Kindle, using the “as is” option. The result was that my Word styling would remain “as is”. My styling includes the first para without an indent, and then every para following the first para in a section, is indented. Now with Scrivener 3, I’m having difficulty understanding how the “as is” option works. When I select my whole document section my section, and select the “as is” format, and then compile, the end result is that all my second paras ands the following indents disappear when read on my iPad App, and my iPhone App, but the strange thing is the indents appear and everything looks ok on my iMac Kindle App. But on the iPhone and iPad everything is aligned to the left margin. Is there a tutorial to show how to use the “as is” formatting option. Thank you.

Since loading up this topic, and my post I’ve discovered that my problem isn’t the use of the “as is” option when compiling, It’s a lot more complicated than that. After testing my mobi file on several other devices, I’ve discovered that the indents show up on the Kindle Touch, the Kindle Fire, and the Kindle App on my iMac, however the indents disappear on the iPad and iPhone. So the MOBI file created via Scrivener 3 is correct, but unfortunately the Apple Kindle Apps are not reading the file correctly (maybe the Apps need an update, who knows).

Find out more here at topic “Formatting displayed incorrectly in Kindle KF8/Mobi files when side-loaded onto iPhone”