Scrivener 3: Starting Visible Page #s on Page 2

I’m having an issue with page numbering and a Google search has been zero help.

I’m writing a screenplay, which should look like:
Title Page (unnumbered)
1st page of screenplay (this is page #1 but the 1 should not be visible)
2nd page and beyond (these pages should have visible page numbers, starting at 2 and so on)

I cannot figure out how to skip the visible number on page one and start them on page two. Normally I wouldn’t sweat it, but I’m trying to submit something and it specifically stipulates that format. Anyone have any insight on this?

Hello steevo83. Welcome to the forum.

You’ll likely need to customize your compile settings for this. When you get to the main compile panel and select the compile format you want to use, you can then select the Plus mark along the lower-left edge of the compile panel. Then, please select Duplicate & Edit Format.

In the options that appear, please select Page Settings in the left-hand column. There, you can designate if the first page has different page numbering.

You might also benefit from watching the 4-part series titled “Getting Your Work Out” on the Mac tutorial videos.

I know you’re on a Windows PC, but the settings in Mac and Win for compile are similar enough that seeing the compile customization demonstrated on a Mac might be useful.

You can also look over the sections in the Interactive Tutorial that cover the compile process, as well as Chapters 23 and 24 in the Manual. The Tutorial and manual are both available via Scrivener’s Help menu.

Then I believe you’d have to make your title page be “front matter” so that it doesn’t get counted in the page numbers.
Inked2022-03-25 12_29_11-Window_LI

Exactly so. Thank you both!

Glad it was a lot simpler than I was making it.

Point of clarification. It looks like if I set it up the way described and include the Title Page as front matter, it still counts that as page 1 if I have ‘Page numbers count first pages’ checked (even though it doesn’t show the number until the page specified). So if I had ‘Page numbers count first pages’ on it would be one ahead of where it should’ve been and if i had it off, it’d be one behind since seemingly it’ll either count the front matter as the first page and include it or not count the front matter’s first page and the body’s first page and exclude them both. I hope that makes sense.

I fixed this by converting the Front Matter and Script to PDFs separately and then combining them in Adobe, though if anyone has a better, in-Scrivener fix for this, I’d be grateful.

I’ve never used it yet, but perhaps you had your front page inside the “draft” folder, thus causing it to be counted.

Whatever your front matter is, it should rest in a folder outside of the “draft” folder.

Otherwise, your workaround is a good one.

Nope, it’s definitely a top level folder. Not sure what’s up… (I knew it would make no difference, but I tried moving the Front Matter folder above the Screenplay folder as well and it didn’t change a thing).

Tried to share some screenshots for reference, but the forum wouldn’t let me. Anyway, the workaround is good enough for now. Thanks again for your help!

My pleasure.

On my end tho, for future use, I’d like to know.

@AmberV @MimeticMouton or @kewms → What is the setup so that the frontmatter pages don’t affect the body page’s <$p> ?
If we want :
Front page, no <$p>
Page 1, no <$p>
Page 2, <$p> = “2” ( → not “3”)
. . . . ? . . . .
Are the front matter pages even supposed to be counted as pages like this ? It kind of defeats the idea of a front matter part to the book, doesn’t it ?

And why is this
Inked2022-03-25 13_37_32-Window_LI
not present as an option for front matter ? (How to i ii iii iv it then ?)

Check the option 5 lines up in the dialog, where “first pages” = “front matter”
I don’t know why they don’t call it that.

Yeah, but that doesn’t make it any more possible…
Plus, if you have to use “first pages” as front matter, then

  • Either you can’t have your front matter in roman numerals
  • Or your intro pages (front page, copyright, citation etc) have to be numbered this way too…

By having the first pages be the front matter, you don’t actually have first pages anymore.

In a way, it should be “Main body Front matter header and footer starts : At page x.”
And then (all naturally) the main body comes after.

So you’d have a header/footer set for first pages, one for front matter, and then the usual body one.

I just don’t see, as it is at the moment, how what the OP asked for can be done.
It would only be logical that the front matter gets his header/footer set, but even more, that the front matter pages be NOT counted as pages.

If things in the end are what they seem to be, and without a checkbox I’m unaware of, I can easily see this being quite a problem for a lot of people. (Eventually myself including.)

Here’s a Mac export with roman numerals in the ToC but not on the pages themselves. I don’t know a way to put numbers on front matter pages but NOT on the first front matter page. I don’t think numbers are needed in front matter, so I’m fine with it.

(?? in the ToC because I didn’t compile everything.)

PDF compile

So, you have <$p> starting on the 6th page, as being <$p>=3
Which means that you have a front matter of 3 pages.
Plus you started the page number display on page 3 of the main body.

→ That doesn’t seem to work under windows.
Checking “page numbers count first pages”, “Page 3” would have been labeled as “Page 6”, as, for some reason, the front matter pages are counted as pages…

There is just no way I can reproduce your compile.


That numbered as “page 3” the third page of the front matter.
And from there, all subsequent pages.

That :


In turn numbered page 3 of the front matter as being “page 1”
And from there, all subsequent pages.

Smells like yet another bug…

No. The first visible regular number (in my example) is 3, correctly — not because of front matter at all. It’s because page 1 (the image) is suppressed because it’s a single page (same for the front matter pages), and page 2 is suppressed because it’s the first page after a page break.

Well, I still don’t get the point then (if it ain’t a bug), of having a front matter if it is counted as normal pages in the book.

It isn’t. If it were, my page 3 would be page 6.

You just told me that in your example it isn’t, but for other reasons.

I explained why page 1 and 2 don’t have numbers. Do the math. Look at the pdf. Page 6 is numbered page 3 because front matter didn’t count.

Ok. I understand better now. So, you are positive that front matter pages are NOT counted as regular main body pages.
→ Under windows, they are. And they definitely shouldn’t.

If I have 5 pages of front matter, the only way I can get page 6 to print as being “page 1” is by unchecking count first pages.
But then, because of that, I can’t start the page number print at “page 2”. Never. Just never. (It would systematically come out as “page 7”.)

Another approach you might try is to Export (not compile) your draft to FDX and open it is a dedicated screenwriting app that takes care of all these things automatically. I use Final Draft with Scrivener, but if you don’t have a copy of FD, you can use WriterSolo for free.