Scrivener 3 Trial window unresponsive for over 10 minutes

I’m attempting to upgrade to Scrivener 3 for Windows, but the process seems broken.

At first, I couldn’t get past the “Project Templates” window. Mouse clicks within the window were ignored, and eventually the title bar showed the “(Not Responding)” message. I tried this several times.

Finally, while I was typing a previous version of this post, the “Scrivener Trial” dialog popped up. (Must have been a good 10 minutes after Project Templates.) I was able to click “Upgrade from an older version,” and my license was identified. I was told I would get a coupon for free upgrade.

But since then the Scrivener Trial dialog has been unresponsive. (Twenty minutes and counting.) I can’t click anything. The “Buy Now”, “Enter License” and “Continue Trial” buttons are greyed out. And the title bar again says “(Not Responding.”

Any suggestions? Is it really taking this long for the license server to respond, or is there some other problem?

I was so looking forward to the long-delayed Scrivener 3 release. So far, very disappointed with the experience. Alas. :cry:

Check to see if there was a window that opened up behind the trial dialog. Happened to me.

Excellent suggestion - I hadn’t thought of that.

However, I’ve just tried launching Scriv3 again, and I’m definitely seeing only the “Project Templates (Not Responding)” dialog - nothing hidden behind it. And I haven’t been able to get as far as the Trial dialog since that one time, no matter how long I leave the frozen Templates dialog sitting on my desktop.

Problem solved by L&L support. I needed to select the Scrivener.exe file, right-click for the Properties dialog, and set “compatibility mode” to Windows 7. I run a lot of new software on this system, and haven’t needed that old trick for many years, so I neglected to try it among my other Scriv3 troubleshooting efforts. (My next PC will be Windows 10, but only because I’ll have no choice. I am not looking forward to the downgrade.)

Anyway, happy ending. Now I just have to wrap my brain around all the changes in Scriv3…