Scrivener 3 Under Wine

Hi all,

Happy to hear that Scrivener 3 is officially released. I tried to run it after installing it, and came across this error:

env WINEPREFIX="/home/chris/.wine" wine-stable C:\\Program\ Files\\Scrivener3\\Scrivener.exe 002b:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution. 002b:err:module:import_dll Library Qt5Pdf.dll (which is needed by L"C:\\Program Files\\Scrivener3\\imageformats\\qpdf.dll") not found

Anyone know where I can find the qpdf.dll?

Hi, I don’t work for L&L but I do also use Scrivener on Linux with Wine on my desktop. I may be one of a very few here. And I strongly doubt L&L staff would support this. I also use it on a Windows laptop too. Anyway, I ran into a network card detection problem with the new Scrivener 3 binary which never hit me with the betas.

And it’s being discussed over at the winehq forum here:

There’s apparently an unofficial patch that someone got working with a Scrivener 3 beta, and several other apps which have the same bug. I’d guess this is about matching your NIC MAC address for licensing.

Anyway, I’m on Ubuntu 20.04 with Wine 6.0. No binaries are available yet but at least some folks over in winehq know about the problem and there’s a shot it may be fixed.

I have to say, I built wine from source following the instructions listed at that winehq thread and while it solved the netprofm complaints, Scrivener 3 just crashes shortly after launching.

OP, you’re missing Qt5 PDF libs, I don’t know why. I would expect this to be bundled with Scrivener.

Can you update to 6.4? It’s fixed in there. No patching needed.

This did fix the issue. Now just need to fix the license issue

Yes. Upgraded to wine 6.4 via PPA and now scrivener 3 starts normally. But I am unable to install my license key. It says it’s unable to reach the network and to try again later. I am able to access my documents and get to work again with the trial for now. So that’s good. But I’d like to license it properly.

It let me enter the code. Do you have dotnet 4.62 installed? with winetricks, 4.5 will fail, but it’ll install 4.62, which is all you need.

I did that and it worked! Now Scrivener on my Linux desktop system is legally registered. I also have a Win10 laptop. I think the L&L guys are OK with me using my license key on both my desktop and laptop as long as it’s for my own use. I have projects I share between them.

This is great! I’ve been using the betas on both systems for over a year now and I’m very pleased everything will keep working with few hiccups.

Yeah! They’re pretty generous with licenses, too.

I was able to install and run Scrivener3 Rel. version with wine 6.4. But i have another (not so important) problem - the background colour on selected binder nodes is annoying (dark blue with black font).
I was not able to figure it out, how that colour scheme is changeable. In options, only binder background and search results background are changeable.
Any ideas anyone?

F12 which brings up Options (or File | Options) then tap the Manage button on the bottom left. That will bring up a slew of themes you can use, or you can change the color of various bits of the GUI individually using the Appearance menu.

Yes, i know (as i wrote):“In options, only binder background and search results background are changeable.”
The problem is, that the node background and font color is not changeable. But it must, i see some changes in themes. So my question is, how can i change that without creating an own scheme (and figure it out, which params are responsible for that).

Did you end up finding a way to solve this? I’m in the exact same boat as you and it’s been driving me up the wall! You’re the only post I’ve found that talks about this, so I’m really holding out hope :smiley:

Topic moved to Linux forum. – Katherine

As previous answers recommend, upgrading wine to 6.4 solves the problem (at least on my machine). It looks like a known bug, fixed in wine.

I had the same issue. In my case it was to do with Wine.
Open the Wine configuration dialog and select the Desktop Integration tab.
In the Appearance section, keep theme as (No Theme), select item: ‘Selection Background’ and alter its colour to something lighter.
Hope that helps…

1 Like

Note: This was in response to the blue-on-black colour issue above.
(I also had the OP’s problem, which was fixed by upgrading to Wine 7)

Great. That was the missing link, thanks a lot.
Searching for solving that annoying little problem since long time, but never had the idea, that it has to do with the wine cfg (desktop integration).

Since doing that, I have changed the Scrivener theme in Options (to Grey Matter Light, then tweaked a couple of its colours), which also seems to eliminate your original problem; I have it all looking quite nice now…