Scrivener acts weird. Again.

In addition to the display problems I’ve encounterered in one project, now another project is acting up in a weird way.

When I click on a folder in the binder, It looks like the folder is selected - name of the folder is highlighted - but in reality a document IN the folder is selected. It cycled even through the documents, when I clicked repeatedly on the folder.

I recognized this error first by thinking the external file bookmarks had vanished that I had added to the Document bookmarks of that folder.

I had to trick Scrivener into selecting the folder, in the end by opening the corkboard of the parent folder and click on the folder I wanted to select on the corkboard.

In addition, text tidying “Replace multiple spaces with a single space” does not work as intended. It does remove one superfluous space in the line the cursor is on. Then it stops doing anything. Not if I click in another sentence and try it again, not if I select the whole text or parts of the text. It just stopps doing anything.

As far as I remember, the option usually removes all superfluous spaces in the whole document. But it just wont.

I never have encountered so many problems in such a short time before. The last update feels incredible buggy.

Any ideas?

Are you on the current version?

Versions before 3.2.2 had a variety of interface problems on Catalina and Big Sur.

Yes, everything is up to date.

Have hou restarted your Mac, possibly more than occe, or deleted and re-downloaded and re-installed Scrivener?

That, I did not. o.O

What I did:

  1. Deinstalled Scrivener
  2. Rebootet 2 times
  3. Reinstalled Scrivener
  4. Rebootet

(and by “reboot” I mean, I powered the laptop down and bootet it up again, instead of using the “reboot” option).

Problems that persist:

  1. Still doesn’t select the folder when I click on it, instead it selects a document in the folder.
  2. Text tidying - double spaces to single space just does nothing at all.

Problem that looks fixed (for the moment):

  • The binder display issue.

Mela

Version of Mac, of MacOS?

I tested and it works for me in Scriv 3.2.2 on both Mojave, Catalina and Big Sur.

[attachment=0]Bildschirmfoto 2021-01-27 um 15.10.08.png[/attachment]

[attachment=1]Bildschirmfoto 2021-01-27 um 15.05.53.png[/attachment]

Then it’s likely your Mac that is causing this strange behavior. Something in your setup.

If it’s just one project, please try clearing the display settings, as explained here:
scrivener.tenderapp.com/help/kb … y-settings

Katherine

Done. Problem persists.
Also “Multiple spaces to single space” still does nothing.

[attachment=0]Bildschirmfoto 2021-01-27 um 19.30.31.png[/attachment]

Regards,

Mela

Any idea where do look?

  1. The index card for the folder “publikum” has focus. Click on the light-blue corkboard to deselect the folder and to return focus to “Active Projects”.

  2. To remove multiple spaces, the text needs to be loaded in the editor and the editor must have focus / be selected.

Cursor focus is critical in both cases. I think your installation of Scrivener is fine.

Best

L

Aaaand the sidebar display issue is back, too.
I’ll try to reset the display settings for this project, too.

Thank you. I did deselect the “Publikum.net” folder and it worked. Yet, I can’t remember that behavior in the past. I thought when clicking on another folder, the focus would follow. But I can remember incorrectly.

In case of removing multiple spaces, here is, what I did:

  1. I opened the text in the editor
  2. I clicked somewhere in the text
    3.I clicked on “Edit”
  3. I clicked on “Text tidying”
  4. I clicked on “Replace multiple spaces with single spaces”

Nothing.
This is what I did in the past, and it happened to work great in the past but it just stopped working.

  1. I opened the text in the editor
  2. I clicked somewhere in the text
  3. I clicked on “Edit”
  4. I clicked on “Select all”
  5. I clicked on “Edit”
  6. I clicked on “Text tidying”
  7. I clicked on “Replace multiple spaces with single spaces”

Nothing.

  1. I opened the text in the editor
  2. I selected a paragraph
    3.I clicked on “Edit”
  3. I clicked on “Text tidying”
  4. I clicked on “Replace multiple spaces with single spaces”

Nothing.

What am I doing wrong?

Regards,
Mela

Clearing the display settings works for the sidebar display issue.

Maybe it is something with the text itself. I copied it from the webpage I published it on (medium.com) into Scrivener. But I already had removed all styles thus I can’t imagine what keeps text tidying from working properly or at all.

Still, I just added some extra spaces in another text in another project and text tidying works there as intended.

Out of explanaitions.

Have you turned on ’Show invisibles’ so you can see that there are actually double spaces in your text?

If the text is published on Medium, possible to share the link so we can copy it for ourselves and see if we get the same double spaces (and subsequent text-tidying error) that you do? Or could you share a sample file with dummy text showing the problem?

I second this recommendation. Text imported from the web often has residual formatting of various kinds.

Katherine