Scrivener and Bookends

Running Scrivener 3.1.2 and Bookends 13.2.0 on this 13" MBP with MacOS 10.14.3.

I hadn’t actually had to use citations for some time, and Scrivener, Bookends and MacOS have all been updated since the last time. Now I find that Cmd-y in Scrivener takes me to Bookends, but Cmd-y in Bookends only takes me back to Scrivener without pasting the citation into the Scrivener document. I have to do Cmd-v for it to be pasted in.

I contacted Jon at Sonny Software who said to go to System Preferences > Privacy and make sure that the two apps are allowed to talk to each other. I have set both to have full disk access and in the FireWall tab allowed both to accept incoming connections.

Still no joy, I still have to do Cmd-v. That’s not really onerous, but if anyone here has any advice or suggestions they will be gratefully received.



Hi Mark, all I can really tell you is that it is working for me (same Scrivener / Bookends / macOS versions). Try de-assigning Scrivener in Bookends, doing the same in Scrivener, then reassigning both to see if that helps. Or perhaps you have some software that manages the clipboard installed that may interfere (though I have Alfred, BetterTouchTool & Karabiner and none of those cause interference)… As much as I hate to suggest it (once upon a time macOS was reliable and this windows solution was meaningless for most macOS problems), but does rebooting help?

Out of curiosity (if you haven’t used Bookends for a while), have you used the newish floating citations system, you may find it much less intrusive than switching to/from Bookends with ⌘Y (page 59 of the user manual). By default tap CONTROL twice and you get a floating search window (in any app), then search and select and you can input the temp citation directly from there. ⌘Y works to copy citation there too, perhaps you can test if it works in this case?

Thanks Ian. I have tried re-assigning in both Scrivener and Bookends, I have also rebooted. But no joy! The interesting thing is that when I re-assign Bookends to Nisus Writer Pro, it works perfectly there! And I don’t have any clipboard managers or shortcut creators installed … though come to think of it, I might disable TechTool Pro to see if that’s getting in the way.

As for why I haven’t used it, since retiring and coming back to the UK, I only need to put references in my recipe project—not that that is for publication, it’s more just pulling together in one place the recipes that we have gathered over the decades, and any new ones we find, and there haven’t been any of the latter for a while.

The only other thing I can think of is to do a complete re-install of both apps, which would be a bit of a bore.

Anyway, I’m glad it’s working for you. Thanks for your suggestions.