Scrivener and Wine 6 on Mint 20.1

HI all,

This updates an earlier note I posted on the Beta board.

The released Scrivener 3 (Win) works under Wine via both PlayOnLinux and Crossover. I didn’t test it on Wine itself, but I assume it would work because all of the previous betas did, and raw Wine was all I used for them.

Req: Dotnet 4.6.2 (I’m up to 4.7) and the Speech SDK.

There’s a problem with Wine 6, however, which seems persistent.

For the betas, when I upgraded my system Wine installation from Wine 5 to Wine 6, the betas stopped working, so I rolled back and the betas started working again.

For the released version of Scrivener, I installed it on Crossover with my system Wine 5 still not upgraded, and after some fiddling, it works.

For Play On LInux, which can testbed various Wine versions in the same bottle, an install into a bottle with Wine 6.5 failed, mainly because installing Dotnet 4.6.2 into that bottle consistently crapped out (failed installation). Seems to be a Wine problem, though I don’t see reports of it (which is odd).

But rolling the bottle’s Wine version back to the latest stable Wine 5.x and then installing Dotnet4.6 and 4.7 worked like a charm. (If this doesn’t make sense to you, the part about a bottle being able to be run under alternate versions of Wine within POL, see the POL documentation. It’s a nice feature!)

Sending this FYI. I haven’t bought a Scrivener license yet, but I’m about to. If the license installs and works, we’re GTG.


You have to use either WINE 5.22 or above 6.4.

Thanks, garpu. It was Wine 6.5 that failed, at least as reported by POL.

What’s going on here? Any idea?


Yeah, there was another regression with it. Either upgrade to 6.7, or invoke WINE as “wine64 Scrivener.exe.”