Scrivener asks for serial number every time

I recently bought the software and it’s worked wonderfully, but everytime I close it and open it again, it asks me to introduce my serial number. It’s tiring to write all those numbers everytime I want to use Scrivener. Is there any way I can fix this? I appreciate any help.

Are you getting any kind of error or other message besides the dialog to enter your serial name and number? That information is stored in the registry, so it could be that there’s another program (security software, for instance) preventing Scrivener writing to the registry, but I’d expect you to be getting a failed registration message after the attempt in that case.

Do you get a request to activate each time, too, or any indication of trial days left?

At first it shows me this message that my trial has ended:

And then to register my license.

A couple of pop-up messages follow everytime saying that it has been registered, etc, but if I close the program and open it again, the same thing shows up.

I have the same problem - has a fix been determined?

After the registration, there should be a step to activate–you’d click to do that, and after a moment it should return either a successful activation or a failed. Either way Scrivener would normally keep working, but it’d be good to know what you’re getting at that point.

This definitely sounds like a registry issue. Do you have any programs installed that might be affecting that? Clean-up programs, disk-monitoring software, third-party uninstallers…? Have you tried a system reboot?

I am having this problem too. I get as far as a pop up window saying it’s validated, followed by another pop up window saying the serial number is invalid. It’s pretty frustrating …

Same here, plus the trial (which I downloaded today), now says it is expired and I must enter S/N. Makes me think I chose the wrong software… :angry: