Scrivener, Bookends & Mellel problem

I am using Scrivener, Mellel and Bookends. In Scrivener the citations were inserted between {} brackets. I exported to Mellel and then chose “Convert text to citations”. The citations now appeared in blue boxes and all seemed well. Then I chose “scan document”.

After it finished and generated a bibliography for me, all of the citations are now outlined in purple. However, all of them still have the Bookends reference ID attached to the end of the citation. Here’s an example: (Meyer et al., 2002, pp. 709-715, #4217).

The problem, it seems, is not incorrect formatting. All of my references have the correct formatting, i.e. (Author, Date, Page Number). The problem is that the citation ID (i.e. #71342) still appears after all of that. This is how ALL of my references appear: (Author, Date, Page Number, Citation ID)

After further testing, I’ve determined that the problem has something to do with the interaction between Scrivener, Bookends and Mellel. I know this because if I create a new document in Mellel, insert a reference from Bookends, and then scan it, I get exactly what I would expect. A citation with the Author, Date, Page Number format.

However, if I write the document (and add the references) in Scrivener, export as an RTF file, open in Mellel, convert text to citations (using {} as delimiter), and THEN scan the document, something goes wrong along the way that prevents Mellel/Bookends from removing the citation ID.

Any ideas?

A thought just occurred to me. I want to make sure that I’m using the right format in Scrivener. In Bookends I have Scrivener set to the default word processor. I have “Author, Date, Unique ID” in Scan & Bib Preferences.

When I enter a citation in Scrivener, it ends up looking like this {Author, Date, #72813}. Is this correct?

The All Seeing I has discovered that your problem is solved:

Maybe the Scriveners would have been as fast as the Mellel forum people with providing an answer to your question if you hadn’t buried this thread in the Zen departement …

(Just for the record and the people who are to lazy to click the above link: Always put the “@page number” at the end of a citation.)