Scrivener cant be installed on Ubuntu 16.10

Too many .so files has another versions than on 16.04. May be static linking can be a solution(temporary) in that case…

I found that my previously working install of Scrivener suddenly wouldn’t open after upgrade to Ubuntu 16.10 :confused:

Here’s the terminal output:

/usr/share/scrivener/bin/Scrivener: error while loading shared libraries: cannot open shared object file: No such file or directory

I had a quick google but couldn’t figure out how to get this dependency? Not sure I’m geek enough for this. Still hoping it’ll miraculously start working after routine updates, but if it carries on beyond November I’m probably looking at a clean install of 16.04. One day I’ll learn to stick with LTS. Though if this missing file has been ditched permanently, eventually Scrivener is going to stop working anyway. Always a possibility with a discontinued development, but I’ll be very sad. Scrivener has been a mainstay of my process for so long I’m not sure how I’ll cope without O.O

Have you considered running the Windows version of Scrivener under WINE? In many ways that would be a lot easier, as you’d also be able to stay up-to-date on the latest features and bugfixes.

I tried to do it with the previous version, but it looked awful. May be i’ll try again.

This is how I was able to get Scrivener to start up on Ubuntu 16*:

sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev

I don’t know if that will help with your missing library, but it worked for me. If it doesn’t, just find something that includes the libraries you’re missing and install it. It really is a shame Linux isn’t supported the same as Windows.

There are very large under-the-hood differences between 16.04 and 16.10. Your solution only works on 16.04.

It is just a sad fact that while Ubuntu is continually developed, Scrivener for Linux is frozen in time and is becoming more and more dated on all platforms. Ubuntu and Scrivener have just diverged so much that it has become inefficient to try to work-around the divergences.

If one must run it, what I’d suggest is to run an older version of Linux, say 16.04 LTS in a VirtualBox or VM Player setting. Or a 14.04, from when Scrivener for Linux worked out of the box on Linux without your solution. The 14.04 was only recently left behind as it was a long term service release, and was replaced by 16.04. 14.04 should be, reasonably, up to date. But just like with Scrivener, updates on it has ceased now.

For most others, Scrivener for Windows running under Wine is the preferable option.

There is a Youtube video that helped me quite a bit towards making Scrivener look right under Wine. It worked for me quite well and it looks as good as Windows now. On YouTube, search for “Install Scrivener for Windows on Linux” by AJ Reissig.

I’ve just set Scrivener for Windows in Wine up in Debian Jessie (in VirtualBox under macOS Sierra…) and it was relatively straightforward.

The resulting version doesn’t look much different to me from how it does in Windows 10 (which is to say – not as good as it does in the Mac, but that’s Windows fault…)

I’m not sure it’s that easy too tell which of these screenshots is from Wine and which from Windows 10. There’s a slight difference in the size of the fonts, which I think is down to slightly different ways the emulators deal with resolutions, but the internal Scrivener settings are the same, as far as I can be bothered to make them.

The one on the bottom is Win10, BTW.

The default install on Wine was horrible though, so I used the fix on this page, which works well for me. Just follow the instructions to download the script, run it, and select option 3.

Hope this helps.

As has been mentioned already, some of the packages upon which Scrivener depends are no longer present in the repositories for Ubuntu 16.10. They are, however, still available to download from the 16.04 (xenial) repository here:

The packages I downloaded were:

libgstreamer0.10-0_0.10.36-1.5ubuntu1 libgstreamer-plugins-base0.10-0_0.10.36-2 libpng12-0_1.2.54-1ubuntu1

I installed them, in that order, using the GDebi package installer and, hey presto, working Scrivener :smiley:


  • Although I have not detected any undesirable side effects from installing these packages, I cannot be sure there are none or that they won’t break something on your system.
  • The next time you upgrade your system, these packages will likely be removed again although there are ways around this: see the documentation for the aptitude hold command.

In conclusion: if you really need or want to have Scrivener running natively on Ubuntu 16.10 this may offer you at least a temporary solution - though future Ubuntu upgrades may well introduce new problems. For what it’s worth, my recommendation, if you are happy using Wine, is to install the Windows version that way on you Linux box. (Wine and Scrivener both installed and ran on 16.10 for me without any problems.)

Hope this helps

I got it working easily by installing a couple of packages using the terminal:

wget wget sudo dpkg -i libgstreamer*.deb

for libpng12, I compiled the older version, and copied the needed libraries to Scrivener/lib. (Didn’t bother to install libpng12.)

I found the same or similar problem with a new installation of (Lubuntu) 16.04, the current Long Term Support version.

Following the above advice for missing/out-of-date packages, I also found the apt-cache policy command, which informed me: apt-cache policy libgstreamer0.10-0 libgstreamer0.10-0: Installed: (none) Candidate: 0.10.36-1.5ubuntu1 Version table: 0.10.36-1.5ubuntu1 500 500 xenial/universe amd64 Packages andapt-cache policy libgstreamer-plugins-base0.10- libgstreamer-plugins-base0.10-0: Installed: (none) Candidate: 0.10.36-2 Version table: 0.10.36-2 500 500 xenial/universe amd64 Packages
Realising that there seemed to be no version of either library installed at all, I tried searching (“libgstreamer0.10-” and “libgstreamer-plugins-base0.10-”) in Synaptic, and sure enough I was able to locate and install these two packages with no problem: libgstreamer-plugins-base0.10-0 (0.10.36-2) and
libgstreamer0.10-0 (0.10.36-1.5ubuntu1).

Now I have Scrivener working in 16.04, just as I had in (a separate installation of) 15.04 previously, which had worked straight off. I have no intention of udating to 16.10 or later versions of Lubuntu for the foreseeable future, so I hope this will remain stable for me. I am posting this in case there may be others struggling with Scrivener under Ubuntu 16.04, and who will find it an easy fix. Slightly surprised that the problem only gets a mention for 16.10: am I alone with 16.04?

Thank you! I installed this on Elementary OS (Ubuntu 16.04) and these dependencies were all that was missing. I previously had the Mac version.