Scrivener can't compile any format

I have the latest Windows Beta version and when trying to compile to any format, the compiler gets to 99% and then the program crashes and closes. I’ve tried to compile to Mobi first, and then to other formats including Word and PDF, but it crashes for all compile formats.

Following a Scrivener crash, I get the following dialogs;

  1. After trying to compile to a *.mobi file - “Error in initializing the manifest file.” (This is a Kindle Creator dialog, so I uninstalled Kindle Creator, rebooted and tried again but Scrivener crashed and closed again.

  2. A “Kindle Compile Result” dialog - “The following error occurred while compiling the Kindle book:”
    “Pinging [] with 32 bytes of data:”
    “Request timed out.”

I uninstalled Kindle Create and rebooted but still have the same problem. Please advise as I need to compile my book.


Moved to beta forum.

Please note that if you need to compile your book to meet a deadline, you should not be using beta software.


I would suggest back up your writing files, uninstall the Beta, and clean and remove its directory in “Program Files.” Just to make sure there’s no remains.
Uninstall the Kindle generators, whatever they are, including any dependencies that also must be used. Reboot the computer to clear any caches.
Then download the latest versions, so you’ve got the ones with updated addresses, and reinstall the Kindle stuff and then Scrivener.

If it still doesn’t work, after complete reinstall?

Um… install Scriv 1.9.x, drag and drop stuff over to it, and compile there? Buy a Mac and use Scriv 3?