Scrivener can't locate Java after upgrading to Big Sur?

Because Smashwords prefers the old Microsoft Word 97-2003 “.doc” format my usual practice is to compile a project to “Microsoft Word 97-2004 (.doc)” – this always worked fine.

To my sorrow, I upgraded to Big Sur, and now I get an alert message that says “Better file conversion is available if Java is installed.”

I installed Java from the linked site, but even after restarting, I still get the warning.

I searched to see if anyone else was experiencing this issue, and didn’t seem to find any reports of it.

FWIW, the Java File I got was jre-8u271-maxosx-x64.dmg / Java 8 Update
/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home

Do I need to set this path in Scrivener somehow (how?)
Or is this some execution permission problem?

Any guidance appreciated!

Here’s an explanation of the error message:
DOCX Converter and Deprecated Native ODT and DOC Support
Scrivener is no longer bundled with a built-in Java Runtime Environment, which was previously used for improved conversion when importing and exporting .docx, .doc and .odt formats. Scrivener now has its own native .docx importer/exporter, so there is no need to include Java (which added 100MB to Scrivener’s file size). This does mean, however, that the default .odt and .doc converters are now of a lower quality. Users who rely on these formats and cannot use .docx as an alternative can install Java themselves; if Java is installed, Scrivener will use the same converters it used previously for these formats. (You can also set .docx to use the Java converters via the Preferences should you ever need to.) Allowing users to install Java themselves also improves security.

(From the Scrivener 3.2 Release Notes.)


The site you downloaded from has an outdated version of Java (caught me too!) Download the current version from this site: … nt=hotspot

No need to uninstall the version you installed by mistake.

Thanks very much! I downloaded/installed the OpenJDK 15 Hotspot.


now gives me


which seems promising, but I’m still seeing the warning when I try to compile my project.

(Restarted the Mac after the install)

Huh. At this point, I have nothing further to offer, as I’m running Catalina. Here’s the thread in which I posed this very question:

It may be worth googling “Big Sur Java” and seeing what challenges there may be in the wider Mac universe with respect to Java. Other than that, I’d suggest you open a support ticket at

https: //

Put [URGENT] in the title if you need a prompt reply, as they’re mostly on holiday break.

Good luck!

Oh wait.

Check your preferences for Sharing>Conversion. Do you now have an option that reads “Use Java converters for .docx”? If you do, try turning it on before compiling. If you still get the same message, then be sure to mention that in your support ticket. If the option doesn’t exist, be sure to mention its absence.

Hope this helps!

Thanks again! Filed a ticket (didn’t flag it as urgent, since I do have a work-around via Libre Office)… FWIW in conversion I only see the options “Use standard macOS .doc exporter”/“Export as RTF-based .doc file”

If/when I hear anything I can report back, if there’s interest.

On the bright side, this has uh, inspired me to dig into generating ePub from Scrivener directly

Dumb question for you – do you have the Apple Store version of Scrivener or the direct download version? If the former, I am wondering if you are getting bit by the sandbox security feature…

Good thought, Devin.

…I did purchase from the App Store, yes.

I added the root folders /Users /Library /System /Applications under Preferences/Allow Folder Access
and for good measure I gave Scrivener full disk access in System prefs.

Still doesn’t think Java is installed, sigh.

Appreciate the help very much, though, even when it doesn’t lead directly to a solution.

It should be possible to confirm that Java is correctly installed without using Scrivener. Check the OpenJDK site for troubleshooting suggestions.


If you follow Katherine’s advice and can demonstrate that your JDK is properly installed and working, but you still can’t get Scrivener to see it, try downloading it directly from L&L and using the trial version to open your project. If that works, then enjoy the 30 days of the trial and work with their support to get your license switched over from the App Store version to the direct download version.

AFAICT Java seems happy, java --version reports

openjdk 15.0.1 2020-10-20
OpenJDK Runtime Environment AdoptOpenJDK (build 15.0.1+9)
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 15.0.1+9, mixed mode, sharing)

I appreciate the suggestion of downloading directly from L&L, but since I don’t need to solve this before they come back from winter vacation at this point I think I will wait for their response rather than introduce new changes to my platform.

So firstly, if Scrivener is detecting Java on startup (and you should restart it if you haven’t already, though I’m sure you’ve tried that), then you won’t even see the option for switching between RTF-based or native macOS conversion for .doc/.odt. If you have Java installed, then there is very little reason to use either of those options. Thus, the presence of that setting is a good way to test whether things are working, before going to the trouble of compiling.

I would open up Console and monitor what, if anything, Scrivener has to say during startup, and then subsequently upon testing import, by dragging a .doc file into the binder, and export, by exporting single text binder item using .doc (again, faster than compiling):

Here is how to launch Console, and get useful results from it (the default settings are extremely noisy) if you are not familiar:

  1. Click on the Finder icon in the Dock
  2. Use the Go ▸ Utilities menu command.
  3. Double-click the Console icon.
  4. Click the “Errors and Faults” label in the toolbar (maybe—you could try leaving this off as well and just filtering by Scrivener, if you get nothing, just be aware you will get a fair degree of output with this off).
  5. After these two keys in the search field, type in “Scrivener”.
  6. Click the “Clear” button in the toolbar.

This is generally a fairly painless process if all you intend to do is test it. In fact you don’t have to do anything other than download the .dmg, drop the Scrivener icon into your Downloads folder, and run it from there. You’ll maybe get a warning about running it from a “non-standard” location, but this can be ignored. You can even have both versions running at the same time, they don’t even share settings (not that this matters much either).

I’d give it a double-check test myself, but unfortunately it appears Apple’s servers are having issues in my region at the moment. I can’t install anything from their store page.

Note that if it does work, and runs in an unlocked state, and you don’t mind switching over to the direct-sale version, here are some tips for getting your settings copied over. And at that point you’d want to drag it into Applications and replace what is there (or rename it, and keep both, again it’s no big deal).

For what it’s worth, I had the same problem as the OP in Catalina. I installed Java 8 from here ( … loads.html). I restarted, and then the ODT export in Scrivener worked perfectly. I’m not sure the SDK did the trick, or it was just restarting that was necessary for my problem. But wanted to share in case others run into this.

Hi Amber,

Thanks very much for the suggestions, sorry for the very late response. I wasn’t able to discern anything useful from console (no errors/faults thrown by Scrivener or one of its processes, and with “all messages” it was difficult to tell what might be relevant.


running the literatureandlatte download from the DMG worked fine.

Thanks for the confirmation, that fits with what we’re learning about the pattern in who sees this and who does not.

As for needing to restart—yes, I’m pretty sure that you need to restart the software after installing Java, so that’s probably a separate thing but something to be aware of.