Scrivener crashes when going into Composition mode (version 3.3.2 and version 3.3.3)

Hi there
My mac (Macbook pro M1) crashes when I try to go into Composition mode?. Has anyone else experienced this?

What version of MacOS? Any recent system changes? Does the Crash Report ( see using the Console app) give any clues? There are numerous reports hear already, with suggestions by L&L as to how to resolve, about specific MacOS versions and the recent Sonoma update…have a review and check.

Could you check and see if disabling the Behaviors: Composition Mode: Open composition mode in its own Space preference, has any effect? I’ve seen a crash log of this, and it looks like it might involve CoreAnimation, which spaces would invoke with all of its sweepy slidey swoopy stuff. I can’t think of any other reason Composition Mode would be involved with that, especially with the Fade option fully removed.

I am having the same problem. When I enter composition mode, I get the “spinning beachball” and then have to force quit. It still works outside composition mode, but this clearly has something to do with Sonoma 14.

I have tested all of the obvious options at this point, and given the issue is not reported in a more widespread fashion, I’m guessing it takes something fairly specific in the local configuration—or potentially the kind of data being loaded into the view.

I’d start with a factory reset, and if that does not work, a reset of the project’s display settings.

In both cases, these instructions show you how to back up your existing settings. That is especially important in this case, because if either one of those clears up the problem, that file could be of use to us in figuring out which setting is the culprit—particularly if you follow the instructions to import your settings back into the software/project, and the crashing comes right back.

Same problem for me - switching into composition mode crashes latest Scrivener.

I tried the factory reset option first and that didn’t fix the issue, scrivener kept crashing switching to composition mode. But resetting the project’s display settings worked.

Are the crashes happening only on macOS 14 Sonoma (I see stevendkrause mentioned Sonoma but no one else has yet mentioned the OS).

Also, is composition mode set to use page view by any chance?

If both of the above are true, please try this build and see if it helps:

All the best,

I can confirm the spinning beachball behaviour when entering composition mode on Sonoma. Unfortunately the new build doesn’t resolve this issue for me. Composition mode isn’t set to open in its own space.

The test build fixes the crashes mentioned here though, so it might be unrelated.

1 Like

There are most likely two different Composition Mode issues that are making things confusing (although more accurately the second is really with composition, rather more that a larger bug can appear there too).

  • We have reports of a hang, the spinning beach ball, and these reports seem to include references to CoreAnimation. I have no leads on what is causing this. I can’t reproduce it and none of the obvious settings are of impact.
  • The test build above is for something else entirely, with different symptoms (instance crash, no hang) that can happen with zoom and/or page view, and seems to be more often encountered with scriptwriting mode, but that could just be a correlation between scriptwriters often using zoom and page view since you can’t as easily mess with font sizes and page is well, very useful for screenplays. Since page view and zoom can both be applied to Composition Mode, it could apply there as well, but we don’t have a lot of data on that speculation.

Right, in that case I’m experiencing both the crashing related to zoom and/or page view and the hanging when entering composition mode. The hanging happens just as described above, with a beach ball spinning and no way out of Scrivener except by force quitting.

The crashing also still happens with the test build, I’ll attach a crash log in the other thread.

I may be losing track of the threads here (it’s been a long week of bug fixing), but did you post the composition mode crash log somewhere?


Actually, could anyone experiencing this issue please do the following:

  1. Go to Scrivener > Settings…
  2. Click “Manage…” at the bottom and choose "Save Preferences to File…
  3. Save the file to disk somewhere.
  4. Send the file to

It would be great if you could include a crash log too if you have one.

Many thanks and all the best,

Just thought I would chip in my 2 cents and confirm I too am having an issue with Scrivener ‘hanging’ when trying to enter composition mode. I get the spinning beachball and have to force quit. Fiddling with ‘Behaviour’ settings and having composition mode open in its own space on/off hasn’t made a difference.

I’m running Sonoma 14.0 - I’ll see if I can get a crash report and send it in.

For those experiencing this issue, does it happen with all projects or only some? If it only happens with certain projects, could you please zip up a sample project showing the issue and send it to us at


If you are experiencing crashes doing into composition mode, please try this build and let me know if it helps:

This is a bit of a stab in the dark because unfortunately only one person has sent in a crash log so far, and we haven’t been able to reproduce it, so we don’t have much to go on.

All the best,

Something you can do, when you get a hang instead of a crash, is fire up Activity Monitor, locate Scrivener in the task list and select it, then use the View ▸ Sample Process menu command, saving the results of that to a file for sending on to us.

It isn’t always useful, but sometimes it can show whereabouts something is hung up, or what it was doing last before it stopped working.

I can confirm this latest build fixes the issue with going into Composition mode for me.

I’ve attached a crash report from an earlier test build ( ScrivOldCaret-051023 or ScrivPageCrash_B_051023) if that’s still of any help.

ScrivPageCrash_B_051023 Composition (389.9 KB)

1 Like

I downloaded this build and composition mode started working fine after. So whatever change you made, appears to have worked.

1 Like

Okay, that’s great news, thanks!

Bizarrely, I still don’t know exactly why it was crashing before as I haven’t been able to reproduce it. But a crash log I received - which is the same as the report mensch provided above (thanks) - indicated the area in the code the crash was happening. So I changed that piece of code in this new build.

It seems that the old code was sending out a notification that was triggering the same code to be called over and over again. What I don’t understand is why that particular notification would have that effect, but at least the change seems to have done the trick! I’ll continue to puzzle over the reason but the main thing is that we should be ready to release an update with these fixes in the next day or two then.

All the best,

1 Like