Scrivener crashing after Mojave update AND support form returns undeliverable email

I am having the crash on startup problem after upgrade to Mojave and submitted a support ticket yesterday, having tried all the solutions proposed in the forum. Afterwards, I received a “undelivered mail returned to sender” message with the text below so I’m not sure my ticket was actually accepted. Please help!

This is the mail system at host

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

If you are a current customer of DreamHost, please contact our
technical support team here

If you are not a customer please use our contact form at.

If you do so, please include this email in your support ticket. You can
delete your own text from the attached returned message.

           DreamHost Email Support (expanded
from host[] said: 554 5.7.1 Service
unavailable; Client host [] blocked using; (in reply to RCPT TO command)
Reporting-MTA: dns;
X-Postfix-Queue-ID: DD30C95C62
X-Postfix-Sender: rfc822;
Arrival-Date: Wed, 27 Mar 2019 18:00:08 -0700 (PDT)

Final-Recipient: rfc822; tender2+c4c56a35d3c6d1c45024840114f3e92 …
Original-Recipient: rfc822;
Action: failed
Status: 5.7.1
Remote-MTA: dns;
Diagnostic-Code: smtp; 554 5.7.1 Service unavailable; Client host
[] blocked using;
Received: from ( [])
(using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits))
(No client certificate requested)
by (Postfix) with ESMTPS id DD30C95C62
for; Wed, 27 Mar 2019 18:00:08 -0700 (PDT)
Received: from ( [])
by (Postfix) with ESMTPS id 7301C4000083F
for; Wed, 27 Mar 2019 18:00:08 -0700 (PDT)
Received: by (Postfix, from userid 10857859)
id 4163A30313A982; Wed, 27 Mar 2019 18:00:08 -0700 (PDT)
To: “”
Subject: Scrivener crashes on startup after update to Mojave
X-PHP-Originating-Script: 10857859:SimpleMailInvoker.php
Date: Thu, 28 Mar 2019 01:00:08 +0000
From: “”
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
X-VR-SPAMCAUSE: gggruggvucftvghtrhhoucdtuddrgedutddrkeefgdegtdcutefuodetggdotefrodftvfcurfhrohhfihhlvgemucggtfgfnhhsuhgsshgtrhhisggvpdfftffgtefojffquffvnecuuegrihhlohhuthemuceftddtnecundfrhhhishhhihhnghdqvghnqdhmihhstgculdeftddtmdenucfjughrpefvuffkfffhgggtgfesthhqjhdttddtjeenucfhrhhomhepfddfuceorhhstghhohgvnhhmsehutghstgdrvgguuheqnecuffhomhgrihhnpehstghrihhvvghnvghrrdgrphhpnecukfhppeeiledrudeifedrudejjedrudelnecurfgrrhgrmhepmhhouggvpehsmhhtphdphhgvlhhopehpshdvfeefkeehvddrughrvggrmhhhohhsthhpshdrtghomhdpihhnvghtpeeiledrudeifedrudejjedrudelpdhrvghtuhhrnhdqphgrthhhpedffdcuoehrshgthhhovghnmhesuhgtshgtrdgvughuqedpmhgrihhlfhhrohhmpehrshgthhhovghnmhesuhgtshgtrdgvughupdhnrhgtphhtthhopehmrggtrdhsuhhpphhorhhtsehlihhtvghrrghtuhhrvggrnhgulhgrthhtvgdrtghomhenucevlhhushhtvghrufhiiigvpedt

Hey rschoenm,

I don’t think we received your ticket, but I’d be happy to help you here on the forum. I have a few questions I need to know the answers to further assist you with this issue.

  1. What version of Scrivener are you using? Go to Scrivener > About Scrivener to locate your version #.

  2. What version of macOS are you currently running?

  3. Will you please post a screenshot(s) that illustrates the issue you are running into?

Hi Oliver, I just upgraded to the latest release of Mojave and Scrivener 3 started crashing on startup. I erased my version and re-installled from the download from your website, downloaded last night. I don’t get past attempting to start the program, so I don’t have any plist file in ~library/preferences

By “latest release” of MacOS, do you mean 10.14.3 or the beta of 10.14.4?

Have you checked whether your anti-virus software is being over-enthusiastic?


Hi! I am actually running 10.14.0, which is what installed from the app store two days ago. The virus software is the same I’ve been running since mid 2018 with no problems with Scrivener. The problems began with the upgrade to Mojave. On startup I get the following problem report (full text in the attachment)scrivener error.txt (67.2 KB):

Process: Scrivener [5639]
Path: /Applications/
Identifier: com.literatureandlatte.scrivener3
Version: 3.1.2 (10882)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Scrivener [5639]
User ID: 504

Date/Time: 2019-03-29 04:19:54.429 -0700
OS Version: Mac OS X 10.14 (18A391)
Report Version: 12
Anonymous UUID: F68579D8-C5D4-4985-0C75-AB9A312EC96B

Sleep/Wake UUID: 25DBCCDA-463E-4E18-946A-D7E99424BC75

Time Awake Since Boot: 22000 seconds
Time Since Wake: 45 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_BAD_ACCESS (Code Signature Invalid)
Exception Codes: 0x0000000000000032, 0x0000000103a445c0

Termination Reason: Namespace CODESIGNING, Code 0x2

kernel messages:

VM Regions Near 0x103a445c0:
__LINKEDIT 0000000103a0e000-0000000103a42000 [ 208K] r–/rwx SM=COW /Applications/
–> __TEXT 0000000103a42000-0000000103a5e000 [ 112K] r-x/rwx SM=COW /Applications/
__DATA 0000000103a5e000-0000000103a63000 [ 20K] rw-/rwx SM=COW /Applications/

Thread 0 Crashed:: Dispatch queue:
0 com.eSellerate.EWSMac 0x0000000103a445c0 +[EWSController load] + 0
1 libobjc.A.dylib 0x00007fff64818629 call_load_methods + 693
2 libobjc.A.dylib 0x00007fff64815758 load_images + 117
3 dyld 0x000000010da4d454 dyld::notifySingle(dyld_image_states, ImageLoader const*, ImageLoader::InitializerTimingList*) + 420
4 dyld 0x000000010da5f0c5 ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 337
5 dyld 0x000000010da5f06d ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, char const*, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 249
6 dyld 0x000000010da5e254 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 134
7 dyld 0x000000010da5e2e8 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 74
8 dyld 0x000000010da4d774 dyld::initializeMainExecutable() + 199
9 dyld 0x000000010da5278f dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 6237
10 dyld 0x000000010da4c4f6 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 1154
11 dyld 0x000000010da4c036 _dyld_start + 54

Thread 1:
0 libsystem_pthread.dylib 0x00007fff65ae3408 start_wqthread + 0
1 ??? 0x0000000054485244 0 + 1414025796

Thread 2:
0 libsystem_pthread.dylib 0x00007fff65ae3408 start_wqthread + 0
1 ??? 0x0000000054485244 0 + 1414025796

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x00007fff9778c0e8 rbx: 0x0000600002ed0408 rcx: 0x0000000000000000 rdx: 0x0000000000000010
rdi: 0x0000000103a61d00 rsi: 0x00007fff369ad350 rbp: 0x00007ffeec8ceba0 rsp: 0x00007ffeec8ceb38
r8: 0x0000000000000044 r9: 0x0000000000000140 r10: 0x0000000000000018 r11: 0x000000000000000e
r12: 0x0000000103a445c0 r13: 0x0000000000000001 r14: 0x0000600002ed0400 r15: 0x0000000103a61d00
rip: 0x0000000103a445c0 rfl: 0x0000000000010246 cr2: 0x0000000103a445c0

Logical CPU: 2
Error Code: 0x00000014
Trap Number: 14

I’m not part of the team—so I apologise to @OLIVERJEVENSON for gatecrashing! :blush: —but it seems to me that the problem is here:

And that you need to go into System Preferences > Security & Privacy > General and look at the “Allow apps from:” section at the bottom. Has the update set itself to “Allow Apps from: App Store” only?

Mojave is more ferociously sandboxed than previous versions of the OS.

Does that help?


This type of problem can spontaneously* happen, particularly in cases like yours, shortly after a system update. If you search the Web for these error messages you’ll find there is no clear understanding of what causes it—I even saw one poor person end up with Finder unable to execute because it supposedly wasn’t code signed correctly—or how to fix it, either.

I had this happen recently with an older copy of OmniFocus. A simple fresh download and reinstall fixed things up for me. But I know that isn’t a reliable fix.

We’ve also seen a case where rebooting to safe mode allows the software to be run from there, and then once you do that it seems to unlock it in regular mode. So that’s something to try as well.

Personally, I would upgrade to the latest 10.14 as soon as you can. It’s a big download, but Apple always releases beta quality, and that’s not a good place to be sitting in for long, with an operating system. Plus, it might “fix” the problem—not through any specific bug patches (they’ve left this one around for years), but through simply forcing the system to rebuild the kind of stuff used verify certificates and such.

  • Well, only Apple really knows, but there seems to be no outward pattern to the types of programs that can be impacted by this malfunction.

Many thanks for all of this. I will try downloading the full install of Mojave and the other suggestions and report back if I’m still having trouble!

Hi, I downloaded and installed the full 6gb installation of Mojave from Apple. I also disabled my anti virus software and reinstalled scrivener. In settings, software from Apple and other developers is permitted. Still getting the same error when I try to start Scrivener. Any other ideas?

Also, just to be clear (as my earlier message did not specify): I’m running 10.14.4. And booting to safe mode did not resolve the issue. I get the same problem report.

SOLVED! My employer had installed an antivirus software called SentinelOne. Removed that and everything works fine. Thank you all for your suggestions.

Thanks for the update! Hopefully that helps anyone else coming across this thread. There are still unexplained reasons for why this can occur, but it’s always good to have one more of them known.

Still experiencing the problem. No anti virus software running. Also tried the Safe mode. Please help!

I’m not sure if it would just be anti-virus (I don’t know if SentinelOne is classified as such), and some things like that run so deep they even load in Safe Mode. Also make sure the crash report matches the description provided here. This doesn’t explain all crashes. :slight_smile:

I have the SentinelOne issue on my new work machine and I can’t uninstall it.

The link to the Known Issues recommends
“If you are working in a context where SentinelOne cannot be removed from your system, you could also download a previous version of Scrivener, which has a lower level of security itself. The current theory is that Scrivener’s increased security is conflicting with security software that use unapproved methods of monitoring it.”

And links to a page with ALL the old versions.
Any idea which one I should try??