Scrivener crashing

I keep encountering a situation where Scrivener is crashing, without any error or crash message – Scriv is just fully unloading itself without warning. Running Windows 8.1, on current model laptop with plenty of memory and other resources.

I first noticed this when I selected the full Draft folder, which contains 425 sub items, for a total just over 138,000 words.

After the editor loads the Draft folder multi, when I scroll through the multi, I see the various documents and their text scroll by, each separated by the separator lines. So far so good.

As I approach the bottom of the multi, I hit a point after which no more text appears, and I end up scrolling though what appear to be blank documents, separated by the usual separator lines. Once I enter this range of the multi, Scrivener becomes subject to crashing.

If I do things that force a screen redraw, such as changing the width of the editor, I can get text to appear in those seemingly blank documents. But sooner or later, Scrivener vanishes in a poof, as though I had killed the process from Task Manager.

While most of the docs in the multi appear normal, some of them display with what I’d describe as rendering distortions, as in the pic below. I see this kind of rendering problem fairly often, almost regularly, and it is always cleared up by forcing a screen redraw, typically, by doing Ctrl-Shift-B twice to open and close binder, which then reflows the text correctly. A similar thing happens when changing the zoom level while in a multi, where zoom changes are not seen until forcing a screen redraw – that’s where I picked up the binder show/hide trick.

This screen rendering distortion seems related to something I first reported back in the Scrivener 1.7 beta days: … 60#p175360

Rendering issues aside, it’s the crashing that’s bugging me. Any idea what might be going on?

EDIT: A possible clue? Before encountering this crash situation, I was trying compile the Draft folder, and no matter what complie setting I used, when I clicked the Compile button, nothing happened, at all. Scriv was still responsive – I could still move around the Compile dialog, and the Cancel button worked as usual, but the Compile button did nothing – it “clicked,” but nothing actually happened.


The Scrivenings display issue is a known bug that we unfortunately have not been able to resolve with the current framework; it’s a drawing problem that occurs more frequently the higher the editor zoom or lengthier the Scrivenings session. I hadn’t previously seen that it also caused crashing, but it sounds like that is directly related to the drawing bug, so at least avoiding the large Scrivenings session should also avoid the crash. I’ll do a few experiments with that. Have you noticed when this happens if it’s eating up your resources trying to render?

Re: the compile issue, that sounds like something different, but not something I’ve seen. If there was no text set to compile, it should’ve popped up a message indicating the file was empty, but you’re not seeing anything happen at all? Has it worked since then, e.g. after closing and reopening the project, or is it still stuck?