Scrivener for Screenwriting

I’ve been hunting around for an answer in the forums tonight, but haven’t gotten a completely clear one yet. I love Scrivener. Been using it for a couple of years for outlining my screenplays, but I’d love to be able to write a draft in Scrivener instead of keeping it open and writing in Final Draft, as I’ve been doing for a while now or “importing” (read cut and pasting) my Scrivener outline into Final Draft’s new outliner. Besides lacking a few screenwriting features, how do I NOT write my screenplay in chunks based on my Scrivener outline? With each scene or story beat being a separate document it seems I have to write in chunks. I appreciate that I can see everything together with Edit Scrivening, but how do I write everything in one big chunk and have it reflect in the outline and inspector? Or is that not possible? In other words, I want outline my script and then write it. And as I write I want to see my outline notes change as I reach my next scene/outline beat while still seeing the previous scene a la Scrivening. Hope this makes sense.

I’m not sure if I get your entire drift, but here’s what it sounds like you want: the ability to write your screenplay as one document and see how it changes in the outline at the same time.

That’s doable, all in Scrivener, if I’m understanding you correctly. I’m including some directions below, but please bear in mind that I usually write novels and short stories, and only recently have started dabbling into Scrivener’s screenplay mode.

  1. Open your Scrivener project.

  2. Write your outline, putting each scene in a separate card, per usual.

I recommend making use of both the label colors and status text. I personally use “status” to indicate if a scene is “To do”, “In progress”, “First Draft”, “Revised Draft”, et cetera, and “label” for the part of the story that the scene’s in—be it a division by narrator, year, etc. I also use rather bright colors like lime green for “PROBLEM” scenes and ideas that may or may not be incorporated.

I don’t add keywords until I’m closer to finalizing a scene, but I’m not sure that’s the best way to work with those.

  1. Once your outline is ready to be written, split your screen. You can find that in the View menu, Layout submenu, and your options are No Split (⌘’), Split Horizontally (⌘=), and Split Vertically (⌘").

I generally prefer vertical, myself, but I’m not sure that I’m in the majority.

  1. Do you prefer your outline on the left or right? I prefer left. In any event, click on the part of the window where you want your outline, then click on the draft part of the binder. Open it with “Outliner” (a button on your header, ⌘1, or View - As Outline).

You may want to also hit Expand All (a button on your header, ⌘9, or View - Expand All).

  1. Click on the remaining pane (if you put your outline on the left, click the right), where you want to write your screenplay all as one document, and again click on your draft folder.

Activate Edit Scrivenings (a button on your header, View - Edit Scrivenings, or option-cmd-1).

  1. You’ll most likely see a faint horizontal striping on the part of the document with Edit Scrivenings on. Notice that the top of the entire window as well as the part of the header that shows the notecard and back-and-forward arrows both show you which document you’re actually in within Edit Scrivenings. Write your first notecard’s scene, then use your down arrow to activate the next file before typing the next—in effect giving you one large window of sections to write in.

If you want to make the stripes more or less obvious, check out Preferences (⌘,), Fonts & Colors section, and change the “Editor background” and “Alternate scrivenings”.

Um… That help?

Helps a LOT! Thank you! It’s now VERY close to what I need (minus the necessary running page count), but I’m finding one niggling issue. When I arrow down to the next scene it automatically goes to “General Text” which is annoying. Generally if you’re starting a new scene it should start on “Scene Heading.” Do you know of any way to change the default so when I start a new story beat in Edit Scrivening it will automatically start as a Scene Heading? Thanks again.

That would be something you’d have to set up when making the outline, I think. You can make a new document by hitting Return while having the Binder selected. When I just tested it, if you change your first document to start with a Scene Heading and make your outline from there (hitting Return with Binder selected for each new entry), it works for what you want. Someone else might know some other methods.

For how to change the files easily now that they’re already set up, when you arrow down into a new document, hit ⌘Y then S.

As far as the running page count, pages aren’t exactly in Scrivener’s purview.

It appears that I did write the outline with “Scene Heading” as the default and when I write within the document/outline beat/scene it starts with Scene Heading. However, when I try and use Edit Scrivening it defaults to General Text. Not sure how to remedy. The command key plus Y and then S is a bit cumbersome for my taste. Either way, I appreciate your help thus far.