Scrivener has created a weird duplicate of my project?

Hey guys, bear with me while I try to articulate the weirdness that Scrivener is putting me through right now.

I opened my file yesterday in preparation for NaNoWriMo, and noticed that my sidebar currently looks like this:

Scrivener sidebar.png

As you can see, there are two copies of everything all of a sudden. I didn’t duplicate anything. The word counter is registering an extra 350k that I haven’t written, which is bugging me to no end.

The TOP copy of the manuscript doesn’t want to show up in compile, despite all the scenes being checked as “include in compile”. It also won’t let me add any folders or text files. The BOTTOM copy will let me add things, but I’m not so sure about compile as I haven’t tested it yet.

I’ve noticed that whatever I do to the top copy, also happens to the bottom copy. If I uncheck “include in compile” on a scene in the top, the corresponding duplicate scene also becomes unchecked. I was hoping that I could just omit all the scenes in the top copy from the compile so my word count would look accurate, but that doesn’t seem to be possible.

I should also note that I’m currently working from a back-up that I had the wisdom to create last night when all of this stuff started. I decided to try and simply delete the top copy of the manuscript and - well - Scrivener ate everything, possibly because the duplicates seem to be connected somehow. If I hadn’t backed anything up I would have lost about 350k, but all I’ve lost is 1500 words that I wrote today.

I hope this makes sense! Does anybody know what’s going on, and how to fix it?

EDIT: Not a fix so much as a solution, but I got around the problem by starting a new project file and carefully copying everything over chapter by chapter. Seems to be okay so far, but I’ll squirrel the dodgy file away somewhere safe just in case I need it. Gonna be backing up obsessively from now on!

I experienced a similar phenomenon with one project converted by the latest Linux version. The project appeared fine just after conversion. After making a few edits and quitting for the evening, I awakened to find my project in triplicate, with all the folders jammed to the left side and no project title. I am glad to see that you experienced this, for it reveals that the problem is not Linux specific. k

I haven’t seen anything like this before. Could you send a zipped copy of the affected project to AT literatureandlatte DOT com so I could take a look at the .scrivx file producing this? Or if it’s too large to send, we could work out sharing a Dropbox folder or such to transfer the project.

Is the project normally stored in a synchronized folder (like Dropbox) or monitored by some kind of backup service?

During my trial I had a similar issue.

I went to bed with one manuscript folder, opened it this morning and I now have three. The contents aren’t the same. Unfortunately, the folder that has the edits I’ve made won’t compile and won’t copy to the folder that will.

I also lost some items in my meta_data and project keys and items in my characters and templates folders.

I registered and activated, closed and restarted. Still corrupted.

I Saved As to create a copy. Still corrupted.

Any ideas why this is happening? I don’t want to use the program and begin importing MS Word drafts of my existing novels (series) if this is going to keep happening. (am hoping this is just an issue with the trial and after recreating the book I was working on, it no longer happens)

Could you send a zipped copy of the project’s .scriv folder to AT literatureandlatte DOT com so we can take a look directly? We have only seen these few reports of this, and we don’t know what may be causing it. Having a sample project that we could examine would help considerably, and hopefully we would then be able to resolve the issue for you.

kelzadiddle’s solution of creating a new project and dragging over the wanted binder items to copy them and their metadata to the new project should also work, or you could restore from a backup if you have created a recent one. (If you’re leaving your project open for extended periods, like overnight, I suggest changing the automatic backup settings so that you can easily trigger a backup with Ctrl+S, or ensure that you’re manually choosing File > Back Up > Back Up Now to get regular backups.)

Even if you try one of those fixes, I’d really appreciate a copy of the corrupted project so we can figure out what’s behind this bug and get rid of it for good. If you’re not comfortable sending the project as-is, you can use Save As to create a copy, then use the project replacements to scramble the text throughout the project–so long as it shows the same problem as the original, that should be fine. You can then use File > Back Up > Back Up To… to create a zipped copy to send to support and delete the scrambled copy.

Zipped and sent - although I was in process of attempting to fix it, so it might not be a perfect representation of the error anymore.

To be clear, I had exited Scrivener and upon reopening this happened. :slight_smile:

Thanks, I’ve got it and will take a look. It appears to have three “Manuscript” folders, two of which appear at quick glance to have identically named contents with custom icons (I haven’t looked closely, so I realise from your previous post they may be different); the third has a clearly different set of documents. I’ll follow up with you in the email for more details on the specifics.

Since this was the appearance after a close and reopen, did you have a backup to check? I’m curious what its state was or is. Actually, if you have the previous two backups–the one made when you closed the project last before it opened with three Manuscript folders, and the one made before that–could you send those zip files as well? I’d like to compare the .scrivx files from before and after the crazy happened.

Same thing happened to me, twice I think. Did you at any point get a dialog that said something like, “There may already be a copy of this open on your machine. Do you want to create a copy and open that instead? If you open the same thing twice you may lose some data.” ?

It’s just a shot in the dark that it had something to do with it.

Either way, this is what I did. I created a new scrivener document, and then had the messed-up version open on the left side of the screen, the empty one on the right, and then I dragged the entire contents of “Draft” into the new “Draft” folder, same with “Research” and whatever else you might have. Seems to have worked fine. Obviously would be better if it didn’t mess up in the first place, but this worked for me.

edit: Side note, I am talking about dragging documents from one scrivener window into another with a different file open in it. I wasn’t sure it would work, but it did.

I think I´m having a similar problem with my project.
I tried to create a new project and moved all the files from the original. But It didntt work. The first time I reopened the new project, the folders were again duplicated and incomplet (some of the chapters werent there anymore).

I`ve just found this topic now, and today earlier I started an other topic descriving my problem.

One curiosity is that the problems started yesterday, when I put the serial number licence in the software.


Anyone know if there’s been any progress on this issue and what might be causing it? (I saw some users might have sent their Project in to be examined).

This has happened to me twice. Judging from the forum, it seems to be a fairly recent issue?

The first time this happened I restored a backup, moved some folders into it and deleted as needed. But the backup copy must still have been corrupted, hence it happened again. Am now in process of creating a completely new Project. Hoping that when I drag/drop files into it, I don’t drag/drop the bug or corrupted files into it.

Thank you.

I have had this problem in the last week.
I have a habit of keeping backups of files within scrivener (rather than using snapshots which I only discovered in the last few days) so I think that may have triggered it. Its a large project at this stage so any help with a fix is appreciated.

Replying with a fix of sorts.
This doesn’t fix whatever caused it in the first place but I was able to remove the duplicates from the project by doing the following:

  • install an xml editor
  • open the .scriv file in the xml editor, viewing the file contents as xml
  • deleting the branches of xml that were duplicate. This deletes the pointers/shortcuts to the files.

This is potentially hugely dangerous in terms of corrupting the file but it seems to have worked for me…I have backups if I need them but didn’t want to lose a significant amount of recent work.

Remarkably when I opened up the older version of the corrupted file (which I had renamed) Scrivener seemed to fix it as well.


Deleting just the duplicates within the .scrivx should be fine, if you were careful not to delete all copies of the Draft, Research, Trash, etc. I’d run Tools > Save and Rebuild Search Indexes also to make sure that is cleaned up.

Irritatingly, we’re still in the dark about what could be causing this sort of replication within the project file. If anyone has a backup copy of their project from before the replication occurred and would be willing to send that to AT literatureandlatte DOT com, we’d hugely appreciate it. If we can manage to reproduce the issue ourselves, or spot something amiss with the file that might have triggered everything going haywire, it will help significantly to find a fix.

Are the projects affected stored in a syncing location like Dropbox or OneDrive or monitored by a backup or security software?

Hi, the same thing has just happened to my project. There are now two Draft folders with duplicated scenes in them. I discovered this when I opened a scene I had finished the day before, to find an old version in it. After some tense moments of panic, I discovered a second Draft folder, and inside that was the latest version of the scene. Seems if I make changes in the one folder, it’ll translate through to the other, but not vice versa. And when I tried to clean it all up, thinking that somehow I must have made the duplicate, the files would go into Trash, but remain in Outliner view, as if they were still part of the manuscript. Once I realised that this level of weirdness had nothing to do with something I’d done, I consulted the forum.

I suspect that the problem has to do with converting over to Windows 10, which I only did at the end of April. I have checked my backups from before the switch to 10, and the manuscript is correct. The very first backup after the switch to 10? Messed up.

MimeticMouton, I have emailed you the backup files from pre 10, as well as the file post 10 (to the windows DOT support address). Hopefully you can find the glitch and let us know what to do about it. Until then, I’m going to try copying new work backwards into the pre-Windows-10 backup and see if that works (though it might well get corrupted again.)

In case it helps someone, I can reproduce this problem reliably by terminating the Scrivener Windows process instead of having a graceful shutdown using File/Exit. So perhaps a Windows crash would also cause it.

I had created a Windows macro that would terminate Scrivener automatically if I had accidentally left it open for a long period of time on another machine to avoid Dropbox sync problems. I was getting duplicate after duplicate of Draft and Research. I was terminating the process this way because it doesn’t seem possible to mimic mouse/keyboard clicks once a screen saver has kicked in. (A command line interface to a Scrivener command to do this would be very useful!)

I removed the duplicates by editing the .scrivx file with an XML editor but then noticed they started building up again everytime the Scrivener process was terminated.

Hope this provides some clues in fixing the problem.