Scrivener has started crashing

I switched to El Capitan (a.k.a. Mac OS 10.11) recently (I do not know how long ago exactly). starting today, I can’t open Scrivener successfully.

if I could, I would cut and paste the crash reports but while I can open up a crash report easily enough (Scrivener crashes whenever I try to open it) I can’t copy it.


Are you using the Scrivener 2.6.5 beta? We don’t recommend using 2.6 on beta OS X, the 2.6.5 build fixes known issues.

That said, crash on start like this is a known pattern, we think at this time the 10.11 updater corrupts or changes files in such a way that it causes certain programs like ours to crash during the startup sequence (in fact, before Scrivener even gets a chance to start running). It’s hard to say without a crash log though. You might check in the ~/Library/Logs/DiagnosticReports folder for them.

If it did work initially but now it doesn’t, that might not be the problem after all. The first thing I would try is loading Scrivener with the Shift key held down to stop any auto-loading of projects, then load your typical projects one by one and see if they crash the software.

thank you for getting back to me quickly. I did not know about the 2.6.5 beta. I will DL it ASAP.

since you suggested it, I tried opening 2.6 with the shift key pressed down. still no success.

yes, thank you! it worked.

Great! Glad to hear it was just a 2.6 bug, the beta will go live as 2.7 within a matter of days so it will be ready for when 10.11 is official.