Scrivener has stopped working completely

I’ve been having problems since I updated my scrivener earlier this month. I lost information and haven’t been able to recover it.

Today, scrivener loaded to 90% and then unloaded to 45%, getting hung in the process. I did not touch it. I just opened the program the way I normally do. I tried several times to access it with the same result.

I don’t have a virus. I have Bitdefender and have run it, CC Cleaner, Superantispyware and Malwarebytes just to make sure the error is not on my side. Nothing came up.

When I shut down scrivener last night, everything was fine, except for the missing files after the update. By the way, all the files were in a different order when they came up after the update. So, things have not been right since the update.

Can you suggest something? I’d like to at least recover my chapter and character notes so I can transfer them to my macbook.

I’m going to try rebooting. :frowning: I’ll be back.

I rebooted. Same problem. It loads to 90%, then goes down to 45% and gets hung. Also, I’m doing this as system administrator because it won’t respond at all in regular mode.

This couldn’t have happened at a worse time. I’ve got an editor at Random House waiting on my manuscript, and I can’t access the most current version.

I’ll check in later and see if anyone has any ideas. Thanks. I’m off to patch the manuscript together from my flashdrives and see if I can’t submit it on Word.

And yes I really would appreciate your feedback and help. I’m sorry if I seem grumpy…but it’s really more panic than anything else. I know I’ve lost some data, and that represents a lot of time and energy and blood, sweat and tears. I’m sure since you deal with writers, and some of you might be writers yourselves, you can understand how upsetting this is to me. But that doesn’t mean I don’t appreciate your time in helping me out.

OK. I’ve got it open, but I’m afraid this will happen again. This is windows 8 I’m using on my PC. I clicked on the compatibility issue test and my computer opened the scrivener file as having one. It opened the program to allow me to report it to Windows. Does this make sense to anyone?

Now that they’re open, I can access my manuscript on Scrivener. It’s fully loaded. I won’t close it on purpose, but when windows does updates, that issue will be taken out of my hands.

There was no update for windows on my computer today or yesterday, so, I have no idea why an incompatibility issue would have happened now.

Unfortunately, the lost file issue was not resolved, because that happened with the scrivener update a few weeks ago. I dealt with that by manually updating things.

I don’t know if I’ve given you enough information to figure out what’s happened or not.

One can launch Scrivener to open a specific project, in Windows Explorer or My Computer, by navigating to and into the project’s .scriv folder and double clicking (or right clicking, then opening) its .scrivx file (typically named project.scrivx). Likewise, if one can manage to get into Scrivener, one can set Scrivener to not automatically open most recently open project(s) on startup, via Tools > Options > General > unchecking “Reopen projects that were open on quit”.

Let’s assume you have multiple Scrivener projects on your PC, with one being the problematic project and the other being a new test project created from scratch.

If the startup problem occurs when opening the problematic project, but not when opening the other, then the problem is in the problematic project. There are discussions in the forums as to ways to go about dealing with corrupted projects. If this turns out to be what you need and you can’t find such, post back here and I’ll take a stab at locating some.

If the startup problem happens regardless of which project, or no project, is being opened, then the problem is with the installed instance of Scrivener and you need to uninstall, re-download a fresh copy and reinstall Scrivener. Avoid using the updater. Avoid using an already downloaded copy.

NOTE: This will not impact projects, as they are normally stored elsewhere than in the Scrivener program directory. But Scrivener will “forget” where they are (i.e. the newly installed version probably won’t “know”), so be sure to make a note of those locations before uninstalling. Scrivener projects in Windows are folders, having names ending in .scriv. Backups are either folders (names ending in .scriv) or compressed files (names ending in .zip), depending on how you specify backups be done in Tools > Options > Backup. And of course be sure you have off-the-machine backups of any on-the-machine projects, as a general precaution. Once Scrivener is reinstalled, you may have to tell it where projects and backups are/should be.

NOTE: NOTE: You will need to temporarily disable, turn off or uninstall Bitdefender, while doing the uninstall/re-download/reinstall. Before or after this, you may need to go into Bitdefender and exempt Scrivener, as Bitdefender seems to be interpreting something in Scrivener as being a threat (which other such software such as Malwarebytes and Norton Internet Security do not). A search of the forums for “Bitfender” turns up several reports of issues between it and Scrivener. It can presumably be turned back on after all that is done. Malwarebytes and Windows 8 are not a problem. CC Cleaner is probably not a problem. I can’t speak to Superantispyware. The Windows 8 compatibility issue you mention is likely a side effect of issues between Bitdefender and Scrivener during the Scrivener install… i.e. Windows saw Scrivener have startup problems and interpreted that as likely being a compatibility issue).

Hope that helps.

Thank you, springfield. I will try and find where scrivener is saved in windows. I’m not sure how to get into system files from Windows 8, but I know there is a way to do it.

When I had the two projects open, I exported the files to a flashdrive, too. It’s very strange that windows finally opened the projects as part of a compatibility check.

I have no idea why I’m having the issue I am, but you are right that one or both projects might be corrupt. I just know that things started to get wonky after the latest update. I manually updated it, which might have contributed to the issue. Perhaps bitdefender interfered with the update. I don’t know.

The scrivener version on my MacBook is fine. I think I will just use it until I can figure out the issue with this one. I haven’t imported the entire novel to the mac version yet, as the mac is new.

I’ll look in the forum to see about corrupted files. Thanks again.

As far as determining location of existing projects and backups and Scrivener itself…

If you are opening projects by navigating to and clicking on their project.scrivx files on the desktop or in File Explorer or My Computer, etc., then you know their locations.

I was hoping to be able to say that if you are opening most recently opened project(s) by launching Scrivener, with Scrivener set to open most recently opened project(s), you could then to find the location of a currently open project, within Scrivener, by going into File > Save As and seeing where it proposed to save the new copy of the project… But that doesn’t seem to be the case. Worth trying, just to see where it points… but on my system it is pointing at a folder I compile to, rather than where it opened the project from.
If you are feeling adventurous, you can download and unzip/decompress and run Microsoft’s free Process Monitor utility and use it to determine the file system folder being accessed by Scrivener.exe … 96645.aspx

To determine where Scrivener is storing backups, in Scrivener, go to File > Options > Backup and make a note of the location specified in “Backup location:”.

Beyond that, can do a general search or scan for Scrivener projects (folders whose names consist of project name, with .scriv on the end), Scrivener index files (names ending in .scrivx, typically project.scrivx). Backups will either be folders (names consisting of project name plus a date time stamp, with .scriv on end of name) or compressed files (names consisting of project name plus a date time stamp, with .zip on end of name).

As to where Scrivener is installed, find the Scrivener shortcut/icon on the desktop or in Start menu, right click, select Properties. By default, it will be something like C:\Program Files (x86)\Scrivener
Normally, projects would never be stored there.

I’d be wary of CCleaner and make doubly sure that it is not allowed access to any of the Scrivener project files. Scrivener projects are made up of many smaller files, some of which may be created and then not modified again for a long period. If CCleaner “optimises” your system by archiving those files, it would corrupt the project. From what I can tell, CCleaner mainly deals with trashing junk files from browsers and cleaning your registry (something else you want to be very careful about), so it may not be affecting your projects at all, but I would definitely check out all its settings to make certain your Scriv projects are out of its reach.

I am back to the same problem because I had to turn off my computer. When I clicked on the scrivener icon to open the program up, it locked first at 90% loaded and then reducing to 45%. I cannot access any feature of scrivener. I am unable to open any project because it’s frozen. So, I guess it doesn’t matter where I try to open the scrivener file, the actual program will not load. I cannot access any scrivener files at all.

About CC Cleaner, I have been using it successfully with scrivener since I bought the software for my pc. CC Cleaner has not affected my Macbook version of scrivener at all, but I will stop using it.

I think the program itself is corrupted on my PC. I can’t even open a new project. I can’t access any feature at all.

I run adblock and ghostery on my PC. Could these be interfering with scrivener? Are there ads or tracking cookies written into the program?

I have been using them successfully with scrivener for quite some time…but perhaps the new scrivener update is not compatible with them. Everything went wrong after the update.

Would it help to go back to an earlier version of scrivener?

No, neither of those should affect running Scrivener. If anything, it would be something like BitDefender hijacking the installation because of the third-party converters used for certain compile formats. We’ve seen a couple cases of this, with 1.7.1 and earlier versions also, where BitDefender flagged and quarantined Doc2Any files. In the cases I know of, this has caused problems when trying to compile and not initially at launch, but since you did mention BitDefender specifically, I’d try disabling that during the installation and keeping an eye for any activity when you do go to compile. Scrivener does check whether Microsoft Office is installed in order to set the default converters, so it could be that that’s what’s hosing the launch on your machine.

So to recap: try doing a complete uninstall, which will clear the program settings and get rid of any potential gremlins there. Then get a fresh download of 1.7.1 here. Disable BitDefender and install Scrivener, then try launching it. Since you did the uninstall, it should just go straight to the New Project window rather than trying to auto-load any existing projects, which could also have been freezing it.

If that all works, you can switch on BitDefender again.

Then, in Scrivener, go to Tools > Options and in the General tab, deselect the option to automatically load projects that were open on quit and hit OK. Now try opening your main project. If it spins and doesn’t load or crashes Scrivener completely, we at least know the problem is with that project particularly, and we can focus troubleshooting there. Having disabled the auto-load option, you should still be able to get Scrivener to relaunch so you can access other projects.

Give it a shot and let us know how you get on!

Thank you, MM. I will look into that this weekend.