Scrivener in WINE Keeps Crashing

I’m a bit of a Linux newb, so please be patient with me. :smiley:

I downloaded the latest Scrivener for Windows beta and installed it on my netbook, which runs Ubuntu Desktop 10.10. I’m using Wine 1.3.5. Every time I try to open Scrivener, the program just crashes. It ran fine the first time I opened it, but crashed once I tried to create a project. Can anyone out there help me fix this?

Your help would be very much appreciated! :mrgreen:

Can you run it from a terminal and paste the text you get? It’s hard to diagnose a problem without anything to go on. Have you installed all the things you need to from winetricks? Are you using the latest version of wine?

I’m not very familiar with the commands yet. How do I start the program via the terminal?

Also, I tried a little while ago the DEB version that was posted on this site (but I’d still prefer to run the Windows version via Wine). Is there a way to get the window to fit the screen? I’m on a netbook, and Scrivener automatically maximizes whenever I open it. However, it doesn’t fit the whole screen. The problem with this is that whenever I click on something in the program, the window automatically jumps to the bottom.

Thanks for your help! I appreciate your patience in dealing with this Ubuntu newbie. :smiley:

If you open a terminal, then go to where Scrivener is installed (It’ll be something like .wine/drive_c/Program Files/Scrivener), type “wine Scrivener.exe” (without quotes) Then when it crashes, copy everything from the command you typed until you get a prompt (it’ll be a huge chunk of text) and stick it in a text file. You can upload that here or at

to get to the folder, do "cd .wine/drive_c/Program (hit tab here to get the full name)/Scrivener. If you don’t have tab completion in your shell type: cd .wine/drive_c/Program\ Files/Scrivener (exactly as typed, you need to use the \ as an escape character, so you can type spaces.

While you have a terminal open, type “wine --version”. (No quotes) If it’s anything before 1.3.5, you’ll need to upgrade.

If you want to dump the output of wine to a file, type: wine Scrivener.exe &> ~/scriverror.txt It’ll create a file in your home directory called “scriverror.txt” that’ll contain all the info.

Does that help? :slight_smile:

Absolutely. Thanks for your help. I appreciate it. I was entering in those commands, but I kept writing “Program Files,” so it kept saying that the directory wasn’t found. I’m attaching what the terminal showed.

BTW, I’m running version 1.3.14 of Wine.
scriv.txt (25.6 KB)

Ooooh. Okay, I know what the problem is… :slight_smile: It’s actually really easy to fix.

You need some stuff from winetricks first. if it’s not installed with wine, go here:

Once you get it, you need the following things installed from winetricks: vcrun2008, vcrun6, quartz, and dotnet20

Once that’s done, you need to go into winecfg (type winecfg at a prompt.) Once there, click the library tab.


As you can see, if you installed the things via winetricks, the libraries should already be there. (I have a couple other things, so don’t worry if yours doesn’t look exactly like mine.) IN the new override for library area, type winegstreamer.dll and click add. Then highlight it down under existing overrides and click edit. Check “disable.” It’ll crash Scrivener, if it’s enabled.

And you’re done!

If you use any other programs with wine, you’ll want to run them with a different wineprefix, because the stuff installed via winetricks could conflict. (I have that problem with WoW, which uses a custom version of one of the C++ runtime libraries.)

And then…

If you want fonts to look pretty, install corefonts and fontsmooth-rgb. You can also put any True Type font into .wine/drive_c/windows/Fonts, and it’ll be usable by Scrivener.

You are awesome! Going to try that fix right now! Thank you so much for your help. I really appreciate it. :mrgreen:

One more question: Is there a way to get the window to fit the screen? When I tried the deb version, it was maximized, and it would jump to the bottom of the screen every time I tried to click on something. I have Ubuntu on my netbook, so screen space is limited. If not, I can just work with the program without it being maximized.

2 things…

1.) you can make it to fit your desktop, if you run it in its own desktop. (That setting is in winecfg, too.)

2.) if it’s maximized past the screen, what you should be able to do is drag it so it’s pushed off the screen enough to grab an edge. You should be able to resize it then. (At least you can do that in KDE and Enlightenment. I haven’t used gnome in ages.)

It loads perfectly. Thanks! The window problem seems to have been taken care of as well. :slight_smile:

Hmmm… It seems to be crashing again. I don’t know why. I deleted a few unrelated files from my netbook. Then I tried to open a Scrivener project I was working on using my Windows notebook; that’s when it started crashing again. I thought that it was because I have the 1.9 beta on that notebook, but the 1.7 beta on this one, so I installed the 1.9 beta here.

Thought we had it fixed… :unamused: If you can, do you think you can help me out? I’m attaching the text file from the terminal.

I really appreciate your time.
scriv.txt (9.26 KB)


Did you copy qtsvg4.dll and qsvg4.dll from your windows computer to .wine/drive_c/windows/system32?

It shouldn’t have installed without them. … r_in_Linux (More details there.)

I installed them, but nothing has changed. It keeps crashing. The problem began when I tried to open a project from my notebook running Windows 7 Premium. Could that have something to do with it crashing in Ubuntu?

Hrm…what happens if you try to open and work on a completely new project on your laptop? Is it stable, then?

One other thing you can try is when you move projects, backup your file on your windows machine by backing up to zip. then move the entire zip file to your laptop.

I installed a few other dll’s I found mentioned in a thread on the Wine HQ site. It seems to be working fine now.

Here are the files mentioned on the site:


It said to also install mingw in Winetricks.

Okay, something is really weird, because I know I didn’t have to install all those…

Thanks for all this and more! Excellent.

It worked for you? Cool beans.

I don’t think the native dlls are actually necessary anymore. I didn’t put them in .wine/drive_c/windows/system32, and it installed and ran just fine on my laptop. (This is with the most current version of wine.)

The winetricks things are still needed, though.