Scrivener Not Importing DOCX File After Import Converters Changed

I am having a problem importing a Word DOCX file into Scrivener’s ‘Research’ folder.

Scrivener will not import this file, regardless of whether I make the changes listed below.

I had originally wanted to import DOCX files which contained both text (generated in Word), and photos (.jpg’s), but Scrivener will not even import a straight DOCX file, containing only text.

Mimetic Mouton and Vincent_Vincent were helping me with this in another thread I posted here on the forums, because I always found that the import process into Scrivener stripped the photos out of my files – I was, however, able to drag-and-drop the photos back into the files, once they had been imported into Scrivener, and converted, but that can be a mighty slow process.

Because I do this a lot, I settled on the option suggested by Mimetic Mouton of changing the default import type by doing the following:

  1. File – Options – Sharing – Conversion, and under ‘Import Converters’, changing DOC to DOCX, and changing Aspose to Microsoft Office, in the box after the word ‘via’

  2. I then click ‘Apply’ and ‘OK’ (and I have tried clicking those words the other way around)

When I do the above, I get the following problems.
3. This Options section only retains the ‘Microsoft Office’ change (and it was not even doing that for the first 10 or 12 times I tried this) – i.e., when I leave the Options section, and then go back to it (using File – Options – Sharing – Conversion etc.), I find that the file extension DOC has replaced DOCX

  1. DOC replaces DOCX even if I close the Project, and then re-open it; this also happens even if I re-boot my laptop

  2. If I open other projects and try the same thing, I get the same results – DOC replaces DOCX, and ‘Microsoft Office’ is displayed in the box after ‘via’

  3. Another, potentially related problem is when I try to import a DOCX file, I get the message:

“An app on your PC needs the following Windows feature:
NET Framework 3.5 (includes 2.0 and 3.0)”

I am presented with an option to “Download and install this feature” or to “Skip this installation”.

I thought I would check here first to see if people think this is a bug resulting from Scrivener interacting with Word and/or Windows, or whether there is something in Scrivener simply not working the way it should.

7. If I save my original file as RTF, I can import it (with photos intact) into Scrivener with no problem
8. If I save my original file as PDF, I can import it (with photos intact) into Scrivener with no problem

But, because I work a lot with DOCX files containing .jpgs, I would like the convenience of changing the default import so that I do not have to import the files one at a time, and re-add the .jpgs to them after I have done that.

I would appreciate any help.


I had the same problem and in options sharing changed the import converters. Yes if change Docx to Microsoft office when you return you see the first choice of doc file in the file format menu, BUT the change to Microsoft from Apose should be there when look at Docx in the drop down. You are not changing doc to doc x but going thru the options for each file type and changing the converter protocol. I was able to import a docx file with images into the manuscript with the converter change. I could also copy and paste as well. I assume you hit apply to force the converter change before leaving the options panel.
I have windows 3.15.1 version.
Have you tried different window files to make sure the issue is not a specific file problem versus a system wide issue.
I would also try in a different project, in case the current project is corrupted.

More of my images imported are png files, but changed one to a jpg and had no problems.

1 Like

Hi GoalieDad,
Thanks for your reply.

Yes, I had said in my initial post, I had tried things like importing into different projects (and changing the import converter settings in those different projects), and also made sure to hit ‘apply’ and ‘OK’ where necessary, after changing the import converter settings.

Nothing worked for a couple of days, but for some reason, things are working now.

I will take the win without trying to reproduce the problem.

Strange, though, that this happened.

Thanks again for your reply.