Scrivener not working on Ubuntu 13.10

I updated to Ubuntu 13.10 recently. Since then, Scrivener will not launch. When attempting to launch from the command line, I get this error:

/usr/share/scrivener/bin/Scrivener: error while loading shared libraries: cannot open shared object file: No such file or directory

I have uninstalled cleanly and reinstalled with no luck. Any help would be appreciated.


PS: This is Ubuntu 13.10 64-bit.

sudo apt-get install libfontconfig1

First thing I did. It is already installed.


Sorry to hear about this. I would suppose that many (most?) Scrivener linux users use Ubuntu and that many are thinking about upgrading to 13.10 at the moment, so this would be a big issue for all of us.

I don’t have any solutions to offer at the moment, as I haven’t upgraded so can’t replicate, but I do have a couple of questions to the OP and everyone else to try and make sure we can all use Scrivener in 13.10 or, alternatively, not upgrade (yet) so that we can still use it.

So, to the OP:

  1. Have you resolved the problem?
  2. Does Scrivener work using an earlier Kernel?

To everyone else:
Has anyone else got this problem in 13.10 after upgrading?
Has anyone upgraded and not had this problem?

Sadly, no.

I’m not savvy enough to discern between kernel and distribution versions. That said, it did work fine under Ubuntu 13.04, and I keep my OS updated with patches as they were released.

I’ve upgraded and not had that issue… I didn’t have the smoothest upgrade possible (another package got hung up and gave me some issues), but so far, it’s been ok.


I’m still on 12.04 – I use my machines quite heavily for development, and Ubuntu tends to make extensive needless changes (lightdm, anyone?) that break things during upgrades. I’ve start to upgrade only to LTS releases, and only when I can spare a week or so of downtime.

As for the Scrivener problem on 13.10, try this command:

LD_LIBRARY_PATH='/usr/share/scrivenerlib' ldd /usr/share/scrivener/bin/Scrivener

It will show you the library that Scrivener can find at runtime.

Probaby Scrivener needs the 32-bit version of the fontconfig library, libfontconfig1:i386. It is possible that the 13.10 upgrade removed this during its cleanup (Scrivener doesn’t appear to list it as a dependency).

It seems Ubuntu 13.10 went to a multi-arch approach. The old ia32-libs package is no longer available. There are many libraries missing beyond libfontconfig. What a mess.

At this point, I’ll have to decide whether to move back to 13.04 or move to the Windows version.

Somebody running that Second Life game posted a way to make their program run, perhaps that would apply to 13.10 and Scrivener?

Yay! It worked for me! Thank you very much, thorjansen!

Adding the raring repository and installing ia32-libs worked for me as well.

I’m not sure what this means for Scrivener and Ubuntu going forward. I leave that to the developer, but I can’t imagine it’s going to make anything any easier.

Maybe it’s time that closed-source developers started releasing 64-bit builds of their software instead of 32-bit.

It’s been over ten years since x86-64 was introduced to the marketplace. I doubt that even Intel still produces desktop/laptop CPUs that aren’t 64-bit.

On Ubuntu 13.10, ia32-libs is gone, and you’ll have to either use a workaround, or install the :i386 files.

For 13.10, I had to run :

sudo apt-get install  libgstreamer-plugins-base0.10-0:i386

See this askubuntu post, which covers the method I used :

So, for the current version, I ran :

ldd /usr/share/scrivener/bin/Scrivener | egrep 'not found'

I had to find the packages which contained those libraries, so I installed apt-file (I believe you could also use dpkg -S) to find the proper ones. Once there, you can append :i386 to get what you’re missing.

Just for the record – the deb installs perfectly under the 32-bit version of Saucy, using dpkg. I haven’t tested much, but the install didn’t throw out any error codes and nothing obviously unusual popped up in 2 minutes of using it.

I tried installing the ia32-libs file(s) using sudo apt-get, and it couldn’t find them. However it did say that ia32-libs had been replaced by three other files. I installed them, it added another during the installation, and when I installed Scrivener it worked just as it did with 13.04. I’m sorry, but I didn’t record the names of the files. However if you try installing ia32-libs in a terminal window, look for the suggested files and install them. Worked for me. J

I installed the latest Ubuntu, and then diligently followed the tutorial; but, the Scrivener install failed miserably on 64 bit Ubuntu 13.10:

What needs to be written is the answer to these two questions:
Q1: How do we figure out WHAT 32-bit libraries need to be installed on the 64-bit Ubuntu?
Q2: How to install THOSE libraries!