Scrivener on iOS says synced to dropbox, but files not updated in dropbox

I’ve recently bought an ipad mini and set it up with Scrivener and Dropbox. I’ve set up the sync settings as per the guidance in knowledge base, using the default folder (Apps/Scrivener) and happily made some edits while I was away. I’m now trying to sync my ipad version back to dropbox.

I click the sync icon and it says it’s synced to drpobox, but when I tried to open the project in dropbox on my desktop none of the edits appear. It’s not a problem syncing from dropbox to the desktop - the files are not up to date on the dropbox app either. So why is it saying it’s synced when it clearly hasn’t, and how can I get it to sync? My test project that I set up in order to get the sync to work seems to sync fine, but my real scrivener project that I’m working on won’t sync. The test project actually seems to think for a second before it says it’s synced, but my real project just immediately says it’s synced. But then every time I open it it says it needs to sync, so I say Sync now, and yet it’s still not synced and says the same thing next time I open it.

Is there a way I can open the individual numbered document files on the ipad and copy them manually? When I go into Files on the ipad and navigate to the scrivener folder it just shows me the project which opens directly into scrivener, not the individual files.

I’m now stuck with a project I can only edit on the ipad - extremely frustrating

Are you sure your real project is in the “Dropbox” section of the projects list, and not in the “On My i[device]”? Are you sure you’re editing the project that’s being synced from iOS to your Mac, instead of a copy with the same name that’s located elsewhere on your Mac?

“Are you sure your real project is in the “Dropbox” section of the projects list, and not in the “On My i[device]”?”
Yes, it appears under Dropbox - there is nothing in the ‘on my ipad’ section

“Are you sure you’re editing the project that’s being synced from iOS to your Mac, instead of a copy with the same name that’s located elsewhere on your Mac?”
Not sure what you mean by this - I’m editing something on my ipad, how could it be something located on my computer (Windows, not Mac). I make changes in the copy on my ipad, I press sync, nothing changes in dropbox (including in the web version of dropbox).

Just now when I pressed sync again, something did happen and some folders were changed on dropbox, but they were only binder.mob, mobile.settings and recents.txt. No .rtf files were uploaded

More weirdness - I was playing around and clicked on the upload files option, which takes you to recently edited files, including the rft files you’ve been editing. I accidentally added this to my project (it’s really unhelpful the ipad having picture icons with no explanation so you don’t know what’s going to happen until you click them…). So now I have a file 774 sat in my binder. This seemed to trigger an update to dropbox - there is now a filed named content.rtf that has been uploaded, which has the same content as 774.
But more weirdly, file 774, which is the scene in the binder I was editing, doesn’t have the content I see in the binder for that scene. So where on earth are the changes to that scene being saved? And how do I see the actual .rtf files that are being saved on the ipad, if I can’t access them via the Files icon on the home screen?

OK, so now if I make a change to the project it’s saving it in a Mobile folder and not in the normal location, and when I open the project in scrivener it’s put those in a separate ‘synced documents’ folder.

But - it still hasn’t done anything with the changes I made before. Those have not been synced at all
And - why is it doing this? Is it supposed to put them in a temporary folder? I thought it was just supposed to sync them back into the project. I didn’t have scrivener open on the laptop when I did the sync.

Hi Aparine,

Yeah, I was a bit confused from your first post, as I think rdale was. It wasn’t clear to me how and where you were confirming there is an issue.

If it’s any consolation, it sounds like you nearly have it working.

For that test project that you synced successfully, were you able to make changes in iOS Scrivener and then see them on your PC? And were you able to make changes to the test project on your PC and then see them in iOS Scrivener? I’d like to confirm that you were able to see a successful round trip.


A guide to setting up iOS synchronization can be found here: … g-with-ios

If the files on the iPad are not appearing in your account at, you have a Dropbox configuration issue and may need to contact their support team.

It is normal for documents created on the iPad to appear in a separate “Mobile” sub-folder within the project. That facilitates conflict resolution (if necessary) with the desktop version of Scrivener. However, if they’re ultimately appearing in the “Synced documents” folder in desktop Scrivener, you may be using the Sync with External Folder command. That command is intended for sharing projects with third party programs, and should not be used for synchronization with iOS Scrivener.


How did you do this? How did you open the project on the desktop? Double-clicked the .scrivx file found in Apps/Scrivener/projectname.scriv ?

OK, firstly - yes i was looking in apps/scrivener for the files and they hadn’t been updated

Secondly - thanks for confirming that this Mobile folder is normal. I didn’t see this mentioned in the guidance. However, I didn’t touch the External sync. When I came to open the project I got a message saying i needed to sync and then it said something like there was a conflict and the files would be uploaded to a new folder.

Thirdly, and most importantly - the changes I made on the ipad have now disappeared. Fortunately I had copy-pasted into a word file and saved them to email to myself. So I assume the reason they weren’t syncing is that scrivener didn’t save them properly. Or that they were later overwritten somehow by syncing. I’m a bit surprised though, as in the interim I had powered off my ipad, restarted it and the changes were still there. But now they’ve gone.

This is a bit worrying for future use

In future, how can I confirm the changes have saved properly?
And/or how can I see the actual .rtf files that are saved - I can’t see a way to find them on the ipad

You can begin by describing in detail every step of what you did. Step by step, from the iPad to the PC. What commands you did, etc.
There are lots of users (I am one of them) who have used iPad and Mac, going back and forth, without a glitch. So you must have done something, or not done something, that caused things not to work.

So, a step by step description of what you did, please.

Hi Aparine,

Were you able to get syncing working? That is, changes made on one device are synced to all other devices?

I can’t tell from your post whether to help you debug a problem or give you advice on syncing best practices. :slight_smile:


Thanks for assuming I’m stupid and not that something actually went wrong. That really made me happy.

This is what I did as far as I can remember it:

I copied an existing scrivener project named caravan story into the dropbox folder on my laptop within windows explorer, in the Apps/Scrivener folder
I checked it had synced to dropbox
The next day I opened caravan story in scrivener on my ipad
I made some changes.
I pressed sync, but I couldn’t sync as I was on a train, so had no wifi
Later on, I got back home and had wifi
I clicked the sync button on the ipad scrivener. I got a message saying dropbox is up to date (it did not say uploading files, or finishing up, just immediately said dropbox is up to date)
I turned my laptop on and looked in the dropbox folder on my laptop in windows explorer. Nothing had uploaded.
I then went to the dropbox website to see if it was a sync problem with the laptop. I found file 774.rtf within the Data folder which corresponded to the scene I had edited. It had not been changed. At this point there was also no folder Mobile
I went back to the ipad and pressed sync again.
The exact same thing - it said dropbox up to date, but no other messages. I checked again - still no changes. Repeat multiple times
Finally, I decide to make an edit to the test project on the ipad I had set up originally and press sync
And something happens - scrivener says it is updating files. Files download onto my laptop version of dropbox. A folder Mobile appears within the Test project. So the sync worked for the test project, but not caravan story
So I start playing around within caravan story on the ipad. At some point I click on the upload button, and some files appear under ‘recent documents’, including 774. I accidentally upload it to the project. Again, something happens when I sync - a Mobile folder appears in the caravan story folder in dropbox
But - file 774 which I’ve accidentally uploaded is the original version, not the one with changes
So I think - I’ll make another edit to caravan story while I’m online and see if this prompts something to work.
I do this - and more files appear in the Mobile folder in the caravan story project. When I open then, they relate to the change I just made. But the original edits I made still don’t appear
So then I think - what happens now if I open the caravan story project on my laptop from the dropbox folder. I do that and get a message saying something like there is a problem with indexing, do I want the files to appear separately under synced documents - so I say yes.
In caravan story on my laptop there is now a yellow bar across the top of the sidebar saying ‘synced documents’. This shows the recent changes I made. But still not the original change I made that I was trying to sync
So I’m starting to wonder - did my changes save anywhere at all. I copy paste the changes into word and email them to myself. Then I turn off the ipad, expecting the changes to have disappeared when I turn it on. But no, they are still there.
I probably give up at that point - I do some other stuff in scrivener on my laptop on a different project, sequel, and save it into apps/scrivener
The next day sometime, I decide to try again - I sync, the new project sequel is loaded, I make changes on the ipad, and I sync again. This time ipad scrivener says it’s uploading about 10 files. Oh good, maybe this time it has worked. The changes appear on my laptop in apps/scrivener - great.
At some point after this, I go into caravan story on the ipad - and this is when I see that the changes I had made, that I had such trouble with, are gone and replaced with the original text

So, as far as I can see, I am not a moron, I have not done anything other than what I was supposed to do, but those original changes I made to caravan story never uploaded to dropbox, even though scrivener kept saying that dropbox was up to date. And then they disappeared altogether.

As far as I can tell, the edits I made to sequel synced perfectly. But I still don’t understand why the other changes didn’t sync. Could it be something to do with the size of the project? Caravan story is a 30 chapter novel with loads of notes etc, where sequel is only about 10 chapters, mostly with hardly any text. There was also an issue where I lost the original version of caravan story and had to use a backup from google drive (I had to sort out the file extension for all the comments files, but otherwise this appears to be sorted).

I am really frustrated, as I fundamentally can’t trust an app which says that dropbox is up to date, when dropbox clearly has not been updated. If this was a problem with dropbox, I would surely get a message saying ‘dropbox can’t be updated now’ or something. So I can only conclude it is an error with scrivener. And I’ve only just bought it on ipad so it’s not an old version. I have version of scrivener on windows.

Please can you help with this

… and before doing that, you had to wait for a fair amount of time while Scrivener downloaded your project, checking file list and the downloading, and finally saying “up to date”? With such a big project that must have taken a noticeable time. Just to get things clear.

No, I don’t assume you’re stupid, but there is usually some simple explanation so it’s best to rule out any user misstake before one assumes that there is a fundamental bug in the app.

And on the iPad, you didn’t do something like copy the project from “On Dropbox” to “On my iPad” in the Projects screen before opening it?

Edit: I have never ever bothered to check the Dropbox server if anything worked and have never had any problems whatsoever going back and forth between three Macs and three iOS decices, counting from the first day the iOS version was released.

Yes, I waited ages for it to upload to dropbox and I also waited ages for it to download again onto the ipad.

No, I followed the instructions at … ss-devices exactly. The project was always saved to “On Dropbox”

Lucky you. Literally the first time I tried this, except with my test project, it didn’t work (since then it has worked consistently with my other project, but I don’t want to risk it with my caravan project until I understand what happened). And the reason I checked the Dropbox server was only because the changes didn’t appear on my laptop, so I wanted to know if the problem was between dropbox and my laptop or between the ipad and dropbox, and it became very clear it was between the ipad and dropbox.

As I said before, this seems to be a problem with scrivener on the ipad - because when I clicked sync it was very clearly not doing any checks or trying to upload any files, it immediately gave me the message that dropbox was up to date. And it kept on doing this every time I clicked it - until I made some new changes, which it then uploaded. I don’t know if it could have been because I originally tried to sync my first set of changes when I had no internet connection. That’s the only thing I can think I did differently with the first set of changes that wouldn’t sync, compared to the ones that have worked.

On the iPad, create a test project. Add a few lines of text. Synchronize with Dropbox.

Go to your account at, using a browser. Is the test project there?

If so, allow your laptop to sync, and confirm that the project appears. If it does, add a new file or two and a few lines of text. Repeat the process in reverse.

If you’re able to transfer the project with changes from the iPad to the laptop and back, then synchronization itself is working normally and we’ll need to look at this specific project. If not, knowing exactly which step fails is critical in locating the cause.


Question to you.

What version of Scrivener are you using?

If you are using Windows version 1.x.x , or Scrivener 2.8 or lower on MacOS, they are not compatible with Scrivener for IOS.

If you are using Windows scrivener, you can download the Scrivener 3 Beta, which is in a late stadium and quite good. If you are using Scrivener 2.8 or lower on Mac, update to 2.9, or get Scrivener 3 for Mac which I do recommend. Then you will be able to sync with IOS and work on both IOS, Windows and Mac.

I hope this helped, or you got you solution already, great.

This is not accurate. For iOS Scrivener compatibility, you need Windows Scrivener 1.9.5 or newer, or Mac Scrivener 2.8 or newer.


Hi Katherine

As I’ve already said, I created a test project and this synced fine. I have also said that syncing has worked fine with another project that I created on windows, saved to dropbox, edited on the ipad, synced back with dropbox and the edits showed up in Windows. Since then I have also made some edits to the caravan project on the ipad and synced them successfully to the windows version. So it did seem to be one particular edit that didn’t work.

What I still don’t understand is why this happened, since no one has been able to give me any explanation as to why the ipad version of scrivener would say ‘dropbox is up to date’ when it so patently wasn’t, because it hadn’t even tried to sync the files - and why it persistently said this over and over again, even after I turned the ipad off and on again.

I am making sure now that I don’t try to sync scrivener on the ipad when it has no internet connection, as this is the only thing that I can think of that was different for the edit that didn’t work, compared to all the ones that did.

Aparine, this is a good practice. Also, I also delay syncing if the internet connection seems flaky and not stable.


Hi Ap,

I have had the same trouble and I think I have an answer for you.

I believe your problem is the same one I had.

I think it is because I got changes in my iPad and Macbook out of time synchronisation.

How this happened (I believe) is that at some point I opened the iPad version WITHOUT SYNCHING before I opened the document.

And then potentially also edited again on the Macbook without closing and synching on the iPad (a double whammy).

This meant I had changes on both the iPad and Macbook that were not appears across the two.

Luckily I did not lose anything.

How I fixed it:

  • I copied at pasted all of the iPad extra content into the Macbook version and treated it as the master (I just used copy and paste and e-mailed it to myself)
  • Once sure I had everything I unlinked my iPad from Dropbox and reconnected it to Dropbox
  • Then all files and changes were there!!!

To prevent recurrence. I am now being super careful never to have two instances on the go.

Everytime I open and close the iPad version I ensure the Macbook version is saved and closed
When I open the iPad version I hit the synch button BEFORE I open the document.
When I close the iPad version I hit the synch button again before opening my Macbook
When opening my Macbook I make sure that Dropbox is synched at the top of my screen
I then open .scrivx by going to the Dropbox folder.

All working now and just acting a little overly carefully each time.

I hope that helps