Scrivener quit unexpectedly


I’ve just downloaded Scrivener 3.1.2 for Mac (from the L&L site, license purchased last year) and installed on Mojave, but every time I launch the app I get the ‘Scrivener unexpectedly quit’ message. I’ve remove any vestiges of an old Scrivener 3 installation.

In the crash log file I see:

Exception Type: EXC_BAD_ACCESS (Code Signature Invalid)
Exception Codes: 0x0000000000000032, 0x000000010ff285c0

Termination Reason: Namespace CODESIGNING, Code 0x2

It may be unrelated but in system preferences I have “Allow apps downloaded from App Site and identified developers” enabled.

Any clues as to how I can get this to work?

Many thanks,


Steps to take, if you haven’t already:

(1) Hold down the shift key while opening Scrivener so that it loads without opening any project. If that works, the problem is with (one of) your project(s) which is causing the crash; set about finding which project it is and come back here or contact Lit&Lat for help sorting it out.

(2) If (1) doesn’t work and Scrivener still crashes on opening, with Scrivener closed, go to ~/Library/Preferences/ find com.literatureandlatte.scrivener3.plist and any other scrivener.plist or scrivener3.plist files and move them out onto your desktop or somewhere you can find them again easily. Then try opening Scrivener—it will create a new default set of preferences.
If that has worked, you’ll need to go through all your preferences to reset them how they were, and you can delete the ones you moved out.

(3) If (2) hasn’t worked, delete the new preference files and move the old ones back in, and set up a support ticket at

Hope that helps.


Thanks Mark

I tried all of those with no luck, and submitted a support email last week with the crash dump attachment. No reply yet, is there anything I can do to get someone to help me with this?

Many thanks,

Did you fill out a support ticket, or just use the crash reporter? Only actual support tickets go into our internal queue.

If you filled out a ticket and haven’t received a response, be sure to check your junk folder.


I took the advice of “use one of our email addresses if you need to send us an attachment” and sent an email to

Same issue here. Latest version of Mojave and latest version from L&L website. Tried all the options and crashes so I sent in a support ticket. Also note that this crash is occurring on a new computer and new install. I don’t have the pref file yet because it crashes instantly.