Scrivener randomly inserts default formatting into text documents

Some of my text documents randomly insert the Scrivener default formatting. I’ve tried Ctrl+A and choosing desired settings; also tried copying style from a properly behaving text document and doing Ctrl+A in an offending text document and pasting style. No dice.
I considered changing default, but my Scrivener version (Version: - 07 Jul 2020) does not have File>Options.
2020 seems old, but update says my version is “up to date.”
Any solutions?

The old version will not prompt you to update to the current version, which is 3.1.4, because it is a paid upgrade. So that’s why you aren’t seeing any recent activity.

Otherwise, I don’t really understand what it is you are referring to. It might help to describe in steps what you doing, what leads to that condition, and where things are happening different from what you expect.

The first image shows the formatting in place throughout the document, including at paragraph breaks.
The second image shows what happens when I hit ‘Enter’ to begin a new paragraph. Here, the new paragraph was begun at the end of the second paragraph. It has the Scrivener default formatting: no indent, Courier New, 1.0 spacing, 12 pt.
As noted about, reapplying my desired formatting to the document in various ways does not keep the default formatting from inserting itself when I press ‘Enter.’
Please, can you explain the cause and offer a workaround?

Ah, if you take a close look at the icon for this document, does it appear different from the others, yellower and with three dots along the left side? It kind of looks that way from the screenshot, and if so that means you’ve accidentally turned scriptwriting mode on (which by default would do its best to force 12pt Courier single-spaced formatting).

You can toggle it back off with the Format ▸ Scriptwriting ▸ Scriptwriting menu command, which uses Ctrl+4 by default.

You’re right. thank you for your advice, but now there is more weirdness.
Earlier, I used Crtl+4 and also the Menu links to supposedly toggle off (or on) Scriptwriting, but neither approach solved the spontaneous formatting issue. Also, neither setting made the ‘Script Mode’ tab on the menu (Formatting>Scriptwriting>Script Mode -Screenplay) show a check mark or otherwise show it was activated.
Upon receiving your advice, I tried it again, and hitting Ctrl+4 worked. (Yay!)
The weirdness is that now I can’t turn Scriptwriting on. The asterisk after the document name shows up for about one second and then disappears. Using the menu yields the same result.
Figuring out this weirdness may be a waste of time, because I don’t want to write a screenplay and am happy to leave Scriptwriting off, but there it is for you if you want to solve the puzzle.
Thanks again for your help!

That could be explained by the formatting just being there, at that point. Turning it off wouldn’t remove the formatting in other words, or if there was some stuck between two paragraphs it might still show up. You could probably use the command to convert formatting to default, off of the Format ▸ Convert ▸ submenu, unless you have a lot of custom formatting you’d want to preserve.

As to why it is no longer toggling, I don’t know for sure why that would be. Perhaps the cursor is not in a place where anything would be toggled.