Scrivener removes linebraks in syncing

Every time when I close Scrivener on MacOS it synchronises with my DropBox folder. When I open it again it has removed all linebreaks so the text is “crumpled” and I have to manually insert new linebreaks.

How come? Have I done something wrong in the sync settings? Haven’t changed anything.

I don’t know what method you are using to sync, but what you are describing is a default behaviour of the File ▸ Sync ▸ with External Folder… feature. If that is what you are using, then go into that panel and at the very bottom of it, make sure Automatically convert plain text spacing is off. You can hold down the Option key to save your settings in this panel without syncing.