Scrivener running extremely slowly

Hello, I have version 3.3.6 of Scrivener for Mac. I’m running MacOS 14.5. It can take minutes to open a project I’ve been working on for a few years. On the Activity Monitor I can see Scrivener jump right up to 100% CPU and then some. Usually with a “not responding” message lasting a minute and eventually clearing up.
Just now, Scrivener had been open for a while. Everything settled. It was not in the top 15 processes open in Activity Monitor. As a test, I went to type in my project. All I did was hit the return key and Scrivener spun and spun. went over 100% CPU. I did it again to confirm. Same behavior.

Intel or Apple Silicon? Which version?

How big is your project? Do you have a lot of images or a lot of snapshots in your project? Those can slow down loading time.

Do you have a lot of inspector comments or footnotes in your project and are you using Scrivenings mode? That can impact editing.

Has a lot of the text been imported from other apps like Word or web browsers? If so, I would try Edit → Text tidying → Zap gremlins.

Other things to try are, in order:

  1. Hold down the Option key and File → Save and rebuild search indexes;

  2. With Option key held down, File → Close Project and clear interface settings;

There are other (more drastic) things, but tell us if those are any help first.

Good luck

1 Like

Thanks for your response.
The Mac is 2.3 GHz 8-Core Intel i9, 16GB RAM.
The project is about 683 MB on disk.
There are some images, but I wouldn’t think it too many. (BTW, is there a way in Statistics or elsewhere to see the number of images in a doc, or folder, or file?
I don’t use snapshots in this project. I know Scrivener puts backup files somewhere whenever I exit, and that has been enough back up.
I have essentially no comments or footnotes and almost never use Screenings mode.
If I have any imported Word or browser content, it is negligible; don’t remember the last time I used that functionality.
I have done the Save and rebuild search indexes and the Clear interface settings. Neither helped with the slowness when entering text or simply clicking to select a different document.

So, the problem is not with loading the file. That seems reasonable for a large file. Even just having it open, on any particular bit of content … once settled, just hitting return or typing can sometimes also cause it to spin for a minute or so. It eventually settles back down, but of course that doesn’t seem right.

Something I tried: The file has a few folders with documents … but it also has one folder with about 11 folders (each grouping a year’s worth of documents, one for each month. I just tried moving that one large folder to a new, separate project. The original file is now down to 69.4MB and the new project file is still 588MB.

After some opening, closing, editing, etc. the large project/file (but still smaller than the original) seems to still have the slow, spinning, sometimes not responding behavior.

So, again, how can I see the number and/or size of images I’ve inserted in line, in case that’s the problem?
And … out of curiosity, why might the more “drastic" options be?