Scrivener Undo & Backup Reversions?

I’m on iPad. I was just learning how to apply formatting to an entire page, and accidentally replaced the entire page of several paragraph with the letter “9”!

But now how do I undo?! It’s not intuitive! I’ve searched the web and it’s not entirely clear how to undo. I tried the arrow keys at top left of screen, but those did not undo text edit, but rather took me backwards in navigation steps (?). I tried looking in iPad keyboard UI, but forward/back buttons are greyed out—no ability to undo.


The more I search for a solution to this issue, the more I’m seeing other people having similar issues, and even very scary stories of people losing months of work (do to backup syncing issues?).

Someone PLEASE tell me all of this has been resolved, and that I can confidently use Scrivener to write large volumes of text without ever worrying it will all be lost. Please.

In this case, fortunately, the page I was editing was a bunch of notes I had recently copied over from a Google doc—and I still have the original text on Google docs (whew)! But what if this was not the case?!

I want to move forward knowing there is a way to ensure work is never lost.

  • how to undo?
  • what’s the best way to manage backups and revisions?
  • how to ensure backups and reversions will always work?

Thank you

What you report are not bugs.

For backup I Googled “iOS scrivener backup” and quickly found Literature and Latte’s:

For Undo I Googled “ ipad undo typing” I found a lot of links and YouTubes. Take a look.

You seemed to know what happened. you selected a lot of text then pressed the “9” key. The iPad did as instructed.

1 Like

Hello gaio. I just replied to your help ticket on this topic. But, in case this will assist other users as well, I’ll also share some suggestions here.

I’m attaching a screenshot that shows the Undo and Redo commands on my iPad, which are located in the secondary toolbar when the on-screen keyboard is visible.

Since an issue like this could result in data loss, I also wanted to point out our Knowledge Base article that explains how to create manual iOS backups.

Since Apple do not permit apps on their mobile devices to create automatic backups of your data like Scrivener 3 on a computer does, I recommend that those working with Scrivener on iOS devices add that process to their writing habits.


As the “undo/redo/ buttons were not working as expected, I thought this might be a bug (still might be).

Yes, I had already googled ‘Scrivener undo” and read around a lot. But in this case, the “undo/redo” buttons were not working (“greyed out”) with no response.

Thank you for the link to backing up iOS.

As ensuring the longevity of work, and maintaining backups is so important—I thought it would be good to ask for the official methods (as Google searches are vast and sometime outdated).

Hi, thank you for the info.

FYI, yes, I had found the undo/redo arrows in the iPad keyboard, but they would not work (they were “grayed out”, with no action to be taken). I’m note sure why this was the case?

I will look into doing proper backups.
Thank you

That’s an excellent question.

When testing what you encountered on my iPad, I haven’t been able to replicate having the Undo and Redo buttons grayed out like this, provided I used that Undo button before moving to a different document in the project.

Once I change documents I’m viewing, then I can no longer use those commands. Did you navigate to another document before noticing the text replacement?


yes, I think I may have navigated to another document in the same project before finding the “undo/redo” method.

good to note!
Thank you!

1 Like