SCRIVENER / Win7 performance tweaks (fast and not furious)


using scrivener extensively and quite happy with your product. changed the way i work.

my work flow within scrivener is smooth and will be a walk in the park once a few bugs are addressed and Mac equivalence is reached. but…

there is one little hitch in my go though… occasionally scrivener grinds to an unresponsive halt so that the windows “(Not Responding)” message appears at the top of the screen to the right of the project name. sometimes the screen grays out.

then i just wait and anything i have typed may or may not be remembered when scrivener wakes up. it always does and i continue on my way. this is certainly not a deal-breaker problem but it happens often enough to be a growing irritation.

this most often happens when i am working with the titles in the binder outline: i click and drag a title to another location; move a title using the context/right click pop-up menu MoveTo; if i edit the title in the editor header bar.

sometimes the problem comes up when i am editing within the editor and i find i am typing into a “Not Responding” scrivener.

my project has 700 entries in the binder outline all on 3 levels, mostly on the second and third levels. about 100,000 words in the project.

so the question is: Are there any scrivener performance tweaks that an average scrivener-er like myself could use to get the job done a bit smoother and faster? and get more out of the system i have without upgrading. windows tweeks? file optimization? indexing? computer genius stuff?
how do i set up my windows environment to be a scrivener machine?

thank you for any ideas on how to get under the hood and help scrivener rumble.

I’ll start with what I have seen on the forum, or experienced myself:

In Scrivener:

  • Import files as aliases i/o the whole thing.
  • Keep pictures in the research.
  • Disable scrivenings when working with large chunks of the binder.

In Windows:

  • Freshly restart windows often.
  • Close all unused programs.
  • Tidy up running processes.
  • Verify & utilize all prophylactic measures.
  • Stick to a strict system maintenance regimen.
  • HD health and tidiness do matter.
  • Consider changing to a mac.

One thing you might try is locking the editor on a single text document before clicking around in the binder. It may be that when you’re doing this to move titles, you end up selecting folders that start trying to load a bunch of subdocuments as a Scrivenings session, and that slows things down. Locking the editor will prevent the binder clicks from loading anything, so you can rearrange all you want and then unlock the editor to go back to working there.

To lock the editor on a given document, click the document icon in the editor header and then choose “Lock in Place”, or select View > Editor > Lock in Place from the main menu.

You can also switch your current group view mode from Scrivenings, if it is that way, to outliner or single doc mode, which will be less of a resource strain, so shouldn’t cause as much trouble if you do accidentally load a container. Do this by selecting a folder that only contains a couple small documents (so loading them in Scrivenings will be quick) and then just choose the outliner icon from the main toolbar or select View > Outline. Folders will now load in outliner until you change it again.

thank you for the good ideas. much appreciated.

but since i WILL be sticking to the windows 7 environment and have implemented all the above suggestions and am still grinding to a Not Responding halt…

i am wondering if windows savvy scrivener users have any more tweaks that would make a windows environment more scrivener friendly.

any ideas?


I’m a new user of the program (under Win 7 on a 64-bit system) and have also experienced ‘freeze’ problems as I’ve been using Scrivener. Alas, when they occur on this machine, I’m for it: time to shut down the hard way (Push And Hold The Big Red Button). Otherwise the machine never comes back, no matter how much I whine at it.

But I don’t know that I can lay this problem at Scrivener’s feet. It might be that my laptop is just plain evil. I’ve begun trying to eliminate possible problem-child applications by keeping them closed most of the time. Firefox has been a very bad boy lately – memory leaks a-plenty, I’ve heard. I’ve stopped using it and have switched to Chrome, though I’m not fond of it. Even then there have been “lock-up” style crashes – always lock-ups, and never blue screens of death. How odd to find myself missing those. I even started missing Win XP. :slight_smile:

At this point the best thing I’ve been able to do to protect myself – these lock-ups being unpredictable – is: Save Early And Save Often. I mean: I’ve set the option in Scrivener to back up immediately if I give the save command (Control+S). I was grateful to find that the program creates a backup copy – I have it create ZIP archives – following Control+S even if the project hasn’t changed at all. Now I create a gazillion ZIP files as I write. Before I began taking the industrial-strength approach to the backups, I had a crash in which I lost all of my work; despite the save-every-two-seconds feature in Scrivener, the whole damned project was just gone. The outline was intact but all of the text seemed to have gone off to meet its Maker somewhere. I did have one ZIP backup, about an hour old, and was able to restore much of the project. (sigh of relief) I’d created it manually. Now I have so many ZIP backups, created automatically, that I might be able to open a Previously Owned ZIP Files shop. But having them sure beats the alternative.

yes… i have gotten the “freeze” effect too; it lasts just long enough to be repeatedly annoying. i dont think my virtuous laptop is ready for the exorcism ritual quite yet. i’d just like to restore the faith a bit.

so i wonder what the scrivener friendly tweaks might be… for instance i have my windows 7 stripped of all the pretty stuff, unnecessary prccesses, bloat. i do disk optimization. and i get faster windows by turning off file indexing… BUT am i slowing up scrivener by not havng indexing?

i just dont know enough… and honestly i dont want to know the details, just want a blindingly fast scrivener race machine… and keep my laptop.


…i’m starting to get the feeling there might not be a lot of data out there about tailoring windows 7 for top scrivener performance… (what to do when you gotta stay with what you have…)

i’ve done the following to get a faster windows 7 machine:

  • disable all aero fancy display effects, user account control
  • stop all un-necessary services, startup programs, current processes, windows features, gadgets, system sounds, bloatware,
  • set up ReadyBoost with 16g flashdrive
  • set power plan to max performance when possible (longer battery time may be more important)
  • regular use of ccleaner, disk defrag/optimizer, AdvancedSystemCare
  • added max ram
  • be current on updates
  • have efficient virus/firewall protection
  • disable Search Indexing feature

its that last one that may not be serving scrivener well.

should i enable the Search Indexing feature for scrivener files only? and thus get faster access to scrivener files… just dont know.

anybody know more about this? or other ways to tune windows 7 to scrivener…


I’m on Windows 7 64-bit and have never experienced this problem. I think it would help if you supplied more info, e.g. how much memory you have; what anti-virus program you’re running; what percentage of free disk space you have; and the processor type (e.g. Intel i5-2400).

BTW, when Windows says a program is not responding, it doesn’t necessarily mean it never will. It may be stalled waiting for another process to finish. Assuming the system hasn’t frozen, check Task Manager (Ctrl-Alt-Del, then Start Task Manager) and look for a process hogging CPU (click the label at the top of the CPU column to sort them by percentage).

Running XP and deleting all Search, Indexing, Google, Evernote, etc. programs from Task Manager makes things hum right along.
Only big resource spender left is AVG but I sorta like having it around.

thank you lee for your suggestions!

and yes the particulars of my scrivener machine are at the bottom of all my posts. disk space is approx 180g free out of 300g. i am running norton internet and it is set up to be quite light on system resources.

i have cut all the pork as far as current processes and services and visual effects…

and you are right as far as the Not Responding state scrivener enters - it does eventually come back. always. when scrivener goes Not Responding, i have checked Process Explorer to see scrivener as the main cpu hog. i suppose i could dig deeper and see if scrivener is in a wait state for some other process.

i understand that multi-document scrivenings mode is resource draining, but i dont use it. i am working in single document mode on a 103K word project with about 150 documents.

i get the Not Responding quite regularly when i use a split screen editor, and the left editor shows the outline view for the project. (the editor is in split screen vertically with the left editor panel showing the project outline just like the binder. this is really handy for moving documents from one place in the binder outline to another. since scrivener does not have a cut and paste function for binder entries, i use this setup to have two windows into the binder and moving documents from one place in the binder to another.)

otherwise, split screen or not, about half the time that scrivener goes Not Responding, i am just making a document title change at the top of the editor screen. or making the first edit to a document just displayed. thats all.

seems like simple functions that should not bring scrivener to its knees. does not by any means make the software unusable, just annoying… as in: i am typing and suddenly realize that scrivener is not listening… and i need to repeatedly wait for it to catch up.

thanks for your time and expertise.

It certainly sounds like you’ve taken care in setting up your system to maximise performance. Frankly, changing settings in Win7 to get Scriv to run smoothly shouldn’t be necessary even on a lightly spec-ed machine, let alone yours.

The only thing that really should be able to cause hang time is the loading of large Scrivenings sessions, which you’ve stated isn’t the case.

As for Scrivener settings themselves, the only real thing you can tinker with that can affect performance is the auto-save duration, but again, with the described system and activity, you shouldn’t run into problems with the default ‘2 seconds’ unless you are writing some extended stream of consciousness without pausing, hesitating or scratching your nose for quite a ridiculous number of words.

The only things I can think of is whether it’s the file system on your machine that is causing the delay. Ie, that saving changes is causing the lock-up somehow.
So, some questions…

  • Are you saving your project files to the same drive as your application, or to somewhere else (like a flash drive, the cloud, or an external / different hard drive)?
  • Do you have your back-up settings to create a back up on every save, or just on closing?
  • Have you tried creating a copy of the project file somewhere else on your system, in case you just happen to be using a ‘bad sector’ of hard drive (you need to make a copy rather than move it so that it’s stored somewhere else physically on your disk rather than just changing the address. I’m clutching at straws here, I know).

If you don’t have any unusual answers to these questions, I’d be tempted to try the old IT standby… have you tried uninstalling and reinstalling?

I’m new to scrivener, but as far as general maintenance goes, have you defragmented your hard drive lately? I know from experience that anything that frequently accesses the hard drive (such as saving every 2 seconds… or creating files/etc when you make a new scrivener file) could potentially slow to a halt if your hard drive hasn’t been defragmented in a while. Forgive me if this is obvious advice, and one of the first things you tried, but some people don’t know, or even I have overlooked it and spent weeks trying to figure out why my programs keep grinding to a halt. In general, sometimes people overlook the simple solutions because they think that there MUST be some major issue behind something that seemingly has no other cause (I’ve witnessed and experienced several cases of this).

sjk, Sorry I didn’t pick up on your specs. It seems as if you have everything the way it should be. Pigfender makes some good points about disk space. If you have a full backup rather than autosave occurring frequently, that would certainly cause Scrivener to go walkabout.

CrystalKitten, A fragmented disk would certainly have an effect, though Win 7 schedules a defrag by default once a week and runs it as a background process, so there really shouldn’t be a need to run a separate one. However, the system may never get the opportunity, e.g. the system is turned off when not in use.

To check defrag status: Start→All Programs→Accessories→System Tools→Disk Defragmenter. (NB: A solid state drive doesn’t need defragging.)

I’d also recommend running chkdsk: Start→Computer. Right-click drive and select Properties, then the Tools tab and the Check now… button. It checks and repairs both the file system and bad sectors.

To check defrag status: Start—>All Programs—>Accessories—>System Tools—>Disk Defragmenter. (NB: A solid state drive doesn’t need defragging.)

It doesn’t seem to work quite that way on my Win 7 system; there’s no “fly-out” menu for “Accessories”. This does works:

Click Start or press the “Start” key
In the text field at the bottom of the Start menu, type defrag or disk.
Matching items appear in the list that appears above the text field.
Select Disk Defragmenter

Command line: type defrag /? to see the available options. Pick the one that’s best for your purposes and run it from the command line.

I’d also recommend running chkdsk: Start—>Computer. Right-click drive and select Properties, then the Tools tab and the Check now… button. It checks and repairs both the file system and bad sectors.

Less friendly but faster — command line:

Type chkdsk /? to see the options for the chkdsk.exe program. Consider the command-line arguments that you need. I always type: chkdsk c: /f.

It is unlikely that you’ll be able to run this tool on the boot drive without restarting the machine — whether the tool is run from the Start menu or from the command line. (In MS parlance, “now” actually means “a bit later”. :slight_smile:

thank you pigfender, crystalkitten, and lee for your comments and insights. much appreciated.

in response:
-using only my one C: drive for all programs and files
-Auslogics DiskDefrag for defragmentation and optimization
-AdvancedSystem Care for overall system optimization, disk check-ups, cleanups, updates…
-scrivener auto-saves set on 120 seconds with full backup only on project close
-occasionally “save as” of my entire scrivener project under new version number so in effect i do have a fresh copy on new disk sectors

i have just recently returned to “turn windows features on and off” and set the Windows Search feature to ON. this started Windows file indexing which i then reactivated only for my scrivener project files using control panel/indexing options. I may have shot myself in my scrivener foot by originally turning off the Windows Search service order to get a faster WIndows environment.

the jury is still out on that one…. But I don’t think I’ve seen the last of the NotResponding Monster hiding under my scrivener bed.

judging from the number of views of this post and of the “Netbooks for use with Scrivener?” post, my guess is that there may be many smaller-laptop scriveners with an interest in running scrivener as efficiently as possible. Monsters under their beds too?!

In the manuals – mac and win – performance tweaks are occasionally addressed.

in this post we might just have a good start on a list of Win tips. Thank you.

I still think that with your specs and usage you shouldn’t be seeing this sort of lag, or need to worry about such things as an “optimised system for running scrivener”.

Assuming you haven’t already, have you tried setting your auto save to something closer to the default 2 seconds instead of 120? Maybe you’re just locking things up by having one large save once in a while instead of lots of little un-noticeable ones?


I am definitely doing this next semester. Mac ftw.


yes, thank you, i understand that i might someday consider becoming a mac user and smirk at the trials and tribulations of those poor windows users.

but… no thanks. dont think i will. not a good smirker. and the key word might be poor user. for reasons that others here might be sympathetic to, i am in windows land and will remain here.

i use windows scrivener and scapple heavily for my work and i will continue doing so. i have full faith in the litandlat crowd that they will not abandon us poor windows users… and eventually the issues i am experiencing will recede into the past.

its the best writing software there is out here in the windows wasteland and thanks to all for constructive comments to make it better. that helps.

One thing that I have found can crawl Windows machines (especially laptops) to a halt is when system protection is on…

If you go into Control Panel -> System -> System Protection, you can see if your main drive’s system protection is on. If your system is otherwise stable at the moment, you can try turning this off. It will delete all your old system restore points, but if your system is OK, you won’t need them.

Then check out Scrivener and see if you’re having the same issues. If you are, just turn it back on and it will make restore points any time you update drivers or install new software.

I have also found out that Norton introduces MANY more problems than it solves. You are much better using Security Essentials or AVG or something lighter weight. I know you said you have set it to minimal system load, but that didn’t seem to matter on a few computers I worked on recently. Norton is a resource hog, pure and simple.

I would definitely try to leave the Task Manager open, always visible (it’s usually on top, so you’ll probably have to set it off to the side) and when the system freezes, see what’s taking up the memory and CPU and perhaps even disk access.

I will also say that Windows 8 seems a LOT less resource intensive overall and smoother than Windows 7. As much of an improvement over Vista that Windows 7 was, Windows 8 is that much of a resource improvement over 7. Even old machines seem to be able to run 8 better.

Don’t jump to Mac just yet. They have their own issues.

If System Protection is slowing your PC then it’s indicative of a deeper problem.