Scrivener's to long to open projects

I’m using Scrivener 3.2.2 on Mac OS Catalina 10.15.7, and suddenly I have almost the same problem as described in the topic entitled “Scrivener won’t open” (last year with Scrivener 3.2.1).
Since a few days, the app takes too much time, 2 or 3 minutes or more, to open. I didn’t modify the projects, and I didn’t do any modifications on my Mac either.

Do you have an idea of what’s happening ?

Perhaps your local hard disk is starting to fail? Do you have backups stored on another device, just in case? Also (and I don’t have a feel if this might be a cause), but your OS is well behind current.

The main question also would be what might have changed a few days ago?

My disc doesn’t seem to be failing, I have backups on Dropbox but i get the same problem when I try to open one of them. I know my OS is not up to date, but my Mac Book pro is not eligible to BigSur…
And I didn’t change anything to my configuration during the last days.
It’s just very long to open, but when it’s done, Scrivener works as usual…
Is it possible that the app get corrupted, for a reason I don’t know ? Is it possible to download another copy of Scrivener without paying it again ?

Remember that when you access your “Dropbox” files, you are accessing COPIES of files that are on Dropbox’s servers, not Dropbox server files. Copied to your local drive and accessed from there. Doesn’t really prove anything about the quality of your disk, IMHO.

And are these Dropbox files actual “backups”, or just synced using Scriener’s sync features. Sync is not backup.

Given you can’t open these copies … humm. If I were you (and I am not!), I’d make sure that I have a real backup of entire machine via TimeMachine or equivalent before going much further. Just doesn’t feel good to me. Even if you don’t have a hard disk problem, having a real backup (and not Dropbox copies) is a good idea, IMHO.

Yes, I think you can install a new copy from Literature & Latte’s web site of the app to fix a “corrupted” app. Just reapply the license. If it’s an Apple Appstore copy, I don’t know for sure how to do it but my guess is you simply delete on local and reinstall. BUT, I’m not sure. Others can comment.

But if the app is “corrupted” and requires re-install, one has to wonder how it got corrupted? Still points to maybe a hard disk issue?

Something changed a few days ago. By you or by the computer.


Also could be that just the project (or projects) are corrupted and then (maybe) synced to Dropbox in their corrupted form–which explains why you can’t open the Dropbox sync files? Why corrupted? I don’t know.

1 Like

Of course you’re right about DropBox. I have some real backup by TimeMachine.
What makes me thinking it’s not a disc problem is the fact that this slow opening occurs only with Scrivener. Others apps open as fast as usual.
Maybe, as you say, it’s my project that is corrupted. I’ll make some tests. Thank you for the help…

Whew! I was cautiously afraid you had no real backups! Good luck. Maybye grab an older versioN backup of the project from TimeMachine without over-writing the copy now already on your machine. Go back in “time” in increments till you find a good copy. But you probably know that!

1 Like

I just tried some others projects : they work properly. You were right : the problem is in that specific project !
I’ll try your solution…

If it’s just this one project, start by resetting the project display settings, as explained here:


Ok I tried to reset the way you said, @kewms, and it worked ! Thank you (and @rms) for your help ! :slight_smile: