Scrivomatic: Paragraph Breaks/Separators >> replace with 2 'Enters'

I am compiling my project with Pandoc/Scrivomatic, which first transforms into the project into Markdown and from there to docx. I am trying to control the separators between paragraphs and I want to have a single break / enter to be understood just as that. Normal way, as I understand, would be compile > edit format > separators and there everything to “single return” for the different sections layouts (or set them to default and then edit the defaults). But that does not work.

In the manual, it is written:

“Single return: a single paragraph break will be inserted, causing the final
appearance to run from one document to the next with no visible “seam”.
In essence this is the “no separator” option.
This can have an adverse effect in Markdown-based and Fountain formats,
where a clear empty line is expected between all elements, including paragraphs.”

The author of Scrivomatic says that one should add two breaks (Enter, Enter) manually or through replacement function at compile stage. Whats the code or how to enter “breaks” or “enters” into the replacement pane?

a partial solution can be found here,

BUT this mingles with the metadata put into the binder for scrivomatic to work, so the main purpose of scrivomatic - to include bibliographic citations - does not work anymore.

My solution: I replaced all Breaks/Enters with double Breaks/Enters through Project Replace in the Search field just over the binder.

The author of scrivomatic suggests to use compile > edit format > Transformations : convert to plain text

Yes, my recommendation is to use Transformations: read section “§24.13 Transformations” in the user manual, specifically, you can convert the paragraph spacing from Scrivener’s RTF engine into multiple line breaks. So for example a 14pt font and 15pt paragraph spacing and the markdown will output with the correct number of line breaks (top is the compiled markdown showing double line-breaks in VS Code and lower part is the single line-breaks from Scrivener’s editor):

[attachment=1]Screenshot 2021-03-07 at 20.09.49.png[/attachment]

[attachment=0]Screenshot 2021-03-07 at 20.14.04.png[/attachment]

It took me a second to understand that you would 1) change appearance of the text through going on Format > Paragraph > Line and Paragraph Spacing (or directly in format line of the editor on line spacing > other and 2) then using the transformations-option described by me above.

I’ll check the out later, how to do that for the whole project.

Well, this is a convenience function (and a really cool one at that) that Scrivener’s compiler offers for those who may compile to formats that require different paragraph breaking requirements, or like you already have a big project using one method that now needs to switch to another; the recommended way is to make sure you use two line breaks between paragraphs in markdown if you do start a new project. But for your existing project, to apply to the rest of the manuscript, first change your default formatting for you project to include the correct paragraph spacing, select the documents you want to change in the Binder and use Documents > Convert > Text to Default Formatting…