Scrivomatic Style character text color

Is there a way to style the text color from scrivener to have it output a predefined word style (where I made it the same color)?

So let’s say I have this in scrivener:

And I want this in Word (artificially made for display here):

I put this in my Styles section for my format in scrivener:

However, the blue font does not appear. It’s just black.

The markdown .MD file output looks fine with:
Explain the<span style=“color:blue” importance of the problem or critical …

But I cannot figure out how to link that to the Word Style.
Out of docx, tex/pdf, and html, only html has the color style correctly.


Yes, this is something Pandoc can do, though you’ll have to set it up a bit, at least from what I have seen in my simple testing of it. The two key ingredients are:

  • A custom reference.docx file (save it into your user folder under .pandoc for it to be used automatically. Instructions for creating and editing this file are in the Pandoc documentation, page 18.

Once you have that file created, you would want to add your custom blue text style to the bottom of the file. Apply the formatting attributes you desire, and then create a new character style for it.

And you can modify the formatting of this document as well to adjust default .docx output. So that’s a nice trick to know about anyway.

  • Marking the text as styled in the source. This technique is documented under the Custom Styles section, starting on page 107. This is what you would want to add to Scrivener’s settings, as your style prefix/suffix, instead of the HTML. For example:
Here is some [blue text]{custom-style="Blue Text"}.

I do think that this approach is fairly format-specific. It doesn’t seem to produce a good result for LaTeX or HTML. There may be ways around that (I’m not a Pandoc expert), but if not—that’s one nice thing about Scrivener’s compile Format system. You can have one format producing special HTML spans, another wrapping your text in DOCX styles, etc.

It sounds like you need a markdown path, but if compiling straight to docx is an option at all, then the remedy is easy. Just name your blue style with the very same style name as you have set in Word. Also, in the style area of compile (for docx output), make sure the preserve-style-info-in-output option is enabled.