Scroll doesn't work while selecting text

Intel
OS X 10.6.3
Scrivener 1.54

While selecting text, I cannot scroll the edit page.

Once I let go of the mouse button, the page snaps, presumably to where I tried to scroll to.

This behavior applies when I try to scroll using the multi-touch pad (two finger scrolling) and when I use the arrow keys on the keyboard.

Some of this sounds like it could be explained by ordinary Mac behaviour. I’ll describe a bit of it; see if it explains what you are experiencing. When using the mouse wheel (or trackpad scroll action) to scroll through text, this doesn’t actually move the cursor. Thus, as soon as you start typing again (or use an arrow key), everything will snap back to where you were before you started scrolling. The way to scroll and target is to use the mouse to click into the text you have scrolled to. This behaviour is also identical for the PageUp and PageDown keys—they only scroll, they don’t move the cursor.

As an aside you can always jump back to where the cursor is without actually typing or moving it, by pressing Cmd-J.

Okay point-by-point:

Do you mean that if your selection goes beyond what is visible in the editor, you can’t see where you are selecting from that point on? What happens for me is that if the selection goes beyond the screen height, the window scrolls to keep up with it—but note again this scrolling is not tied to the original cursor position. Selections are a little more complex and you can think of them as having two positions, one at the end and one at the beginning. Consequently two of the arrow keys, Right and Down, will reposition the cursor at the bottom of the selection. The Left and Up arrows will position the cursor at the start of the selection.

Your phrase could also be interpreted to mean that while you have something selected, the scroll wheel doesn’t work at all. That would be very odd and I’ve never seen anything like it.

That’s a little more confusing to me. Which mouse button are you referring to, since you only mention two-finger scrolling and arrow keys? And wouldn’t ending up where you scrolled to kind of be what you want when scrolling?

That aside, things generally don’t “snap” around except in two cases:

  1. PageUp and PageDown. These snap between positions by definition.
  2. Typewriter scrolling is turned on—then the page will “snap” into a position which places the current typing area in the middle of the screen.

If things are snapping about outside of those cases, then you might accidentally be brushing against the trackpad with the palm of your hand or something. This can cause the trackpad to get confused and suddenly register a value that is way outside of what you meant.

Hi Amber,

Thanks for your most thorough reply!

I think you are right about it being normal Mac behavior; I just tried to repeat what was I doing in TextEdit, and it doesn’t work there.

However, it does work the Chrome browser, and it’s a great feature!

To better describe what I was trying to achieve (what I thought was a bug), I will detail the steps I took:

  1. Edit a document that spans multiple pages.
  2. Using the trackpad, select a small portion of text towards the top of the document.
  3. Without letting go of the trackpad button, attempt to scroll down the page using either two-finger touch on the trackpad, or the up/down arrow keys, so that you can expand your initial selection to include text on pages below.

Does that make it more clear?

I guess I should turn this into a feature request instead of a bug report!

Seems to me that you’re simply holding down the wrong button! Hold down the shift key and scroll by whatever means you like … it’ll select everything up to the point where you let go of the shift key.
:slight_smile:
Mark

You’re right; I would just be smitten if I could use the trackpad select AND scroll at the same time!

Then how about putting the cursor at the beginning of what you want to select, holding down the trackpad button and then dragging down with one finger, not two … when you get to the bottom of the screen, the screen should scroll. Works for me!
:slight_smile:
Mark

That works! :wink:

Yup! That’s the way to do it. I have one of those nifty “no button” trackpads on my laptop which basically forces you to use this method since clicking is a matter of pressing down on the whole trackpad and then moving your finger down until you’ve selected everything and then letting go. Anyway, glad you got a solution.

No, tmanasa is right – and this works on the no-button trackpads (on a 2009 Macbook Pro for example). If you click and hold on some text in Chrome or Safari and two-finger scroll then a) the page scrolls, and b) the selection is extended. I’d never noticed this before. It doesn’t seem to work in Preview, TextEdit, Scrivener or Firefox.

Just to clarify, this isn’t a bug, just a difference in behaviour, as set by Apple.
Best,
Keith

Not a bug – sorry if I accidentally implied that (or contributed to doing so) – but interesting. Playing with it just now, it seems that in Safari, to get this to work, you need to create a text selection before starting the two-finger scroll. That is, the procedure on a no-button trackpad is a) click and hold, b) drag with one finger to start a text selection, and then c) drag with two fingers to simultaneously scroll and extend the selection.

That seems like an awful lot of clunking around to just drag out a selection. What is the purpose of that technique, how is it superior than just dragging to the bottom of the page and letting it scroll?

Agreed!

I don’t know, but I suppose it has one advantage: the mouse pointer keeps its position relative to the window, so you can see what is coming up even when making a long selection – which you can’t if you extend selections the normal way by dragging over the edge of the window.