Search display of file path

Hi
When I search the document, the results come back from the different files, is there any way to display the folder as well as the file in which the search result is at the same time?
Thanks

If open a file from search results and right click icon will show options at top is reveal in binder which will all adjacent binder elements including folders

In addition to the “Path” submenu described above, you can also hover the mouse over the editor title bar to get the full path in a tooltip, and the Navigate ▸ Reveal in Binder menu command is always useful for exiting the search result with any selected items fully revealed in the main binder.

Hovering the mouse over the item name in the search results list also will show a tooltip with its binder path.

Hi GoalieDad
Thanks for getting back to me, but I am obviously still doing something wrong.

If I click on the file and open it - what icon should I right click on? I have tried the ‘document’ icon, ‘Binder order’ option and title of the document - I just get the right click menu displaying - see attached.

But it does not give me the option to see which folder the file is in. Any ideas?
Cheers,

Tereza

Hi Amber
Thanks for getting back to me. However, I must not be doing it correctly. The option from GoalieDad doesn’t work for me.

If I use the ‘Navigate > Reveal in Binder’ it just displays the documents but without the folder they are stored in - see image.
Navigate _Reveal in Binder

The option always shows ‘Novel Format’ but then no folders are displayed beneath it when I do a search.

binder structure

But in my binder see image above - there is the folder e.g. Prologue and the document within it is also called Prologue.

Have I set the folders up incorrectly?

If I hover over the document heading - I still get the ‘Novel Format’ path, rather than the folder path - see image;
Document title

Though if I am not searching for anything - then hovering over the document title does show the correct folder / document path.

Any ideas.
Cheers,
Tereza

Either of these work?


Hi MimeticMouton
Thanks for getting back to me - however, I must be doing something wrong.

If I hover over the search result list it shows ‘Novel Format / first line of the document’ - not the correct folder or document name - see images.

Hover over search results.

It should be Bodies (folder) > Interview (document name)

So have I set it up wrong? The binder, when not searching, displays the correct folder and document names. Any ideas?

Cheers,
Tereza

Hi SWM

Thanks for getting back to me.

Unfortunately not.

I still see ‘Novel Format > first line of the document’ for both options instead of the folder and document name! See images:

Document title
Hover over search results

The search should show The Bodies (folder) > Interview (document name)

Any ideas?

Cheers,

Tereza

1 Like

Could you post a larger screenshot of your Binder, as it appears when you’re not searching? Without knowing what structure you actually have, it’s impossible to say whether it’s “correct” or not.

Hi Kewms

Thanks for your interest.

Binder structure when not in search;

Any help would be appreciated.
Cheers,
Tereza

Hi, @Silhouette

I think my post was posted seconds after your reply to Amber, making my post more or less redundant.

I am sure @kewms will solve this for you now—the binder structure is key … or a gremlin is dancing a drunken jig and playing tricks on all of us.

Could you open the triangle next to Novel Format and send another screenshot, please? Based on what you’ve already posted, I suspect you’ll find some documents are hiding there, rather than wherever they’re supposed to be.

Your screenshot with the hover text shows what I’d expect a path (in the general sense) to look like, and the name of the document displayed there matches what is visible for the document name as it appears in the search results list: in the list the selected item also is named “At the end of the drive they pulled …” (the end cut off there because the binder isn’t wide enough to show all the text). It looks like perhaps at some point that first line was used as the title—Scrivener 1 did this automatically for untitled documents, so if this is an older project, it could be from that. Scrivener 3 displays the initial text of the document as a placeholder title, but it is formatted in italics to distinguish it from a real title and would look a little different than what’s visible in the screenshot.

Search wouldn’t be changing titles or location or anything of that nature, but (unless limited via the search settings) it will pull documents matching your search query from anywhere in the project. My guess then is that you have a few duplicate documents (or nearly duplicate—enough that the text at a glance looks the same to you and they both contain the search term): the ones with the proper title, located where you expect them in the binder structure, and then these duplicates that are within the Novel Format folder.

Yes, that’s what I’m guessing as well.

For example, in @Silhouette’s screenshot there appears to be at least 3x binder items named Prologue, 2x docs and 1x folder, found in these paths:

  • Novel Format > Prologue (a doc)

  • Duped DE > Prologue (a folder) > Prologue (a doc)

Perhaps this duplication is causing some confusion about where documents are residing?

Best,
Jim

when right click icon in editor window of file name in header then see option to reveal in binder when click now shows binder with file currently in the editor window highlighted in the binder section see pic

Hi Kewms

If I click on the > Novel Format it displays all the documents without the folders.
Dropdown arrow

If I click on the triangle it just gives me information about the template

Triangle next to Novel format
Cheers,

There’s nothing special about “Novel Format.” It’s just another item in the Binder. And just like any other item, if you click on Novel Format, you see the sub-documents of Novel Format.

That is, you are not seeing “all the documents without the folders,” you are seeing duplicate documents. And that’s the source of your problem. As @MimeticMouton and @JimRac suggested, you have duplicate documents in your project, which the Search function is (correctly) returning. The file path as displayed by Scrivener is correctly indicating the locations of these files.

What to do next is up to you. If these are indeed duplicates, you can just delete them. If some of them contain new work – check the Modified date in the Inspector – or if you aren’t sure, you might want to move them to appropriate locations elsewhere in your Binder for further investigation.

Hi

Firstly thanks to everyone who have been so helpful so far.

I have now combined my feedback on latest answers received, thanks.

Sorry for the long and detailed feedback.

MimeticMouton
“It looks like perhaps at some point that first line was used as the title—Scrivener 1 did this automatically for untitled documents, so if this is an older project, it could be from that. Scrivener 3 displays the initial text of the document as a placeholder title, but it is formatted in italics to distinguish it from a real title and would look a little different than what’s visible in the screenshot.”

Yes, this was originally a novel in windows Scrivener 1 before I upgraded to Scrivener 3, so that may well be the reason. However, I did have the documents in the relevant folders in both Scriv 1 and Scriv 3.

New folders and documents still have the same issue except that the path appears to be ‘Duped DE Edit’\document name’

new folders

“My guess then is that you have a few duplicate documents (or nearly duplicate—enough that the text at a glance looks the same to you and they both contain the search term): the ones with the proper title, located where you expect them in the binder structure, and then these duplicates that are within the Novel Format folder.”

OK, so it does sound like I may somehow have multiple documents within the same novel project:

I have taken snapshots of the documents that I am changing - could this be part of the problem?
How do I see where the duplicates are? As when I open the binder that I am working in (which is the only one that I have ever opened), it only shows single documents under each folder i.e. not duplicates
How do I find and delete the older documents without deleting the most recent version of the document file that I want to keep?

Hi GoalieDad
“when right click icon in editor window of file name in header then see option to reveal in binder when click now shows binder with file currently in the editor window highlighted in the binder section see pic”

OK, so when I do this it it shows the file > corkboard > document
Reveal in binder_path

This isn’t what appears if I hover over the document name but is what I would expect to see when I do the search and hover over the document name.

Hi JimRac
"For example, in @Silhouette’s screenshot there appears to be at least 3x binder items named Prologue, 2x docs and 1x folder, found in these paths:

Novel Format > Prologue (a doc)

Duped DE > Prologue (a folder) > Prologue (a doc)

Perhaps this duplication is causing some confusion about where documents are residing?"

Thanks for getting back to me. I think you are right and it does sound like I may have duplicate documents residing somewhere - see comments below

Everyone
It looks as though I have somehow got a previous version mixed up with a current version - which is a bit of a concern when I try to (eventually :slightly_smiling_face: publish).
However, as backups I always compile and check the word file and that seems to have the latest version in it.

As you can appreciate I am getting a bit ‘panicky’ now if I have somehow created separate files / versions…

Particularly as the file I am working on is ‘Duped Post Dev Edit’.

The Duped DE Edit was the file I edited before sending to my developmental editor. When I got her response, I reuploaded the file as ‘Duped Post Dev Edit’ - so I thought I was just updating and changing the latest version.

Confused! :confused:

Any ideas on how I can check and update and have only the latest versions (including the snapshots) in one file?

Thanks again
Tereza

1 Like

Try View customize toolbars and add collapse all and expand all to see binder totally collapsed and expanded to help you get a handle on this. seeing all collapsed may give you more oversight

1 Like