Search Results Sort Order

Whenever I search for a particular string of words among some 20 chapters, those pages on which the words were found, of course, appear under Search Results in the Collection panel.

The problem I find, however, is that the chapters do not appear in sequential order, which for my purposes is rather important (e.g. determining where the first mention of a specific phrase or concept might appear). Logic would seem to dictate that the first occurrence would appear in the earliest chapter, the next in the next sequential chapter, and so on. The randomness of results delivered defeats my intended goal.

Is there a way to define such a sort order and keep it as the default?

Thanks to anyone for giving it thought (or best of all—an answer).


That’s rather odd. I just did a name Search (on “All”) and it delivered the Search results in Binder sequence (which itself is in Chapter sequence).

Is your Binder in Chapter sequence?

Odd indeed, SCRIVERTID. Yet I don’t get the same behavior you’re getting (using v2.8.1). Of the three attachments here, “Binder Order Before Search” indicates the proper chapter order (I use names rather than numbers). For clarity, the red numbers indicate the natural order of the chapters that (I would expect) should be delivered in search results.

The second image, “Binder Order showing search results,” shows the actual order delivered after searching on a particular word (though obviously the search phrase is irrelevant here; behavior is consistent on any search). Note the order now: The earliest chapter, Supposition, appears last, with Custody and Fingerprints above it. Doesn’t matter what I search on, results still appear in random order.

As for adding more columns, AUXBUSS—yes, I was hoping Scrivener conformed to the Mac OS standard of column selection, but as you see in the third graphic “Column Header,” all I get is the option to Show or Hide. I’ve tried over and over with no different options.

Thanks to both for checking in, but if there’s something I’m just not seeing or finding here, I’d be grateful for a shove in the right direction. I find no Sorting options in Preferences either.

Your last image shows the issue. See that upward-pointing caret at the right side of the “Search Results” column (to the left of the “Label” column)? That indicates you have it sorting in alphabetic order by title. Click on the “Search Results” header until there aren’t any carets in any of the headers.

Brilliant! Such a simple thing, yet so elusive. I’d would not have thought a third click would clear sort order.

Thanks rdale. Life just became less complicated.

Ah, yes, I see now what you meant, sorry. What threw me was

. That didn’t work. (But I’ve now learned to read more and test…thanks).

You learn something new… I’ve never seen that caret in Search Results! I’ve always assumed that if you do a Search, it returns the results in Binder order.