Section title without numbers.


I know marking a chapter or section title is this way:


It will compiled into you this code to LaTex


Which will issue numbers to each sections. However is there any way to mark a section title without numbering which will compile LaTex code like this:



If it’s just one document which you want to skip numbering:

  • In the compile options, tick the compile as is box. That will suppress the automatic title generation.
  • At the top of the document text insert . The comment markers will let the latex snippet pass through MMD processing unchanged, so the tex file will contain the \chapter command.
  • Typeset as normal.

Where do you find the compile as is box?
Where do you set the typeset?

I remember is marking for original LaTex code. If I use for every of my chapter title that means I am not getting benefit of MMD. I might as well edit all documents with LaTex code and save it as a plan text file. Is there any MMD code lets you to compile unnumbered chapters or (sub-)sections?

MrGruff’s advice was for single special cases. I have a few of those that I use here and there where I want a title, but I don’t want it to appear in the ToC or at the level that it would appear if I left it up to Scrivener.

If you wish to change how MMD exports LaTeX code for the document, then you need to download the MultiMarkdown-Support-Mac package from GitHub, add a “LaTeX XSLT” meta-data key to the compile settings, and use the XSLT post-processing option in Scrivener to use your customised XSLT file. There are examples provided in that support package, so just duplicate memoir.xslt, and set up your own overrides for the h# elements (see the xhtml2latex.xslt file for how this is done).

While there, you might notice that Fletcher has coded in what appears to be, preliminary support for an automatic switch to \chapter*{etc}. If the chapter name “Ends With an Asterisk*”, then it triggers the part of the rule that uses \chapter* instead of \chapter. The reason why I say it is preliminary is that it doesn’t actually then remove the asterisk from the title as output to visible LaTeX. So maybe if you are well verse in XSLT, you could achieve this by patching the code in the xhtml2latex.xslt, rather than creating an override XSLT.

It’s in the Inspector; General section. When using MMD, that checkbox disables normal title generation for the document in a singular case. So you can ordinarily use MMD titles for folders, say, but on one single folder have it disable the title (potentially to replace it with custom code, as we are discussing).

I’m not sure what you mean by that. If you are referring to his last bullet point, I’m pretty sure that means “Now go typeset your document using LaTeX”.

If you want all your chapters without numbers (rather than just one) then it might be easier to tinker with the Latex to turn off chapter numbering rather than diving into the XSLTs. The latex command could be added to one of the MMD support files which are used during typesetting (by which, as Ioa correctly inferred, I mean the Latex typsetting process which turns the tex file into a well- laid out PDF or printed pages).

Personally, I’m never going near the XSLTs as they make my brain hurt.

Thanks, so what I need to do is to add this line in Begin Document box:

% disables chapter, section and subsection numbering

That command should do it.

Not entirely sure what you mean by the Begin Document box.

Personally, I would add it towards the end of the support file mmd-memoir-begin-doc.tex, which is called by the Latex input meta data. But then your latex set up may be different from mine.

They might be using the Custom setting in the LaTeX Options pane, which lets you create boilerplates on the fly and save them into the compile settings.

Ah. That will be it.

The speed of change here makes me feel like some slow, hairy palaeolithic beast lumbering towards extinction.

Let me tweet that for you.