Selecting font bug

Release candidate 5

If I press Control-A to select the whole text in order to change the font type, Scrivener starts choosing fonts randomly without stopping.

Please verify.

I wonder if I am the only one having this problem…

I’m not 100% clear from your description what is happening.

Here’s what I did: I clicked into a document, pressed Ctrl-A to select all text, then clicked on the font selection pulldown in the toolbar. The list of fonts was displayed. I selected a different font, and all the text was changed accordingly.

It seems like everything’s working fine for me.

Are you doing a different list of steps? At which specific step do things go haywire for you?


Thanks very much, Jim for your reply.

I am sorry I wasn’t very clear but your described steps were in fact what I meant.

Unfortunately, for me, it works as I described previously. I am using Windows 10 on a Toshiba laptop. I don’t know if this issue is specific to my system only or if somebody else is also experimenting it.

Anyway, thanks again.

I pulled up a Beta project in my second laptop, a Toshiba Satellite Win10 x64. I can’t duplicate the problem either.

Have you checked your keyboard? What you describe is reminiscent of a “sticky key” situation or other keyboard type problems.

I was unable to recreate this problem. I’m running Windows 10 on my white box tower.

I also tried to recreate this and didn’t have a problem. Sorry I can’t help, but it seems very likely that it’s something in your setup (the “sticky key” suggestion above is one I would try; check that you don’t have a Windows accessibility option enabled by mistake, and try a different keyboard, if you can.

Not sure how helpful this is, but I’m using Windows 10 on a Toshiba laptop, too, and I’ve also had trouble with font selection, except instead of cycling through fonts, it acts as if I selected whichever font appears in front of the bar once the dropdown menu appears. Sometimes clicking a second time gets it to behave normally, but sometimes it doesn’t, so these days I’m in the habit of clicking and holding, then dragging my cursor down the menu and releasing when it hovers over the font I want. (I tried reporting this bug in a MUCH earlier beta, but I’m guessing no-one was able to recreate it back then, either, because it’s continued to happen with every beta since.)