Serious Compile Issues (tags, footnote, formatting and styles)

Hi y’all! I’ve used Scrivener for years, but am brand spanking new to 3.0.

I am trying to create my own blogging template. My design is that all Manuscript sub-folders are named subjects, so I can find previous posts easily and update them. Each Subject folder contains a subfolder named as the Date and in that folder are three documents named: “Header Text” (Title, my name, date posted, date updated and if necessary a disclaimer); a “Body Text” (where the post actually is); and a “Footer” (containing footnotes, if needed).

It’s really very simple! However compiling that is a nightmare. I created my own styles and for whatever reason, when I compile it is ignoring my styles. Here is a list of issues:

  1. My Header text creates extra lines between what it thinks are paragraphs, which I have formatted it not to do (via: Format > Paragraph > Line and Paragraph Spacing).

  2. This second one is a problem. I want my Endnotes tag (<$--ENDNOTES-->) to come immediately after my blog post. I tried trashing the front and back matter, since I don’t need them. That comes with a couple of problems. 1) The Endnotes are a mile away from the text, when I want it just below the previous text and 2) it literally prints like so, to include tags:

    Endnotes

    <$–ENDNOTES–>

    [1] Staff writer. “Black-out Must Be Complete: Strict Enforcement, Public Warned of Penalties.” The Manchester Guardian. September 4, 1939, No. 29,002 edition. The Guardian (London, Greater London, England) 04 Sep 1939, Mon, pg/image 2. Newspapers.com. Scanned images of original.

  3. Finally, I want to format the endnotes to match the look out of Zotero but instead, it’s bunching it into a paragraph rather than the preferred style of the first line all the way to the left and subsequent lines of each citation are 0.75" in. Zotero exports that style in copy/paste but because it goes to inspector, I can’t reformat it. For this reason, I clicked just before the (<$--ENDNOTES-->) tag and set the format, but that isn’t working and I can’t figure out how to do this.

I do not want to have my endnotes in a Back Matter folder because each blog post should have its own endnotes. If it matters, I plan to export to RTF because my website uses templates without a whole lot of control, but will copy/paste just fine in RTF.

Hopefully all of this makes sense. Please help me! :sob:

1 Like

Unfortunately, due to the flexible nature of the new compile features, it’s hard to determine if you’re starting from a good foundational knowledge of how it fits together.

Rather than try to address all of your issues, let’s start with the fundamentals.

  1. Are you familiar with Document Types? How they’re assigned (either automatically by heirarchy or manually) to each binder entry?
  2. Are you familiar with how you assign each Document Type to a Document Format in the Compile window?

It sounds to me like you’re trying to do all your formatting in the editor, which is fine, but you have to be aware of how that translates into your compiled format. Which brings me to…

  1. What output format are you choosing? Since you mentioned blogging, I assume HTML? Or does your blogging software accept some other format?

I think establishing all of the above is a good start for anyone trying to help you get this all sorted. In the meantime, have you taken a look at the v3 tutorial, especially the collection “What’s New in Scrivener 3” that you get to via View->Show Collections? That covers section types and compiling basics.

1 Like

One very important ingredient that is necessary for the <$–ENDNOTES–> marker to work is a setting in the Compatibility pane, in the compile format design interface: Flatten footnotes and comments into regular text. Without that you get “proper” endnotes, and as far as I’m aware, RTF has no way to say: put endnotes here instead of… well, at the end. So by “flattening” them we generate the formatted and numbered result of what endnotes look like, and then stick that chunk of text at the indicated spot in the output.

My Header text creates extra lines between what it thinks are paragraphs, which I have formatted it not to do (via: Format > Paragraph > Line and Paragraph Spacing).

That one is impossible to diagnose without more detailed information. A few questions that might help: What does this style look like in the Styles compile format pane? Is it present in your Format’s stylesheet? If not, how are you defining “extra lines”? Are they actual lines you could type on, or pure spacing? What else is involved in the production of the header? Is it something being generated by Section Layouts? If so, have you checked to see if there are any newlines in the Title Options or Prefix tabs?

Finally, I want to format the endnotes to match the look out of Zotero but instead…

And that, with just about all aspects of formatting, my return question would be: this for a blog, so why are you formatting anything in that case? Should you be looking to generate as clean-as-possible HTML without any formatting at all, and letting the blog software handle all of that with CSS? To me that seems more straightforward than trying to get the RTF looking like the blog software looks.

But to answer your basic question, you’d have to format those yourself after compiling. Endnote formatting, for RTF, is generally left up to how the software displays them, which in most cases will be a word processor.