setting the date in project targets

I’ve been using this feature for quite a while. Suddenly, with the advent of 2017, I can no long set a target date. Instead of letting me enter the full year, it defaults to 17 instead of 2017 and then doesn’t show me the days remaining. Has something changed?

This is a problem I have seen happen very rarely, we don’t really know how it happens, it seems to be some kind of malfunction between the system’s date format localisation settings and the control used to set dates. Basically you’re stuck in 17 CE and it won’t let you easily get out of it with the keyboard (one person tried holding down the up-arrow button for ages and that worked, but that’s a less than desirable solution).

Here is what I would try:

  1. Use the File/Back Up/Back Up To… menu command to create a backup copy of your project somewhere handy. If anything goes wrong with the following surgery, you can use that to get back to where you are right now with the project.
  2. Go into your project target settings and disable the deadline option.
  3. Close the project.
  4. In Finder, right-click on the project and select Show Package Contents.
  5. Open the “.scrivx” file you’ll find at the top level here in a plain-text editor (TextEdit will work if you don’t have one).
  6. Use Cmd-F to search for “<DraftTarget”.
  7. On that same line you should see ‘Deadline=“…”’, with a date stamp in between the quotes. Remove the entire phrase, both the keyword “deadline” and the quoted text with the date stamp. Make sure to leave behind at least one space separating the stuff around the part you deleted.
  8. Save the file.
  9. Close the Finder window with the package contents and double-click on the project to load it.

Hopefully you’ll find the deadline date has been reset to today and not today two thousand years ago. :slight_smile: