Shortcut key conflict

I have found a couple of instances where the default shortcut key conflicts with programs that use that key to launch – e.g., Ctrl+Shift+K in Scrivener is a split shortcut, and I use that to launch KeePass – and I’ve been able to remap Scrivener to eliminate the conflict.

But there’s one case where it’s not working as expected.

I am currently using Ctrl+Shift+P to launch a clipboard utility. In Scrivener, that is the shortcut for Page Setup.

I have deleted that key combo from the Page Setup command, but for some reason I’m still unable to use Ctrl+Shift+P call up the utility. And even after assigning a totally new shortcut key to Page Setup, I’m still unable to use Ctrl+Shift+P as expected, though it still works from outside Scrivener.

It’s as though Scrivener is somehow holding on to that key combination even though it’s been unattached from any command – yet I had no problem doing this with Ctrl+Shift+K.

I’ve tried fully exiting Scrivener, but that didn’t make any difference.

Any ideas why this might be?


As a test, are you able to change the shortcut for the clipboard utility and get that to work from within Scrivener? If you’ve cleared the shortcut from all of Scrivener’s menu commands and it’s still lingering, you could try resetting the shortcuts by choosing “Scrivener” from the “Import…” menu in the Keyboard shortcuts options. (You may want to save your current settings first, so you can reload them if the reset doesn’t fix it. You can either save all the preference settings and reload those, via the Manage button menu, or you can export the shortcut settings and then re-import them.) After resetting the shortcuts, you’ll need to again remove the Ctrl+Shift+P shortcut from Page Settings, as well as any of the others you had to change. Try closing and restarting Scrivener again as well and then see if you can use the shortcut for your other program.

I tried to emulate this briefly using AutoHotKey and assigning Ctrl+Shift+P to launch another program, but that overrode Scrivener’s shortcuts entirely, so there was no issue. Hopefully restarting and refreshing the shortcuts will clear this up for you.

Hi MM. Thanks for the reply.

I thought I had tested this before posting my question, though I’m apparently mistaken.

It seems that there is something about the combination of Scrivener and my clipboard utility (Clipboard History, by Outertech) that is preventing the latter from being invoked when the Scrivener has the focus.

I’ve changed the hot keys for Clipboard History to something that Scrivener doesn’t use, and it still can’t be called up. Seems kind of odd, but it seems to be an issue with Clipboard history, since other applications can be hot-keyed from within Scrivener (including Linkman, another Outertech app.)

So I guess I’ll ask Outertech about it (Clipboard History is a small but really useful freebie that I’ve become shamelessly dependent on.)

Thanks again!

hmm… this is interesting…

I just downloaded Scapple (I seem to be joining the L&L family) and the first thing I did was try to paste a note into it from my clipboard manager. And just as with Scrivener, it and Scapple are unable to communicate with each other.

How weird.

It still seems like it’s more of a problem with the Clipboard History app than with the two L&L apps, yet those are the only two that I’ve experienced this with in about 3 years of regular use of CH.

And the problem isn’t really a shortcut or hotkey problem as I initially thought, because even when I call up CH via mouse from its tray icon and select a clipboard item to be pasted, it doesn’t paste into either of the L&L apps. So the hotkey not working is just a symptom of, and is only incidental to, some larger problem.

So there’s something that Scrivener and Scapple have in common, but that (most) other apps don’t, that is negatively interacting with, or preventing interaction with, Clipboard History.

Scapple and Scrivener are both built using the Qt framework, so likely that’s the cause of the conflict with passing the clipboard info. I’ll dig around a little to see if there are any reports filed about this particular problem with Clipboard History and other Qt programs.


I was going to write to Outertech and tell them about what I was experiencing. They’d be interested, even though CH is a freebie. Now I have a clue I can share with him about Qt (which I never heard of before just now, and even after wikiing it, I’m still pretty much in the dark. :unamused: )


I’m wondering if I’m having the same or a similar problem. I thought I was having a global problem with my keyboard, but I’ve come to the conclusion that the issue only happens with Scrivener. Since it’s only happened in the last few months, maybe it’s tied to an update. I’m using Windows version - 31 October 2013. I used this keyboard, Scrivener and this computer to write my last novel with no problems, so maybe it’s something that changed in the latest version.

Anyway, the situation is that I’ll be happily typing in my novel and then it’s like a key gets stuck, e.g. the Alt key. So then everything starts trying to open windows and other very strange behavior. The problem affects every program, so after the problem starts, it’s not limited to Scrivener. The only thing I can do is shut down the computer.

Like I said, I initially thought it might be my keyboard. I use an IBM Model M, which admittedly is old, but I’ve never had problems with it. Now I’ve cleaned it out and replaced the USB to PS2 connector.

Is there a way to completely disable the keyboard shortcuts in Scrivener? Maybe I could narrow down the problem that way.


  • Susan

Hi Susan.

Your problem sounds not exactly like mine, but in the same general category.

FWIW, I just posted about another shortcut key problem that also bears some family resemblance to the two others.

Keyboard issues are so frustrating! Here’s to us both getting them sorted out.

It looks like you resolved your other shortcut key issue.

I reset the shortcut keys. I never changed any, so I’m not sure it will make a difference. But I did notice in some of the update notices that Scrivener suggests you reset them.

We’ll see. I didn’t work much on my book yesterday. Since the problem is intermittent, you never know when it’s going to happen, which is frustrating.

  • Susan

Hi MM.

Just reviving this old thread, as I finally looked into the problem (I’ve been so enjoying using Scrivener, that I let it slide.)

Quick refresher: The problem was that I have a clipboard history utility that can be invoked by a hotkey, and which works consistently in every other app I’ve used it in, but that consistently does not work in both Scrivener and (I later discovered) Scapple. After ruling out a hotkey conflict (which was originally suspected, hence the subject of this thread), that led to this first clue.

I finally wrote to the developer of the Clipboard History utility ( and asked about it, including the possibility that it was somehow related to Qt, and that another app I use by them (Linkman) has no problems with Scrivener and Scapple.

His reply:

I just verified this, installing and using Pidgin, and successfully calling up the Clipboard History program.

So I’m wondering if you or anyone else might have any other ideas?

Having a deep clipboard history, with a large number of presets, is really useful and I’d like to get it working in Scriv (which at this point is my main writing app.) There are alternatives to this particular utility out there, but CH is lightweight and straightforward (and familiar) so I"d like to stick with it, if possible.

FWIW (which I imagine isn’t much), I am able to use Clipboard History from within Scrivener when the focus is on a regular Windows dialog, but I realize that’s just consistent with it working in programs other than these two from L&L.

(I’m tempted to see if I can get AutoHotKey to invoke CH from inside S, let me select the saved text that I want, then return me to S. I suspect it’s possible, but it’s a temptation I’ll resist for now. :unamused: )


My shortcut key conflict hasn’t gone away either. However, I have determined that it is definitely just a Scrivener problem.

I’m not sure, but it seems to be related to the Ctrl key. For example, if i use Ctrl+ right or left arrow to move around in a sentence, sometimes, badness happens and it locks up my system. Unfortunately, it doesn’t just mess up Scrivener, it messes up the use of the keyboard for the entire computer, so the only solution to the problem is to use the mouse and reboot.

The only other program I have open is Chrome. Is it possible that there’s a Scrivener/Chrome conflict? I never use keyboard shortcuts in Chrome either.

I still wonder if there’s a way to disable all keyboard shortcuts in Scrivener or if anyone else has had this type of problem.



Because so many writers use Scrivener and so many writers also use IBM Model M keyboards, I thought I’d check back and see if anyone else has run into the keyboard lock up problem I’m having.

I can’t really replicate it, but it seems like it happens mostly if there’s a Shift key or Ctrl key combination that I hit wrong. The keyboard stops working. I can’t type any characters and it behaves like the Ctrl key is held down permanently. The only thing I can do is reboot the computer.

Needless to say this really interrupts my writing flow :confused:

Has any type of key conflict been reported? I’ve tried disabling pretty much all keyboard shortcuts in Scrivener, but I don’t know that it did much good.



Hi Susan.

Sorry you’re still having that same issue. (I am too, but yours sounds like real showstopper.) I occasionally get a stuck Ctrl key, but I’m able to unstick it pressing it a time or two, and I can’t say if it’s only in Scrivener. I’ve been assuming it’s a mechanical thing with my old notebook’s keyboard.

I can’t speak to what has been reported. But right from the start of my Scrivener adventure I’ve regularly found its keyboard implementations can be (shall we say) problematic. This thread was one of my first posts here. Sometimes, as above, the issue is a function of the Qt framework. More often, it seems due to the keyboard layer of the UI suffering from a bias towards mouse and trackpad operation that results in a kind of keyboard blindness.

One interesting consequence of this is the way it makes me more prone to user error (and outright dumb mistakes) because operational inconsistencies sprinkle the learning curve with uncertainty.

Scrivener is a brilliant program that I’ve enthusiastically allowed to colonize my writing life, but it’s a bit of a hot mess from a keyboard UI pov.

Are you by any chance using Ctrl+Shift along with either the Alt or/and the Win key? Those larger combination sometimes seem to act oddly in Scriv. I’ve mostly avoided them.

Hope you figure it out.

I’ve been meaning to post here that I’ve discovered another program that behaves the same way as Scrivener re: my OP. When I looked into it, it turned out that it too is built with the Qt framework.

YouTube To MP3 Converter

It’s devs have an About Qt item on their main menu.

In fairness to Qt, I know of one other that, last I checked, didn’t have any similar problems.