Shortcut problem

A recurrence of an old problem, and I can’t remember if there’s a solution.

I’ve set up a shortcut - cmd-ctrl-S - for Show Invisibles, and another, cmd-ctrl-H for Hide Invisibles. (I use these for searching for repeat carriage returns.)

But the shortcut doesn’t work unless I first - in each session - go to Help and find Show Invisibles and Hide Invisibles.

Is there a solution?

I am not sure if this is the reason why it isn’t working properly, but there is something you can do that makes these toggle style menus easier to work with: assign the same key combination to both menu commands, “Hide Invisibles” and “Show Invisibles”. Since only one of these commands exists at at time, they do not conflict with each other. Press Ctrl-Cmd-S once, invisible characters are shown and the menu becomes “Hide Invisibles”, which the system picks up and applies the Ctrl-Cmd-S shortcut to, and round and round it goes.

When I tried that technique I did not have to reference the menu first for it to work. That behaviour is something that can happen by the way, it’s a quirk in how menus are built, and how the shortcut system only attaches to existing menus—you usually only see it menus that are dynamically built on the fly, like Format/Lists, but I have seen it happen to some toggle-style menu commands as well, notably in the Format/Revision Mode sub-menu. There are a number of commands there that you can’t see without selecting text or having revision modes enabled first, and I’ve found that until I look at that menu with them active, the shortcuts don’t “take”. They seem fine for the session once I do though.

Hm. Thanks! Does this mean I only set one shortcut, for, say, Show Invisibles, or that I set one for Show and one for Hide, but the same keystrokes for both?

Ah, s’ok. I set the same shortcut for the two, and it works like a dream. Thanks so much, AmberV - as always, you found the perfect solution.

You’re welcome!