Shortcuts doesn't work when using hebrew? + question about binder

Hello!
I’m using Scrivener for a few years and just upgraded to the new version 3.

I caught a bug: when I use my native language to type - the shortcuts for bold/underline etc just won’t work. they only work when I use English. that’s very unfortunate since this is working perfectly on the older version of scrivener. another issue:

I’ve noticed that the only way to move the binder to the right side is by choosing Hebrew as the main language (which changes the entire interface’s language - something I don’t want).
is there a way to move the binder right and leave the menu language as english? same thing: the older version doesn’t have this problem (when I choose “system language” - the menu stays in English but the binder moves right).

are those bugs that cannot be fixed, or am I missing something? thanks in advance <3

Hello Shay,

Welcome to the forum. I tested the keyboard shortcuts on Scrivener 3 for Windows using the Hebrew dictionary and a sample of Hebrew text, and found bold, italic and underline all worked seamlessly on my machine. The first troubleshooting step is to make sure you are using the most up to date version of Scrivener 3 for Windows, 3.1.1.0. Then try changing your font and see if that resolves the issue. If it does not, try downloading a new dictionary by going to File ▸ Options ▸ Corrections ▸ Spelling. Click on the “Download…” button and download a new dictionary. Then click on “Select” and select it. Test to see if that works.

I’m afraid it is not possible to place the Binder on the right-hand side when using left-to-right languages. If you are writing predominantly in English and want to simulate the effect of having a binder on the right hand side you could split your screen vertically with the right hand split narrowed to the same width as the binder and in outliner view:

  1. First, do a vertical split of the editor.
  2. Place your Manuscript folder in the right-hand split, choose outline mode, and then deselect most of the columns leaving only the titles and the synopses if you need them.
  3. Hover your cursor between the two splits till you see a double arrow and reduce the width of the right-hand split.
  4. Click on the Manuscript folder’s icon in the editor’s header and select “Lock in place” so that the documents you select in that split don’t automatically display in the left split.

Now you can hide your regular binder and the inspector menu if you want.

If you want to switch to a different top level folder like “Research” you will have to Uncheck “Lock in Place” for your Manuscript folder, unhide the regular binder, choose a different top level folder and lock the right-hand split in place again.

Hi, so I also have this bug in Hebrew.
The shortcuts only work when my keyboard is set to English. So, for example, if I want to search something I have to switch to English, click the shortcut (ctrl+f), then switch back to Hebrew again to enter the phrase to search. It is the same with all the keyboard shortcuts - they don’t work when the keyboard is set to Hebrew, and it’s really annoying to always need to switch between English and Hebrew - it make the shortcuts very long.
By the way, I’m using version 3.1.4.0 for Windows, but it had happened in previous versions as well.

Hello galawriter,

Welcome to the forum. I was able to replicate your problem by installing a Hebrew keyboard at the Windows system level. When switching from English keyboard to Hebrew keyboard in the Windows status bar some keyboard shortcuts worked in Scrivener but others didn’t. I had the same problem when testing in Notepad and Google Docs.

If you can only type in Hebrew if your system level keyboard is set to Hebrew, and the shortcuts don’t work with that keyboard, you can switch quickly between Hebrew and English keyboards using the system level keyboard shortcut: Windows Key+Space.