Shortcuts for adding comment and footnote don’t work

Hello !

I use Scrivener iOS a lot since few days and today I tried to improve my writing process by adding comments while writing my scene. I love when everything is available with a few keys and use shortcuts A LOT.
My problem is the shortcut for the comments and footnote (⇧ ⌘ 8 and ^ ⌘ 8 ) don’t work. I can use the buttons in the extended row, and that’s what I do for now but I’d like to know if I can get these shortcuts work, especially the comment one !

Thanks a lot, I’m sorry for my bad English because French is my first language.

Cheers !

Maybe I can tell you what is my stuff… :unamused:
iPad Pro 10,5" and Magic Keyboard !

I have the iPad Pro 10.5, using the Apple Smart Keyboard.

I think what’s happening is that you have to have some text selected first – once you’ve done that, then those keyboard shortcuts become available (you can see them when you hold down the command key). If you don’t have any text selected, then the shortcuts don’t work (and don’t appear when you hold down the cmd key.

At least, that’s what happens for me…

Thanks for your answer.
I select some text, and I can see the shortcut when I press the ⌘ key ! The icon associated with the insertion of a comment works perfectly.
The only problem is the keyboard shortcut :frowning:
Does it work with you ? ⇧ ⌘ 8 ?

Yes, all four shortcuts work properly when text is selected (i.e. cmd-shift-8 and ctl-shift-8 for inspector comments/footnotes and cmd-shift-a and Ctl-opt-f for inline annotations/footnotes).

I don’t know what to do … =(

I presume your Magic Keyboard is a French keyboard (AZERTY or something like that)? Perhaps the code assigned to those key combinations is different from the code on the English keyboard. On shift-8, the English gives *

I would start by trying Cmd-* and Ctrl-* however you would do that on your keyboard.


Thank you for your answer, I think you’re right, and this shortcut isn’t implemented with French keyboard. I tried many combinations including the one you told me, and it didn’t work at all !

Dear all,

I’m having the same problem with the footnote shortcut.
Moreover I can’t find the way to change the shortcuts.
Have any of you found a solution to this problem?

MacOS High Sierra - 10.13.12
french - France keyboard (AZERTY)
Scrivener in French

Thanks a lot