Shortcuts greyed out

The shortcuts in the Scrivener menu are greyed out, and don’t work, though the menu commands do work. At least, the ones for Copy Formatting and Paste Formatting, which I use a lot, don’t. Is there a fix for this?
(By the way, I don’t seem to be able to open the questions under “Your topic is similar to…”)

No answers? It would be good to find a solution for this.

It’s generally a good idea to try reinstalling the software if something like this happens. Shortcuts are a mechanism provided by the OS, so if those aren’t working across the board, that’s not normal behaviour and probably not something Scrivener has anything to do with directly (at least in the sense of there being some kind of bug in its code).

As for them being grey, that may just be Apple’s weird design decision in the latest macOS version. They are printing lots of stuff in a lighter grey that makes stuff look disabled when it isn’t. There isn’t anything that would specifically grey out a shortcut independent from the command title, nor any condition where the shortcut would be disabled but not the command.

Thanks, Amber. For the “copy style”/“paste style”, the menu works but the shortcuts don’t. How do I reinstal the software? Trash the one in Applications and go and re-download it and hope it recognises my licence?

Here’s what the Format menu looks like… damn, I get a message saying “Sorry, you can’t embed media items in a post” - there seems to be no way to add the file in the Reply function.
I really don’t like this new Forum style.

It doesn’t have much to do with the forum style, it’s that it doesn’t allow brand new accounts to post images (it’s a form of spam protection). One can get past that new-account level rather easily, but if you only log in to check this one thread it needs a little more from you than that. At any rate, I’ve bumped your level so you can post images now.

For the “copy style”/“paste style”, the menu works but the shortcuts don’t. How do I reinstal the software? Trash the one in Applications and go and re-download it and hope it recognises my licence?

What about other shortcuts? Can you toggle the binder on and off with ⌥⌘B for example?

As for reinstalling, yup, that’s all you have to do. The registration info has nothing to do with the software itself. You are registered even if you don’t have the software installed, in other words.

Yes, the Binder toggle works, despite being greyed out in the menu. Thanks for upgrading my “new” status, Amber



!

Ah, weird! The shortcuts suddenly started working!

Yeah, that screenshot is showing how Apple wants shortcuts to look now: disabled. :slight_smile: But they shouldn’t be, unless the label to the left is the same shade of grey.

Very weird that they should suddenly start working! But weird or not I don’t mind!

Ya! Don’t know what happened there. Do you use any kind of background utilities for handling shortcuts, or anything of that nature? I’ve sometimes had shortcuts break, when using tools like BetterTouchTool (which also allows for keyboard shortcut customisation). In cases like that if I restart that utility the problem tends to go away. I’d check for updates for that software if it is happening frequently.

Yes! I use TextExpander, which can go very hinky after a few hours; the only solution is to start the computer when it starts putting spaces, commas, etc behind words or phrases that it’s expanded, or mixing up the letters. And I’ve got the latest version and have had long hopeful correspondences with the makers.