Shortcuts problem under Catalina & 3.1.4 version

I have updated to Catalina and to Scrivener 3.1.4, but shortcuts (cmd-i, cmd-b, …) still does not work.

As this generally works, you should try a few basic troubleshooting steps:

  1. Reinstall the software from a fresh download.
  2. Reset preferences.

Also verify that you’re using a good font for this kind of testing. Lucida Grande, for example, would lead you to believe the Italic command doesn’t work, when in fact it is working precisely as it should be since there is no such thing as Lucida Italic.

Thank you for you reply

I reinstall the software and reset preferences.

If I use Courier New, italic or bold shortcuts (cmd-i …) does not work. But I can write in italic or bold if i use the toolbar, with the pointer. Shortcuts like cmd-c comd-v or cmd-, works well.

Just in case I tried a all new project, but no italic with Courier New with shortcuts.

But, if i use Palatino, the shortcuts works well (but I prefer to work with Courier New)

Sorry for my very bad english, I hope you understand me correctly.

About my last post, I specify that if I use Courier New in Textedit, shortcuts for italic or bold, it works correctly.

Very strange, I just cannot get this to happen on my system, even using Courier New to follow along. I can use all four types of Courier (bold, italic, regular and bold+italic) from the keyboard alone.

You are right, TextEdit works fine. The bug itself makes no sense. We were doing things correctly according to the documentation. But they changed something without explaining it, and now that method does not work at all. So we switched to using another method in 3.1.4 that we should not have to use. It seems to work for most people (us included), but not everyone.

I wonder if localisation matters? What language do you have your Mac set to, and is Scrivener translated?

All my environment is in french.

Great, thanks to both of you! That was the “hidden” ingredient that makes this happen. I tried setting my system to Portuguese, launched Scrivener, and now I cannot make italic Courier New text, just like you describe.

We’ll have to take another look at this one.

Yes, I’m in french too.

I noticed that (in Courier New) CMD-U works.

And I noticed that when something is in italic (Courier New), then cmd-b works with this thing in italic. (Am I clear?)

Great, Thanks Amber.

It depends on the font, what works or does not. Sometimes you can make something bold by first italicising it, or vice versa. It is probably easier to just click the button for now though.

Underline is something else entirely. It does not change the font itself, it is more like adding colour to it, or changing its size. This bug has to do with how the shortcuts automatically select different related fonts from a family of fonts.

Thanks for your precisions.
I forgot to say, I dont know if it helps, but when I cmd-i, I hard the unpleasant sound system, that said you did something wrong.


I changed parameters in System Preferences, in "Language and Region " . I put Scrivener Apps in English.

And now, shortcuts works.

I’m not sure about the names of the menus (language and Region) because my environment is in french.

So Amber, you were right about localisation. It seems the cause of the trouble.

Thanks for checking that out, it will be fixed in the next update.

I’m having the same issues, not being able to use shortcut keys to change fonts. I’ve set my language to English, but that didn’t make a change.

I’have this message when I try to update.
My Scrivener does not run on a volum or disk image or optical drive. The application is in Applications folder. I relaunch 14 times.
I wonder more and more when I will be able to use CMD-I or CMD-B, besause it is very usful with a keyboard.

Thanks you a lot. but When the next update will be released ?

L&L does not provide timeframes any longer.

Hi, thanks, but I’have this message when I try to update, so I dont even know if there is an update.

Update Error!
Scrivener can’t be updated when it’s running from a read-only volume like a disk image or an optical drive. Move Scrivener to Applications folder using Finder, relaunch it from there, and try again.

Erreur pendant la mise à jour!
Scrivener ne peut pas être mis à jour quand il fonctionne à partir d’un volume en lecture seule, comme une image disque ou un lecteur optique. Déplacez Scrivener dans votre dossier Applications, relancez-le à partir de là et réessayez.

My Scrivener does not run on a volum or disk image or optical drive. The application is in Applications folder. I relaunch 14 times.

I’m not sure if it would require setting your whole system to English or just Scrivener, so you might experiment with that.

There isn’t an update out that would fix this yet, but for future reference, if the automatic updater doesn’t work for whatever reason, just download the latest version from the website. The auto-update is purely for convenience, so there is no sense in trying to make it work because after one failure it is more convenient to download.

Ok, thank you, I’ll wait next update with Menlo.