<Show last document viewd> sometimes wrong[NOTED]

The button (in the editor) does not always work correctly. Sometimes this function insists on taking me to a document in the trash, instead of to the last document I viewed. After I have emptied my trash it work correctly again.

Joost, The Netherlands
Scrivener 1.03 for Windows

I haven’t ever noticed anything like this myself. Of course once you did view that item in the trash it became part of the permanent history record, so it would eventually keep returning to it until it was removed. If you feel that your history record is glitchy though, I would recommend clearing it. Use the View/Editor/Clear Document History command to do so. You’ll need to run that in both splits as they each retain their own history record. Speaking of which, maybe that is the source of the confusion? Since each split has its own record, one might be accessing something from a long time ago whereas the other split has a newer record.

Thanks. If it happens again I will report it here. I never use the split screen though. And I am certain that the behavior I described was abnormal. But I can not reproduce it, so I will stay alert.

Apart from this, lots of compliments to the makers of Scrivener.


I am still convinced something is wrong here. Sometimes the button takes me up one level (to a folder) instead of to the actual last document viewed. Sometimes it insists on taking me to a document in the trash, even if this was not the last document I viewed.

I cannot find the method to the madness, and I am not able (yet) to give a set of steps to reproduce the problem.

I am using Windows 7, with all the fixes and updates. Am I the only user to encounter this problem?

Regards, Joost

No, you’re not alone. I’ve had problems with last viewed. In my case, I think it’s something to do with the scrivenings view mode–at least, that’s when it’s the buggiest. If I’m viewing the entire draft as scrivenings, and am scrolled down to say chapter 3, then I switch to chapter 7, and try to “show last” to go back to my place in chapter 3, it takes me to someplace random.

I get this problem too. I’ve been waiting to see if I can see a pattern, but aside from noting that I usually work in two windows, one with cards and the other with text, I can’t offer much help. Sometimes the back button takes me to pages that I haven’t been to for ages.

I think I managed to get something like this to happen myself, after poking around a bunch. Unfortunately I could find no pattern either. I thought it might have to do with multiple selections in the history stack, because initially that was what got skipped over, but after clearing history and trying a sequence again it worked.

Yep, after clearing history it works for me ok for a while. And then some time later I’m taken somewhere random again.

I got this, too, in the past. That’s the reason why I stopped using this button. Now I cleared my history and will observe if it happens again (and I will try to remember using the button at all :wink: ).

It’s still a mystery what causes this problem. First I thought it had something to do with whether a page was actually edited, but it turns out this is not the explanation. Another thought: could it have something to do with wether a page or folder is moved to another location in the binder? I move around pages and folders a lot. I really hope the boys and girls of L&L find the sollution and come up with a fix.


Happens to me quite often as well. It just happened then. I went from one document to one in another folder, and then when I tried to go back it took me to the Manuscript folder instead of the subdocument of that which i was looking at previously. strange! I clicked on a few other documents after that and then tried the back button and it worked correctly. Sorry that’s not very useful, if it happens again I’ll see if I can find a pattern.

Can anyone else confirm if the beta fixes this? It seems to be more stable to me.

In a similar vein, I often notice that when I use split screen for a while with one of the screens locked, then close Scrivener and reopen, I’m on an entirely different document (not one of the two that was open before).

I’m not sure how it’s randomly picking what document to open on when I reboot Scrivener, but it’s kind of bizarre. Doesn’t really bother me too much, but I just thought I’d mention it here, as I couldn’t find anywhere else where anything similar has been mentioned. Thanks!

I have not been able to replicate this. If anybody has any luck with reliably reproducing a step by step scenario that clearly highlights this issue then please email me directly and I will address it immediately. However, I’m struggling to find any issue here.
Lee AT literatureandlatte DOT com