Smart Quotes are on, so why did I get a plain double quote?

I have a regex to search for unclosed double quotes… it found this, so I added a double quote.

As you can see, it came out plain. I was pretty sure this had been happening from time to time, without me noticing, because I keep finding plain double(/?single) quotes and couldn’t understand where they were coming from.

If I then backspace to remove the plain quote, and retype, it comes out “smart”

Anyone know why this is happening and how to stop it?

PS the options look like this


I can’t see any difference between items 1, 2 & 7 , and item 3 looks as though only the opening quote is “smart”. I have always used item 1 and it’s been fine :slight_smile: Manual V3.1.0, B6 doesn’t describe the various options. What are they?

Do you have a third-party app like Grammarly running in Scrivener? On the odd occasion it adds a quote, it’s normally does so as a straight quote. Alternatively, did your RegEx add the quote? It may have the same effect, since it sneaks it in under the radar, as opposed to what normal typing would. The other bugger is pasting from elsewhere, which is source dependant.
Use Ctrl+Q and it converts all straight quotes to smart quotes. It works across documents in Scrivening Mode on Windows too, which is a surprise.
Choose the different options for your editor and you’ll see the differences–some particularly quirky, like closing quotes for opening quotes.
What you call 1 is actually the highlighted 4th item down.

No, Scrivener is vanilla, and the quote was added by typing, so the add, and re-add (after backspace delete) were identical methods.

That shouldn’t be necessary; the differences should be visible. But, yes, 1 → 4, though as you can see, visually indistinguishable from the first item on the list, hence my error (just because an item is highlighted in a drop down doesn’t mean it is the current selection, see e.g. the style drop down.

So, no explanation for the defective " so far.

Next caller, please. :wink: