Smart Quotes in Scrivener 2.3.1 for Mac broken after update?

Hi. I’ve noticed that my Smart Quotes no longer work after the recent Scrivener update. I’m running 2.3.1 and the smart quote feature no longer seems to work. I’ve checked my settings (Preferences > Corrections) and the “Use smart quotes” tick box is definitely ticked. Yet each time I try and type an apostrophe or quotation mark I get the old inch and foot marks (straight quotes). It was working fine before the update. I know that I can go back and use the Format > Convert > Quotes to Smart Quotes feature, but this adds an additional step. Has something happened? Am I missing something? Many thanks!

They’re working for me on 2.3.1.

Sorry, got nothing to suggest as a solution…

This might be a little out there, but it’s worth double-checking what the system is using as smart quotes. You can see this in the “Text” pane of the Language & Text system preferences. It’s possible for this to be set so that smart quotes just produces straight quotes.

Nope, that was one of the first things I checked. The overall system (Text pane in the Language & Text system preferences) is properly set for smart quotes. So i’m a bit baffled by this behaviour when i’ve got everything set properly. I also didn’t change any settings when i upgraded to 2.3.1. I’m still getting the inch and foot mark instead of smart quotes even though everything is set properly. Hmmmmm…

Just checking something: do you get the same problem in TextEdit (which uses the same text engine as Scrivener)?

Hi brookter, Just got your message and just checked in TextEdit, and the answer is yes! When i type quotes i don’t get the smart quotes. So you’re on to something. What’s the solution?
Many thanks!

Hi again, I think I just figured it out, based on your asking me to check in TextEdit. I checked my TextEdit preferences and saw that “smart quotes” were not ticked, so i ticked smart quotes on again. (BTW: I rarely use TextEdit). Nothing happened. So i quit TextEdit, then opened it up again, and smart quotes were working in TextEdit. Then i switched back to Scrivener hoping that smart quotes would work again, but they didn’t. So i quit Scrivener, then opened it and smart quotes works again! So many thanks for helping me solve the problem. But what caused the issue? I think the last time i opened up TextEdit was months ago, and i’ve never opened up its preferences pane before, so how could it have been changed? It’s baffling, but even if i never figure out what happened, i’m really glad that you’ve heped me solve the problem! :smiley:
many many thanks brookter!

I’ve absolutely no idea what caused the problem: I’m only someone who reads the forum and have little technical expertise myself. I know that Scrivener uses the Apple text engine and that when something like this happens people often suggest seeing whether it’s also a problem in TextEdit, to see whether it’s a Scrivener problem or a more general one… I just nipped in first with the suggestion this time… :smiley:

Glad it worked, though!