Smart Quotes not working

I’m using Scrivener 2.5 (25239) and OS X 10.9.1. Both the system preferences and the Scrivener preferences have “use smart quotes” checked. Smart quotes work fine in other programs. Smart quotes work fine even in new Scrivener projects. It’s only in the one project that I’m having this problem, ergo I’m fairly sure the issue lies in project settings somewhere—but I can’t find where.

I’ve uploaded a screen shot of my corrections preferences. The only message I have in the log file (in the support folder) appears unrelated, but I’m including it anyway: 2014-02-16 08:57:57.288 Scrivener[11062:707] 10.4-style NSDateFormatter method called on a 10.0-style formatter, which doesn’t work. Break on _NSDateFormatter_Log_New_Methods_On_Old_Formatters to debug. This message will only be logged once.

If it is just one project that is consistently giving you troubles, it may actually be some of the files in that project that are set up wrong. There isn’t an overall project setting for disabling corrections, those are just universally on or off. However as you can see in the Corrections pane, there is a setting just below the various options that reads, “Disable smart quotes, em-dashes and ellipses in script mode”. So, with that in mind, do the icons in this particular project have a yellow-ish tint to them, with a 3-hole punch down the side? If so they are script documents and just following the rules and disabling typographic punctuation. You can easily toggle scripting mode with Cmd-8 on a per-document basis.

If that is not the problem, then it could be the project is triggering an OS X bug that has been around since the summer of last year. They released an update that caused spell check and corrections to fail periodically. We’re still tracking down exactly what is causing it, or even if it is something we can fix at all (a number of people facing the problem have reported spell check while typing can fail in other programs too; so it could just be overall a bit flaky now). A number of people have had success avoiding Page View mode, however. Maybe if that one project has Page View enabled, try turning it off.

Hiding page view fixed it for now.

“If that is not the problem, then it could be the project is triggering an OS X bug that has been around since the summer of last year.”

I continue to have inconsistent performance of smart quotes in Scrivener. It’s disappointing, for sure. I must use page mode for my work style, so if you can keep us updated, it would be great. It’s been a while that this problem has been around.

I just started having this problem as well. Smart quotes were working fine in page mode in this one project, but today they’re suddenly not working, regardless of whether or not I’m working in page view.

What really helps us find these sorts of problems is not just hearing when you have them, but what it takes to make them happen. We know Page View can make it worse, but we also know it doesn’t require Page View to happen. We’re pretty sure it requires 10.9 or 10.8, but it may also happen in 10.7, but never earlier. It usually happens sporadically in all Mac software on impacted systems, not just Scrivener. That’s it. That’s literally all we know about this bug. You can see why it there isn’t much we can do about it. :slight_smile: It is impossible to fix something if you don’t know where it is (and might be constrained to 10.8 and 10.9 is awfully vague). So if anyone has any sets of conditions, preference settings, system utilities, third-party tools, etc. that clearly impact the behaviour of this issue more than once, then please do relay them to us. Hopefully they will be enough to trigger the bug on a test system. Then we can at least know if it is something that can be fixed from our side. I’m not terribly hopeful of that, since the only thing that changed when this bug appeared was a multi-version OS udpate from Apple—but you never know.

Like many writers, I try to be observant of things around me, and also with the software I use. If I could be more specific about why smart quotes cease to work, I would be, but it is a sporadic issue. And the problem is not just a cosmetic one of presentation on the screen. When printing a document to paper, I’ve found straight quotes where I expected smart quotes to have been, so from my experience, what mode you choose to view the document in is not the issue. Information (the quotes style) is not correctly registering at a file level, it appears.

I use Scrivener version 2.5. (I’ve had this problem with the last official release of Scrivener as well.)
I run Mac OS X 10.9.3. (I’ve had this problem with the previous OS version as well.)
I use no third-party extensions.
I have smart quotes enabled in Scrivener.
I also have “Use Smart Quotes and Dashes” enabled in the Mac OS X System preferences. (Is the advice to have this on, or off, at this point. I don’t recall. I have it on.)

I was told this problem happens in another program that my wife uses, so it does appear to be a problem that was introduced by Apple at the OS level. I don’t blame Scrivener for the problem, but I think I’m surprised that it hasn’t been fixed in Scrivener, because of the Scrivener development team’s amazing track record. I can’t recall Scrivener having a long-standing bug (at least that affected such a main aspect of writing).

I could be wrong, but given my interaction with the bug, I doubt more specific information will be gleaned from users over this problem. So, if L&L is looking for more info to get this moving … dunno.

The next version of Mac OS X was announced today. Could the dev team test the problem with the new OS release, and if it’s fixed for “Yosemite” users, maybe learn how to reverse-engineer a solution for Scrivener users who are back on Mavericks and earlier. Just a thought.

Thanks for the additional information.

Well to be honest we may just go back to using our own smart quotes in the future since Apple’s have been so problematic over the years (they are kind of slow, too). I don’t know if that will be the case, but it has been discussed.

Indeed, that’s the problem. If it had an easy path to reproduction we probably would have figured out what was wrong by now, at least to say whether or not it could be fixed. We lean toward saying it cannot be, since literally everything here is Apple technology that we’re just passing through to the editor (which is also their code). That is why it is difficult for us to fix. The only hope that it can be fixed is that there is something Scrivener is doing that other Mac programs are not (which isn’t supported by the fact that the problem happens universally, even in Mail by the reports we’ve seen—but the fact that page view can make it worse is hopeful).

That type of scenario did in fact happen a few years ago—there was a similar problem and it turned out to be some newfangled thing in 10.7 that needed to be disabled. But, in general, when the total amount of code you are responsible for is a few lines, and entirely revolves around telling Apple to do this here with such and such options enabled, and it doesn’t enable those options as requested, then what can we do?

But yes, to recap why this is hard:

  • The text editor is Apple’s.
  • The text editor has many options, and one of them is to enable spell check while typing.
  • Another option is to insert typographic punctuation to replace standard keyboard forms.
  • We tell Apple to put a text editor here with these options on or off…
  • And it doesn’t always work. :slight_smile:

We’ll find out if they did anything in 10.10, but so far that looks more like an update to the client software and the skin. I didn’t see much in regards to the fundamental components of the OS (they don’t focus on that stuff in keynotes any longer though). We’ll have the seed soon though and will know more.

I closed and reopened the project where I had the issue and everything was back to normal. It’s also pretty sporadic for me, so it’s real difficult to say what it is that happens when the issue crops up.